SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Goseq for non-native goseq db annaprotasio Bioinformatics 12 03-31-2013 10:36 PM
GOseq errors egorleg RNA Sequencing 6 11-29-2012 01:09 PM
problems installing package goseq PFS Bioinformatics 2 05-29-2012 12:18 PM
GO analysis for Arabidopsis with Goseq melis Bioinformatics 1 01-19-2012 07:39 AM
downloading GOSeq R package issues RockChalkJayhawk Bioinformatics 6 06-30-2010 06:09 PM

Reply
 
Thread Tools
Old 03-23-2012, 10:30 PM   #1
ETHANol
Senior Member
 
Location: Western Australia

Join Date: Feb 2010
Posts: 308
Default GOSeq not finding database

I don't know what is going on here. GOSeq use to work fine for me. Now there seems to be some problem with finding the database. I think I've narrowed to problem down to the following code:

Code:
> library(goseq)
> GO.pvals=goseq(pwf,'hg19','ensGene')
Fetching GO annotations...
Error in library(paste(orgstring, "db", sep = "."), character.only = TRUE) : 
  there is no package called 'org.Hs.eg.db'
I'm running R version 2.13.2 and GOSeq version 1.4.0.

I have tried a few genome/gene ID combinations.

Any ideas would be greatly appreciated. Thanks.
__________________
--------------
Ethan
ETHANol is offline   Reply With Quote
Old 03-25-2012, 11:38 PM   #2
ETHANol
Senior Member
 
Location: Western Australia

Join Date: Feb 2010
Posts: 308
Default

Solved this one so I figured I would post the answer. I uninstalled R 2.14.2 and installed R 2.13.2 because the BSgenome package won't install in 2.14.2. It appears that goseq won't run in 2.13.2.

It's always nice when there are incompatibilities in the same work flow.
__________________
--------------
Ethan
ETHANol is offline   Reply With Quote
Old 05-11-2012, 11:27 AM   #3
ETHANol
Senior Member
 
Location: Western Australia

Join Date: Feb 2010
Posts: 308
Default

This issue has popped up again. I don't have any idea what is going on. Now it only happens when I am using the mm9 genome.

Code:
> library(goseq)
> GO.wall=goseq(pwf, "mm9", "geneSymbol")
Fetching GO annotations...
Error in library(paste(orgstring, "db", sep = "."), character.only = TRUE) : 
  there is no package called ‘org.Mm.eg.db’
It works when mm9 is replaced with hg19. Any ideas??

I am running R 2.14.2 and I can't seem to remember how to get the version of a R package but I believe it is the current version of goseq.
__________________
--------------
Ethan

Last edited by ETHANol; 05-11-2012 at 11:40 AM.
ETHANol is offline   Reply With Quote
Old 03-29-2013, 03:10 AM   #4
yjzhang913
Junior Member
 
Location: china

Join Date: Mar 2013
Posts: 3
Default

hi, you shoud install the package you needed.

To install this package, start R and enter:

source("http://bioconductor.org/biocLite.R")
biocLite("org.Hs.eg.db")
yjzhang913 is offline   Reply With Quote
Old 04-06-2018, 01:15 PM   #5
Nancy_Julia
Junior Member
 
Location: Bryan, TX

Join Date: Feb 2018
Posts: 2
Default

I tried to post a reply, but I think it disappeared. I too am having the same problem with that package, whether I use http or https. I need to work with mm9 for my assignment. I have installed the latest version of R and Rstudio. What more can I do?
Nancy_Julia is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 06:37 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO