SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samtools "is recognized as '*'" "truncated file" error axiom7 Bioinformatics 3 11-26-2014 02:53 AM
Trouble converting SAM to BAM, all 'chrM' recognized as '*'? SEQanswer Bioinformatics 6 09-16-2013 09:31 AM
tophat: option --read-gap-length not recognized? eric.yu Bioinformatics 5 08-01-2013 06:19 PM
[sam_read1] reference 'chrN.fa' is recognized as '*' ramirob Bioinformatics 1 03-25-2013 02:39 AM
TopHat: output is not recognized by UCSC geriatrics1200 RNA Sequencing 2 11-06-2009 10:13 AM

Reply
 
Thread Tools
Old 02-06-2014, 11:44 PM   #1
Coryza
Member
 
Location: Enschede

Join Date: Feb 2014
Posts: 29
Default 'bowtie2' is not recognized.

Hi all,

I'm currently trying to use bowtie2 to map our RNAseq data to the mRNA reference / chromosomes reference. Building indexes went ok, however when trying to use bowtie2 -p 1 -x [path to 6.bt indexes] [fastq file] > [sam file] it says 'bowtie2' is not recognized as an internal or external command, operable program or batch file.

I'm using the cmd on windows. Anyone who can help me out here?
Coryza is offline   Reply With Quote
Old 02-07-2014, 12:43 AM   #2
dpryan
Devon Ryan
 
Location: Freiburg, Germany

Join Date: Jul 2011
Posts: 3,480
Default

You might have to type the full PATH to bowtie2. As an aside, it's going to be a lot of hassle to deal with bioinformatics programs on windows (try to borrow someone's Mac).

Also, unless your organism doesn't have much splicing, you'll probably get better results using tophat2.
dpryan is offline   Reply With Quote
Old 02-07-2014, 01:29 AM   #3
Coryza
Member
 
Location: Enschede

Join Date: Feb 2014
Posts: 29
Default

Ah it worked now, doing bowtie2-align instead of bowtie2. Anyhow, I was trying to map 60 homo sapiens mRNA sequences against the indexed reference mRNA of the homo sapiens, and 100.00% aligned 0 times.

Is this normal? O_O
Coryza is offline   Reply With Quote
Old 02-07-2014, 01:38 AM   #4
dpryan
Devon Ryan
 
Location: Freiburg, Germany

Join Date: Jul 2011
Posts: 3,480
Default

Probably not, but I'd have to see the reads and know more about how they were generated to tell you for sure. Try using the "--local" option to see if that changes things. Also, did you quality/adapter trim your reads at all?
dpryan is offline   Reply With Quote
Old 02-07-2014, 01:58 AM   #5
Coryza
Member
 
Location: Enschede

Join Date: Feb 2014
Posts: 29
Default

Reads were generated with Illumina MiSeq 2 paired-end reading. Adapters & Barcodes were trimmed off.

I'm using command bowtie-align -x hg19 -1 [file1] -2 [file2] -S [output] -fr -q

Using extra parameter --local generates 92.50% aligned 0 times.
Coryza is offline   Reply With Quote
Old 02-07-2014, 02:49 AM   #6
dpryan
Devon Ryan
 
Location: Freiburg, Germany

Join Date: Jul 2011
Posts: 3,480
Default

You might try quality trimming things to see if that solves the problem. Alternatively, try blasting a few reads and see how they align. It may be that you simply need to change the defaults for bowtie (e.g., score-min).
dpryan is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 04:49 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO