SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
CummeRbund error steindorff Bioinformatics 6 07-30-2013 06:37 AM
CummeRbund error NRiddiford RNA Sequencing 5 07-26-2013 12:18 PM
cummeRbund error emolinari Bioinformatics 0 06-15-2013 11:41 AM
CummeRbund error newbietonextgen Bioinformatics 1 06-15-2012 12:24 PM
CummeRbund Volcanoplot error Him26 Bioinformatics 1 04-20-2012 11:50 AM

Reply
 
Thread Tools
Old 12-25-2013, 01:27 PM   #1
nancysky
Junior Member
 
Location: North Carolina

Join Date: Dec 2013
Posts: 2
Default Error in dispersionPlot using cummeRbund

Hi all,

I'm new to RNA-seq analysis. And I'm now trying to use R to visualize the Galaxy data. I'm using the cummeRbund to deal with the data from cuffdiff in Galaxy.

Here is the codes I've run:

> cuff= readCufflinks (dbFile = "output_database", geneFPKM = "gene_FPKM_tracking", geneDiff = "gene_differential_expression_testing", isoformFPKM = "transcript_FPKM_tracking",isoformDiff = "transcript_differential_expression_testing", TSSFPKM = "TSS_groups_FPKM_tracking", TSSDiff = "TSS_groups_differential_expression_testing", CDSFPKM = "CDS_FPKM_tracking", CDSExpDiff = "CDS_FPKM_differential_expression_testing", CDSDiff = "CDS_overloading_diffential_expression_testing", promoterFile = "promoters_differential_expression_testing", splicingFile = "splicing_differential_expression_testing", rebuild = T)

> cuff
CuffSet instance with:
2 samples
26 genes
44 isoforms
36 TSS
0 CDS
26 promoters
36 splicing
0 relCDS

> disp<-dispersionPlot(genes(cuff))
> disp
Error in `$<-.data.frame`(`*tmp*`, "SCALE_X", value = 1L) :
replacement has 1 rows, data has 0
In addition: Warning message:
In max(panels$ROW) : no non-missing arguments to max; returning -Inf


Does any one know why there's error? My cummeRbund is the latest version, R is 2.15.3, and cuffdiff v1.3.0.

I've tried to search the internet for solutions but apparently it's not a problem that people discussed much.

Thank you very much in advance!!!

Nancy
nancysky is offline   Reply With Quote
Old 07-22-2015, 06:49 AM   #2
USVTBIOC
Junior Member
 
Location: Vermont

Join Date: Jul 2015
Posts: 1
Default dispersion plot error

Hi Nancy,

Did you ever figure this out? I'm having the same problem.

Thanks
USVTBIOC is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 08:32 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO