SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
BLAST Database error: No alias or index file found for nucleotide database [nt] chris_s Bioinformatics 14 03-24-2019 07:11 AM
No alias file for nr database? bossanova352 Bioinformatics 18 01-23-2014 11:36 AM
Local BLAST no hits found PSchneeb Bioinformatics 6 04-18-2012 05:16 AM
BLAST database error - when changing to new BLAST+ local program biobio Bioinformatics 4 06-15-2011 05:20 AM
Local Blast Error of index file Shani Bioinformatics 0 02-12-2011 01:45 AM

Reply
 
Thread Tools
Old 03-08-2015, 08:48 PM   #1
hyates
Member
 
Location: Kansas City

Join Date: Jan 2014
Posts: 18
Default Doing local blast. No alias or index file found for nucleotide database?

I am attempting to do a local blast nt. I have implemented the following procedure:
  • update_blast.pl nt
  • tar zvpf nt.01.tar.gz command for each volume downloaded
  • ran a simple bash command (which fails)

The command I run is as follows:
Code:
blastn -query ~/programming/blastexamples/example2/db/even_tribolium.fasta -db ~/localblastdb -task blastn -html -out out.html
Quote:
blastn -query ~/programming/blastexamples/example2/db/even_tribolium.fasta -db ~/localblastdb -task blastn -html -out out.html
BLAST Database error: No alias or index file found for nucleotide database [/home/heath/localblastdb] in search path [/home/heath/programming/blastexamples/example2::]
Is the output given. At first, I thought this was because it could not read my the location of my local db. So I made sure I had appropriately extracted the tarball. I have.

Is there something wrong with my .fasta file? All I want to do is blast the local nt db against it and see what hits/matches I get. So I am quite confused as to why I am getting an error.
hyates is offline   Reply With Quote
Old 03-09-2015, 02:05 AM   #2
bt27uk
Junior Member
 
Location: Denmark

Join Date: Aug 2011
Posts: 7
Default

You haven't specified nt as the database you want to search in the command you gave. Assuming that your nt files are all in place and as they should be, and that they are located under ~/localblastdb, then try changing the -db part of the command to "-db ~/localblastdb/nt" and see if that helps.
bt27uk is offline   Reply With Quote
Old 03-09-2015, 04:22 AM   #3
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,978
Default

You have to provide "basename" of the database you are trying to search against (in your case nt) with the -db option. As bt27uk has already pointed out above, all nt* files need to be in the same directory.
GenoMax is offline   Reply With Quote
Reply

Tags
bash, blastn, fasta, ncbi

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 02:57 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO