SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
running soap denovo sweet_dna_girl Bioinformatics 6 07-30-2013 07:30 AM
SOAP denovo assembly results bioinfosm Bioinformatics 9 06-13-2012 08:22 AM
Rank In Soap denovo sivasubramani Introductions 1 08-31-2011 11:05 PM
SOAP denovo output to AFG format Autotroph Bioinformatics 0 02-21-2011 02:00 PM
Need help on soap denovo sundar De novo discovery 4 11-29-2010 04:03 AM

Reply
 
Thread Tools
Old 08-10-2011, 12:52 PM   #1
ians
Member
 
Location: St. Louis, MO

Join Date: Aug 2011
Posts: 53
Angry SOAP denovo seg faults during map

Hi all,
I'm getting a seg fault while running map during a SOAP denovo run. I'm running on OSX with SOAPdenovo v 1.05.
I have checked to be sure input data has reads larger than 30 bp and that no empty lines exist. Does anyone have any other debugging ideas?

Here is my cfg:

max_rd_len=70
[LIB]
rank=1
avg_ins=200
reverse_seq=0
asm_flags=3
q1=s_1_1.fastq
q2=s_1_2.fastq


Here's the map execution:

map -s soap.cfg -g test
K = 23
contig len cutoff: 25

there're 3424 contigs in file: test, max seq len 60625, min seq len 24, max name len 10
time spent on parse contigs file 0s
8 thread created
time spent on hash reads: 1s
4517379 nodes allocated, 5614229 kmer in reads, 5614229 kmer processed
time spent on De bruijn graph construction: 1s

time spent on mapping long reads: 0s

In file: soap.cfg, max seq len 70, max name len 256

8 thread created
5450 edges in graph
basicContigInfo: 2 vs 3
basicContigInfo: 3 vs 5
basicContigInfo: 5 vs 7
basicContigInfo: 7 vs 9
......
basicContigInfo: 4331 vs 5457
basicContigInfo: 4333 vs 5459
basicContigInfo: 4334 vs 5461
Segmentation fault
ians is offline   Reply With Quote
Old 08-11-2011, 07:51 AM   #2
ians
Member
 
Location: St. Louis, MO

Join Date: Aug 2011
Posts: 53
Default

I've been troubleshooting now by trying to divide and conquer. I've been halving the data set to see if i can get one to not seg fault. However, this strategy has really got me scratching my head. I can get the top 1st 1/4 and 2nd 1/4 to get past map. However, the top 1/2 fails. Also, when I concatenate the 1st and 2nd 1/4, it also fails (cmp shows this concat with the top 1/2 are identical).

Does anyone have ideas??
ians is offline   Reply With Quote
Reply

Tags
soapdenovo seg fault

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 12:09 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO