SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tophat - reporting only best hit given multi-reads/multi-maps. john_nl Bioinformatics 1 07-05-2012 12:15 PM
Tracks from ncrna.org Palgrave Bioinformatics 0 03-08-2012 11:09 AM
TopHat - Segment Join Failed fongchun Bioinformatics 1 05-16-2011 10:46 AM
TopHat Checking for Bowtie [Failed] ercfrtz Bioinformatics 1 03-14-2011 01:43 PM
TopHat+BWT = reads that failed to align ~ 99% repinementer Bioinformatics 6 09-28-2010 07:31 PM

Reply
 
Thread Tools
Old 09-02-2013, 06:40 AM   #21
middlemale
Member
 
Location: Oxford

Join Date: Feb 2010
Posts: 15
Default same problem

I faced the same problem with tophat 2.0.9 (bowtie 2.10.0) for my paired-end rna-seq data.

the size of each file is ~3.6GB, 51 bases, my hardware is 12 core x86 machine with 96GB memory and 64_bit debian.

If running tophat2 with --no-discordant, 'reporting output tracks [failed]' happened. it will generate "NORMAL" results without --no-discordant param, but how reliable these results are ?

Next I tried analysing 10,000 first lines of each file with --no-discordant param, it produced "NORMAL" results. odd.
middlemale is offline   Reply With Quote
Old 12-01-2013, 01:28 AM   #22
gs512
Junior Member
 
Location: world

Join Date: Oct 2012
Posts: 3
Default possible working solution

Hi everyone, I've been running in the same error while trying to resume tophat jobs.

So I took a look at the code and found that

the following line was not working :

bowtie_sam_header_filename = tmp_dir + idx_prefix.split('/')[-1]

because of the following error :

AttributeError: 'NoneType' object has no attribute 'split'

meaning that idx_prefix is not considered as a python string, so I edited the line as follow:

bowtie_sam_header_filename = tmp_dir + str(idx_prefix).split('/')[-1]

casting idx_prefix to string

and did the same modification for the line :

bwt_idx_name = bwt_idx_prefix.split('/')[-1]

editing it to

bwt_idx_name = str(bwt_idx_prefix).split('/')[-1]

The job seems to have resumed and is still running I'll give more updates at the end of the run

Let me know if that works for you too
gs512 is offline   Reply With Quote
Old 01-04-2014, 03:02 AM   #23
gs512
Junior Member
 
Location: world

Join Date: Oct 2012
Posts: 3
Default

The jobs resumed properly
gs512 is offline   Reply With Quote
Old 01-06-2014, 07:51 AM   #24
Parharn
Member
 
Location: Sweden

Join Date: Jul 2013
Posts: 84
Default

gs512 can you explain it for dummies? I have same problem here. Where should I make these changes?

Thanks
Parharn is offline   Reply With Quote
Old 01-06-2014, 07:53 AM   #25
Parharn
Member
 
Location: Sweden

Join Date: Jul 2013
Posts: 84
Default

The error I get is:




[email protected][pombe] tophat --no-discordant -p 8 -G genes.gtf -o tag1tag2_thout genome S0001_tag1_ATCACG_L004_R1_001.fastq S0001_tag2_CGATGT_L004_R1_001.fastq

[2014-01-06 17:28:50] Beginning TopHat run (v2.0.9)
-----------------------------------------------
[2014-01-06 17:28:50] Checking for Bowtie
Bowtie 2 not found, checking for older version..
Bowtie version: 1.0.0.0
[2014-01-06 17:28:50] Checking for Samtools
Samtools version: 0.1.19.0
[2014-01-06 17:28:50] Checking for Bowtie index files (genome)..
[2014-01-06 17:28:50] Checking for reference FASTA file
[2014-01-06 17:28:50] Generating SAM header for genome
format: fastq
quality scale: phred33 (default)
[2014-01-06 17:28:50] Reading known junctions from GTF file
[2014-01-06 17:28:51] Preparing reads

WARNING: read pairing issues detected (check prep_reads.log) !

left reads: min. length=50, max. length=50, 9844728 kept reads (2813 discarded)
right reads: min. length=50, max. length=50, 10021563 kept reads (3496 discarded)
[2014-01-06 17:31:34] Building transcriptome data files..
[2014-01-06 17:31:35] Building Bowtie index from genes.fa
[2014-01-06 17:31:52] Mapping left_kept_reads to transcriptome genes with Bowtie
[2014-01-06 17:35:48] Mapping right_kept_reads to transcriptome genes with Bowtie
[2014-01-06 17:39:51] Resuming TopHat pipeline with unmapped reads
[2014-01-06 17:39:52] Mapping left_kept_reads.m2g_um to genome genome with Bowtie
[2014-01-06 17:40:13] Mapping left_kept_reads.m2g_um_seg1 to genome genome with Bowtie (1/2)
[2014-01-06 17:40:21] Mapping left_kept_reads.m2g_um_seg2 to genome genome with Bowtie (2/2)
[2014-01-06 17:40:29] Mapping right_kept_reads.m2g_um to genome genome with Bowtie
[2014-01-06 17:40:47] Mapping right_kept_reads.m2g_um_seg1 to genome genome with Bowtie (1/2)
[2014-01-06 17:40:55] Mapping right_kept_reads.m2g_um_seg2 to genome genome with Bowtie (2/2)
[2014-01-06 17:41:03] Searching for junctions via segment mapping
Coverage-search algorithm is turned on, making this step very slow
Please try running TopHat again with the option (--no-coverage-search) if this step takes too much time or memory.
[2014-01-06 17:43:36] Retrieving sequences for splices
[2014-01-06 17:43:37] Indexing splices
[2014-01-06 17:43:41] Mapping left_kept_reads.m2g_um_seg1 to genome segment_juncs with Bowtie (1/2)
[2014-01-06 17:43:46] Mapping left_kept_reads.m2g_um_seg2 to genome segment_juncs with Bowtie (2/2)
[2014-01-06 17:43:51] Joining segment hits
[2014-01-06 17:43:57] Mapping right_kept_reads.m2g_um_seg1 to genome segment_juncs with Bowtie (1/2)
[2014-01-06 17:44:02] Mapping right_kept_reads.m2g_um_seg2 to genome segment_juncs with Bowtie (2/2)
[2014-01-06 17:44:09] Joining segment hits
[2014-01-06 17:44:14] Reporting output tracks
[FAILED]
Error running /usr/bin/tophat_reports --min-anchor 8 --splice-mismatches 0 --min-report-intron 50 --max-report-intron 500000 --min-isoform-fraction 0.15 --output-dir tag1tag2_thout/ --max-multihits 20 --max-seg-multihits 40 --segment-length 25 --segment-mismatches 2 --min-closure-exon 100 --min-closure-intron 50 --max-closure-intron 5000 --min-coverage-intron 50 --max-coverage-intron 20000 --min-segment-intron 50 --max-segment-intron 500000 --read-mismatches 2 --read-gap-length 2 --read-edit-dist 2 --read-realign-edit-dist 3 --max-insertion-length 3 --max-deletion-length 3 --bowtie1 -z gzip -p8 --inner-dist-mean 50 --inner-dist-std-dev 20 --gtf-annotations genes.gtf --gtf-juncs tag1tag2_thout/tmp/genes.juncs --no-closure-search --no-microexon-search --sam-header tag1tag2_thout/tmp/genome_genome.bwt.samheader.sam --report-mixed-alignments --samtools=/usr/bin/samtools --bowtie2-max-penalty 6 --bowtie2-min-penalty 2 --bowtie2-penalty-for-N 1 --bowtie2-read-gap-open 5 --bowtie2-read-gap-cont 3 --bowtie2-ref-gap-open 5 --bowtie2-ref-gap-cont 3 genome.fa tag1tag2_thout/junctions.bed tag1tag2_thout/insertions.bed tag1tag2_thout/deletions.bed tag1tag2_thout/fusions.out tag1tag2_thout/tmp/accepted_hits tag1tag2_thout/tmp/left_kept_reads.m2g.bam,tag1tag2_thout/tmp/left_kept_reads.m2g_um.mapped.bam,tag1tag2_thout/tmp/left_kept_reads.m2g_um.candidates tag1tag2_thout/tmp/left_kept_reads.bam tag1tag2_thout/tmp/right_kept_reads.m2g.bam,tag1tag2_thout/tmp/right_kept_reads.m2g_um.mapped.bam,tag1tag2_thout/tmp/right_kept_reads.m2g_um.candidates tag1tag2_thout/tmp/right_kept_reads.bam
Loaded 10422 junctions
Parharn is offline   Reply With Quote
Old 01-06-2014, 08:23 AM   #26
gs512
Junior Member
 
Location: world

Join Date: Oct 2012
Posts: 3
Default

My patch is only about the resume function, in your case the issue seems to be different
gs512 is offline   Reply With Quote
Old 01-06-2014, 08:25 AM   #27
Parharn
Member
 
Location: Sweden

Join Date: Jul 2013
Posts: 84
Default

Alright! Thanks anyway!
Parharn is offline   Reply With Quote
Old 01-07-2014, 09:05 PM   #28
Parharn
Member
 
Location: Sweden

Join Date: Jul 2013
Posts: 84
Default

Expanding RAM solved the problem for me!
Parharn is offline   Reply With Quote
Old 05-14-2014, 01:07 AM   #29
N00bSeq
Member
 
Location: Sweden

Join Date: Mar 2014
Posts: 12
Default

I am getting the same error (fail when reporting output tracks) on tophat 2.0.11. I have made three mapping runs for each of 12 samples. Of these, only the ones using both --no-discordant and --no-mixed together fail (I have not tried these two parameters individually), and runs with these options fail for all 12 samples.

My reads have been trimmed, and pairs may not be of equal size. But as far as I understand, tophat should be able to handle that. At least, it certainly seems to when not using these particular parameters. Number of paired reads are around 30-40 M.

Increasing RAM did not help in my case.

Last edited by N00bSeq; 05-15-2014 at 12:02 AM.
N00bSeq is offline   Reply With Quote
Old 07-17-2014, 05:26 PM   #30
daidaobee
Junior Member
 
Location: Houston

Join Date: Feb 2014
Posts: 1
Default

I was using 2.0.8 and had the same problem.

My command line was
Quote:
tophat2 -p 22 ref.hg19 R1.fastq R2.fastq
It kept failing out at the "Reporting output track". I added/took away different conditions as stated above and it still didn't work.

Then I decreased down to -p 5 and it completed without error. I have NO idea why, but this is my case.
daidaobee is offline   Reply With Quote
Old 08-14-2014, 05:05 AM   #31
wacguy
Member
 
Location: NC

Join Date: Sep 2012
Posts: 24
Default -p flag causes problems

Hi,

I'm running tohat2 against the sequence of my transgene (luciferase). I only use the bowtie2 indexes and the FASTA file (i.e., no GTF).
I realized that using the -p 2 (or more) comparing to no -p option (but I didn't try to explicitly run w/ -p 1) can sometimes (this is file related because it doesn't haapen w/ all files) spits the following error:
Reporting output tracks
[FAILED]
Error running /usr/libexec/tophat.

Another type of error occured on some files:

Warning: Empty fasta file: '/rdata/ngseq/Playground/guy/tophat2/030314_root4/130814luc/P4/tmp/segment_juncs.fa'
Warning: All fasta inputs were empty
Error: Encountered internal Bowtie 2 exception (#1)
Command: /usr/bin/bowtie2-build /rdata/ngseq/Playground/guy/tophat2/030314_root4/130814luc/P4/tmp/segment_juncs.fa /rdata/ngseq/Playground/guy/tophat2/030314_root4/130814luc/P4/tmp/segment_juncs
[FAILED]
Error: Splice sequence indexing failed with err =1

I solved it by the flag: --no-novel-juncs
It is starnge because according to tohat manual, this flag is ignored w/o the -j/G option but it solved the problem.

topaht version 2.0.9 or 2.012.
Good luck,
Guy
wacguy is offline   Reply With Quote
Old 01-06-2015, 02:45 AM   #32
krespim
Member
 
Location: Dresden

Join Date: Jul 2012
Posts: 49
Default same in v2.0.13

Quote:
Originally Posted by N00bSeq View Post
I am getting the same error (fail when reporting output tracks) on tophat 2.0.11. I have made three mapping runs for each of 12 samples. Of these, only the ones using both --no-discordant and --no-mixed together fail (I have not tried these two parameters individually), and runs with these options fail for all 12 samples.

My reads have been trimmed, and pairs may not be of equal size. But as far as I understand, tophat should be able to handle that. At least, it certainly seems to when not using these particular parameters. Number of paired reads are around 30-40 M.

Increasing RAM did not help in my case.

I had the same experience with v2.0.13. Tophat stopped reporting the error when the 2 options, --no-discordant and --no-mixed, where removed.
krespim is offline   Reply With Quote
Old 05-12-2016, 08:12 AM   #33
ngoc_nguyen
Junior Member
 
Location: Ireland

Join Date: Nov 2015
Posts: 1
Default Error: [Errno 16] Device or resource busy

Hello, I'm new here.
I'm running tophat 2.0.10 with Bowtie 2.1.0.0 to map SE RNAseq to human genome. I have run the same tophat command with several datasets; some of my experiments exit fine with both accepted_hits.bam and unmapped.bam files produced and no tmp files left; some of the datasets fail without outputing unmapped.bam files, but tmp files still left in tophat output (I guess it is due to unfinished tophat run). For those runs that failed, it always reported error Error: [Errno 16] Device or resource busy, like this

[2016-05-12 15:34:26] Mapping left_kept_reads.m2g_um_seg1 to genome segment_juncs with Bowtie2 (1/2)
[2016-05-12 15:34:35] Mapping left_kept_reads.m2g_um_seg2 to genome segment_juncs with Bowtie2 (2/2)
[2016-05-12 15:34:43] Joining segment hits
[2016-05-12 15:39:47] Reporting output tracks
[FAILED]
Error: [Errno 16] Device or resource busy
Found 63037 junctions from happy spliced reads

[samopen] SAM header is present: 86 sequences.

Interestingly, the error seems to very consistently occur with some particular datasets, mean if a dataset fails with the fisrt tophat run, it keeps failing when I repeat running; but sometimes when I used the datasets that have successfully exit the tophat before, I have the tophat output failure in the next repeating run; so I don;t think it is because of the input file format problem.

And, if I converted the accepted_hits.bam files in tophat output to fastq files and remap them again using tophat, all of the run have exact this error no matter what the previous runs exit successfully or failed or not.

I had run tophat 1.4.1 with the same datasets before n did not get any errors.

I have search but havent found this kind of error " Error: [Errno 16] Device or resource busy" reported before. Any advice would be much appreciated!
ngoc_nguyen is offline   Reply With Quote
Reply

Tags
illumina, reporting output tracks, tophat

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 08:21 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO