SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
tophat max number of junctions per read? rcorbett Bioinformatics 0 11-23-2011 10:06 AM
tophat -j junctions option cedance Bioinformatics 0 06-19-2011 02:34 AM
Tophat ignoring '--max-multihits' flag? polarise Bioinformatics 3 03-04-2011 11:28 AM
A question about tophat -g/--max-multihits option keycard Bioinformatics 2 12-29-2010 04:36 AM
tophat max-multihits not heeded brentp Bioinformatics 1 06-14-2010 09:54 AM

Reply
 
Thread Tools
Old 06-11-2011, 09:10 AM   #1
andrewmagis
Junior Member
 
Location: United States

Join Date: Jun 2011
Posts: 2
Default Tophat 1.3.0 max-deletion-length option BUGFIX

I have recently tried to perform insertion/deletion alignments with Tophat 1.3.0, but received the following error when I tried to set the max-deletion-length option:

tophat: option --max-deletion-length not recognized
for detailed help see http://tophat.cbcb.umd.edu/manual.html

I looked in the tophat file itself (it is a python code file), and found the problem. While the code to process the max-deletion-length option is present, the code to allow the command line option is missing. Users can easily fix this themselves using the attached patch file in linux. Copy the patch file to the location of the tophat executable, and run the following

patch < tophat.min-deletion-length.patch.txt

This will add a single line of code to the tophat file and restore functionality for the min-deletion-length option.

If you wish to do it manually, just open the patch file in your favorite text editor and you will see what needs to be done.

Andrew
Attached Files
File Type: txt tophat.min-deletion-length.patch.txt (548 Bytes, 22 views)
andrewmagis is offline   Reply With Quote
Old 06-11-2011, 09:32 AM   #2
shurjo
Senior Member
 
Location: Rockville, MD

Join Date: Jan 2009
Posts: 126
Default

Thanks! It's very generous of you to share your code with the community.
shurjo is offline   Reply With Quote
Old 06-11-2011, 09:43 AM   #3
andrewmagis
Junior Member
 
Location: United States

Join Date: Jun 2011
Posts: 2
Default Typo above

I just realized I used min-deletion-length and max-deletion-length interchangeably in the post above. The fix is only for the MAX-DELETION-LENGTH option, not min! Sorry about that.
andrewmagis is offline   Reply With Quote
Old 06-17-2011, 11:07 PM   #4
qifei9
Junior Member
 
Location: china

Join Date: Mar 2011
Posts: 1
Default

I think it is not a miss of "max-deletion-length", but a wrong write to "min-insertion-length", because the "min-insertion-length" only appears once.
qifei9 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 01:11 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO