SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Bowtie alignment Linas Bioinformatics 1 07-17-2016 12:11 AM
Have a problem installing Bowtie Hamed General 4 05-08-2016 06:13 PM
bowtie index problem (bowtie-build and then bowtie-inspect) tgenahmet Bioinformatics 4 09-10-2013 11:51 AM
Bowtie mapping problem harrike Bioinformatics 1 05-09-2011 06:29 AM
Bowtie Problem BioTalk Bioinformatics 6 05-05-2010 07:20 AM

Reply
 
Thread Tools
Old 03-29-2018, 12:12 PM   #1
eduillueca
Junior Member
 
Location: Murcia, Spain

Join Date: Mar 2018
Posts: 1
Default Problem with Bowtie 2

Hi, I am a student and I'm doing work with data obtained by ChiPSeq. I am trying to do the alignment of the reads with the reference genome, but I get the following error:

system("./bowtie2-build ./data/tair10.fasta ./data/tair10.fasta") # Indexes reference genome

./bowtie2-build: 20: ./bowtie2-build:
Copyright 2014, Ben Langmead <[email protected]>

This file is part of Bowtie 2.

Bowtie 2 is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.

Bowtie 2 is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with Bowtie 2. If not, see <http://www.gnu.org/licenses/>.
: not found
from: can't read /var/mail/collections
./bowtie2-build: 31: ./bowtie2-build: Syntax error: "(" unexpected

Then, I attempt to put in place the following commands and I get this error:

> resources <- list(walltime="1:00:00", ntasks=1, ncpus=cores(args), memory="10G")
> reg <- clusterRun(args, conffile=".BatchJobs.R", template="slurm.tmpl", Njobs=18, runid="01",
+ resourceList=resources)

Creating dir: /home/usuario/chipseq/results/submitargs01_BJdb_7642
Saving registry: /home/usuario/chipseq/results/submitargs01_BJdb_7642/registry.RData
Adding 18 jobs to DB.
Error in system2(command = command, args = args, stdout = stdout, stderr = stderr, :
error in running command
Además: There were 40 warnings (use warnings() to see them)

> waitForJobs(reg)
Error in checkRegistry(reg, writeable = FALSE) :
objeto 'reg' no encontrado

I don't know where can be the problem. I'm using the tutarial of the following web http://girke.bioinformatics.ucr.edu/...hIPseq_04.html
for ChIPSeq Analysys. I am working on RStudio with the package systemPipeR
eduillueca is offline   Reply With Quote
Old 03-29-2018, 04:37 PM   #2
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,701
Default

For reference cross-posted: https://www.biostars.org/p/301685/#306693
GenoMax is offline   Reply With Quote
Reply

Tags
bowtie 2, chip seq

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 05:13 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO