SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error "RG ID on SAMRecord not found in header" from Picard's MarkDuplicates.jar‏ cliff Bioinformatics 4 11-10-2011 03:27 AM
Relatively large proportion of "LOWDATA", "FAIL" of FPKM_status running cufflink ruben6um Bioinformatics 3 10-12-2011 12:39 AM
The position file formats ".clocs" and "_pos.txt"? Ist there any difference? elgor Illumina/Solexa 0 06-27-2011 07:55 AM
"Systems biology and administration" & "Genome generation: no engineering allowed" seb567 Bioinformatics 0 05-25-2010 12:19 PM
SEQanswers second "publication": "How to map billions of short reads onto genomes" ECO Literature Watch 0 06-29-2009 11:49 PM

Reply
 
Thread Tools
Old 04-02-2010, 06:28 AM   #1
sunnyvu
Member
 
Location: USA TN

Join Date: Mar 2010
Posts: 17
Default TopHat "accepted_hits.sam" header line

I am runing the TopHat. I found that the header line of the file "accepted_hits.sam"is as following:
@HD VN:1.0 SO:sorted
@PG TopHat VN:1.0.130

The file "accepted_hits.sam" does not working for Samtools.

I use the commond "./samtools view -S -t -X -o exampl.flag accepted_hits.sam", and got two errors:

The tag [ID] required for [PG] not present.
Segmentation fault..

According to suggestions from nilshomer, I changed the line "@PG ID:TopHat VN:1.0.13). The first error is gone.

So my problems:
1) Why my file "accepted_hits.sam" without "ID:"?
2) how to fix the second error?

Thanks
sunnyvu is offline   Reply With Quote
Old 04-02-2010, 08:05 AM   #2
nilshomer
Nils Homer
 
nilshomer's Avatar
 
Location: Boston, MA, USA

Join Date: Nov 2008
Posts: 1,285
Default

Quote:
Originally Posted by sunnyvu View Post
I am runing the TopHat. I found that the header line of the file "accepted_hits.sam"is as following:
@HD VN:1.0 SO:sorted
@PG TopHat VN:1.0.130

The file "accepted_hits.sam" does not working for Samtools.

I use the commond "./samtools view -S -t -X -o exampl.flag accepted_hits.sam", and got two errors:

The tag [ID] required for [PG] not present.
Segmentation fault..

According to suggestions from nilshomer, I changed the line "@PG ID:TopHat VN:1.0.13). The first error is gone.

So my problems:
1) Why my file "accepted_hits.sam" without "ID:"?
2) how to fix the second error?

Thanks
It seems that it is still not liking the "@PG" line. Can you make sure that they are TAB separated?
nilshomer is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 01:45 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO