SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Errors encountered while running Metasim sandhya Bioinformatics 1 09-14-2017 11:01 PM
Running GATK, keep receiving errors. prs321 Bioinformatics 2 06-28-2013 09:50 AM
BRIG Blast Ring Image Generator-GC Skew? Inma Bioinformatics 2 06-07-2013 01:16 AM
errors running Trinity bioBob Bioinformatics 3 03-30-2013 08:56 PM
tophat Error running running 'prep_reads' victoryhe Bioinformatics 2 10-17-2011 04:53 AM

Reply
 
Thread Tools
Old 07-26-2013, 04:10 AM   #1
NGS group
Member
 
Location: Netherlands

Join Date: Apr 2013
Posts: 28
Angry Running errors showed by BRIG

Hi all,

I am trying to learn using BRIG for genome comparative study. I followed the manual step by step. However, after submitting my work, BRIG gave an error as follow:

"Rendering CGVIEW image...
java -Xmx1500m -jar cgview\cgview.jar -f jpg -i C:\NGS\Genomecomparison\Output\scratch\EC338.fa.xml -o C:\NGS\Genomecomparison\Output\EC338.fa.jpg
Error occurred during initialization of VM
Could not reserve enough space for object heap
SYS_ERROR:Error: Could not create the Java Virtual Machine.
SYS_ERROR:Error: A fatal exception has occurred. Program will exit.
Done."


I tried to reinstall the Java program, but it was useless. BTW, my computer has 32G memory.

Is there anyone can tell me how can I solve this problem?

Thank you very much!

Victor
NGS group is offline   Reply With Quote
Old 07-29-2013, 11:31 PM   #2
sromero
Junior Member
 
Location: México

Join Date: Oct 2010
Posts: 2
Default

Hi,

Although you have that amount of memory you might want to try making smaller the amount of memory that BRIG is using. This can be done in the "Image render memory" option of the BRIG's image settings.

Hope this helps.
sromero is offline   Reply With Quote
Old 07-29-2013, 11:50 PM   #3
NGS group
Member
 
Location: Netherlands

Join Date: Apr 2013
Posts: 28
Default

Hi Sromero,

Thanks for your reply. I already solved my problem. However, I get another problem is that I could not get all rings after running finished, even I tried with the Example data from BRIG tutorial. Do you have any idea about that?

Thank you!
NGS group is offline   Reply With Quote
Old 07-30-2013, 12:23 AM   #4
sromero
Junior Member
 
Location: México

Join Date: Oct 2010
Posts: 2
Default

Hi,

This I have seen that happens when you don' t specify some data from the data pool to every ring. Yo can check this in the "Customize rings" section that follows after you start a BRIG project. By the way, what was your solution for the previous memory problem?.
sromero is offline   Reply With Quote
Old 07-30-2013, 01:46 AM   #5
NGS group
Member
 
Location: Netherlands

Join Date: Apr 2013
Posts: 28
Default

The memory problem was due to the version of Java. My computer is win 64bit, and both 32bit and 64 bit version of java have been installed. The program would use 32bit version automatically, which does not support memory > 1.5G (the default setting of BRIG). So, the solution is just uninstallation of 32bit version java.

Anyway, thanks for your helps.
NGS group is offline   Reply With Quote
Old 07-30-2013, 11:57 PM   #6
NGS group
Member
 
Location: Netherlands

Join Date: Apr 2013
Posts: 28
Default

I found that this is not the reason of my problem. Are there any other possibilities?


Quote:
Originally Posted by sromero View Post
Hi,

This I have seen that happens when you don' t specify some data from the data pool to every ring. Yo can check this in the "Customize rings" section that follows after you start a BRIG project. By the way, what was your solution for the previous memory problem?.
NGS group is offline   Reply With Quote
Old 04-14-2014, 08:22 AM   #7
mcastro
Junior Member
 
Location: Barcelona

Join Date: May 2011
Posts: 7
Default BRIG error in multi-fasta tutorial

Hi,
I have the same problem when I try with multi-fasta example tutorial. I get this error:
java.lang.IllegalArgumentException: Comparison method violates its general contract!
at java.util.TimSort.mergeHi(TimSort.java:868)
at java.util.TimSort.mergeAt(TimSort.java:485)
at java.util.TimSort.mergeCollapse(TimSort.java:410)
at java.util.TimSort.sort(TimSort.java:214)
at java.util.TimSort.sort(TimSort.java:173)
at java.util.Arrays.sort(Arrays.java:659)
at brig.Main.reverseBlast(Main.java:206)
at brig.Main.BlastMaster(Main.java:1494)
at brig.Main.ParseBlast(Main.java:1352)
at brig.Three2.compute(Three2.java:337)
at brig.Three2.access$300(Three2.java:33)
at brig.Three2$4.run(Three2.java:234)

The rings corresponding to this error appear empty. Anyone solved this problem?

Thanks!
mcastro is offline   Reply With Quote
Old 09-01-2014, 01:01 PM   #8
AnaCarol
Junior Member
 
Location: Brasil

Join Date: Sep 2014
Posts: 1
Default

I am receiving the same message. Has anyone solved it yet?
AnaCarol is offline   Reply With Quote
Old 10-30-2014, 11:41 AM   #9
reubennowell
Member
 
Location: Edinburgh

Join Date: Jan 2013
Posts: 18
Default

Quote:
Originally Posted by mcastro View Post
Hi,
I have the same problem when I try with multi-fasta example tutorial. I get this error:
java.lang.IllegalArgumentException: Comparison method violates its general contract!
at java.util.TimSort.mergeHi(TimSort.java:868)
at java.util.TimSort.mergeAt(TimSort.java:485)
at java.util.TimSort.mergeCollapse(TimSort.java:410)
at java.util.TimSort.sort(TimSort.java:214)
at java.util.TimSort.sort(TimSort.java:173)
at java.util.Arrays.sort(Arrays.java:659)
at brig.Main.reverseBlast(Main.java:206)
at brig.Main.BlastMaster(Main.java:1494)
at brig.Main.ParseBlast(Main.java:1352)
at brig.Three2.compute(Three2.java:337)
at brig.Three2.access$300(Three2.java:33)
at brig.Three2$4.run(Three2.java:234)

The rings corresponding to this error appear empty. Anyone solved this problem?

Thanks!
I was having the same issues, and I think it's do with the version of Java you are running. BRIG was written in Java 1.6, I don't think it works with 1.7 (on my system anyway). On Ubuntu, try
Code:
java -version
to see what version you are running, then you can change to 1.6 with:

Code:
sudo update-alternatives --config java
type the number corresponding to Java 6, hit enter, and try BRIG again. This worked for me at least.
reubennowell is offline   Reply With Quote
Old 04-18-2015, 05:20 AM   #10
inahw
Junior Member
 
Location: London

Join Date: Apr 2015
Posts: 1
Default

Hi all I'm having some issue finding the output image file (.png or .jpg) from BRIG no matter what I run they don't appear in the scratch folder all I get is the .xml and .tab files…

I'm new to BRIG and would be really grateful for some help!

Thanks

Roseina
inahw is offline   Reply With Quote
Old 04-21-2015, 04:39 AM   #11
bastianwur
Member
 
Location: Germany/Netherlands

Join Date: Feb 2014
Posts: 98
Default

I'm not sure why, but there seems to be some incompatibility with the latest java version. Either switch back to an older one (no idea which), or try the developers version (also in the download directory).
bastianwur is offline   Reply With Quote
Old 11-09-2015, 06:11 AM   #12
fpj
Junior Member
 
Location: London

Join Date: Nov 2015
Posts: 4
Default Running BLAST and that's it!

I've previously used BRIG with no problems but this time I click submit and it says Running BLAST..... and that's it. I can leave it for forever and nothing will change. I've tried uninstalling blast+ and reinstalling it, the same with java and no help. Anyone have this problem too and how can I fix it? I don't understand why it's not doing anything!

Thanks,
Frances
fpj is offline   Reply With Quote
Old 06-21-2016, 02:40 PM   #13
wlud
Junior Member
 
Location: CA

Join Date: Aug 2012
Posts: 1
Default

Thanks @reubennowell. I was having similar problems with BRIG not displaying rings of BLAST results. Starting BRIG from the command line with Java6 (a.k.a. Java 1.6) fixes my problem.

First navigate into the BRIG-x.xx-dist folder on command line and then execute:

Code:
wlud$ /Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin/java 
-Xmx1500M -jar BRIG.jar
BRIG now does what it's supposed to do, which is lovely.

I'm on MacOSX 10.11.5
wlud is offline   Reply With Quote
Reply

Tags
brig, error, memory

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 04:38 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO