SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I use DESeq and edgeR for mixed ANOVA abebe Illumina/Solexa 18 07-13-2017 04:45 AM
Can edgeR/DESeq have more than one covariate? arrchi Bioinformatics 8 10-28-2013 02:37 PM
DESeq and edgeR up/down regulation murphycj Bioinformatics 7 09-21-2011 07:09 AM
BaySeq vs GLM in EdgeR and DESeq Hilary April Smith Bioinformatics 0 08-03-2011 10:14 AM
edgeR vs DESeq vs bayseq Azazel Bioinformatics 1 10-07-2010 07:11 AM

Reply
 
Thread Tools
Old 03-11-2012, 06:19 AM   #1
papori
Senior Member
 
Location: berd

Join Date: Dec 2010
Posts: 179
Default DESeq and edgeR

Hi,
i am using both programs to analyse differential expression.
i used this manual http://manuals.bioinformatics.ucr.edu/home/ht-seq
so may script is that:

library("DESeq");
conditions <- c("1","2")
cds <- newCountDataSet(x,conditions)
cds <- estimateSizeFactors(cds)
cds <- estimateDispersions(cds,method="blind",sharingMode="maximum",fitType="local")
res <- nbinomTest(cds,condA="1",condB="2")
res[order(res$padj), ][1:4,]

sigDESeq <- res[res$padj <= 0.05, ]
sigDESeq <- na.omit(sigDESeq)
sigDESeq <- as.character(sigDESeq[,1])

library("edgeR");
group <- factor(c(1,2))
cdsR <- DGEList(counts=x, group=group)
cdsR <- estimateCommonDisp(cdsR)
cdsR <- estimateTagwiseDisp(cdsR)
et <- exactTest(cdsR, pair=c("1", "2"))

all <- as.data.frame(topTags(et, n=100000))
sigedgeR <- all[all$adj.P.Val <= 0.05, ]
sigedgeR <- na.omit(sigedgeR)
sigedgeR <- row.names(sigedgeR)

source("http://faculty.ucr.edu/~tgirke/Documents/R_BioCond/My_R_Scripts/overLapper.R")
OLlist <- overLapper(setlist=list(DESeq=sigDESeq, edgeR=sigedgeR), sep="_", type="vennsets")
counts <- sapply(OLlist$Venn_List, length)
vennPlot(counts=counts)
counts

oveLapp <- OLlist$Venn_List

$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

i want to check Differential expression between biological replicates.(here: i have only 2)
1 & 2 are biological replicates.

the problem is:
in edgeR i get 377 significant genes where in DESeq i got 0 (ZERO)

it looks weird to me, but i do'nt know what i did wrong..

Any advice!?!?

Thanks,
Pap
papori is offline   Reply With Quote
Old 03-14-2012, 08:06 AM   #2
Wolfgang Huber
Senior Member
 
Location: Heidelberg, Germany

Join Date: Aug 2009
Posts: 109
Default

For the record, Pap cross-posted this question also to another list, where it has been addressed in the thread starting at https://stat.ethz.ch/pipermail/bioco...ch/044178.html
__________________
Wolfgang Huber
EMBL
Wolfgang Huber is offline   Reply With Quote
Old 03-14-2012, 10:42 AM   #3
papori
Senior Member
 
Location: berd

Join Date: Dec 2010
Posts: 179
Default

Hi Wolfgang Huber,
Thank you!
i didn't see that someone answer me there
papori is offline   Reply With Quote
Old 05-15-2012, 06:29 PM   #4
capricy
Senior Member
 
Location: 63130

Join Date: Apr 2012
Posts: 125
Default

I had the similar issue. I used the sharingMode="fit-only", but still Deseq gave me 0 differential genes, whereas edgeR gave over 1000

I couldn't post to BioC mailist since it was in archive and I just subscribed. So I posted here.
capricy is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 06:04 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO