SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
GOSeq not finding database ETHANol Bioinformatics 4 04-06-2018 02:15 PM
goseq error message gilby Bioinformatics 1 05-29-2013 01:14 PM
Goseq for non-native goseq db annaprotasio Bioinformatics 12 03-31-2013 11:36 PM
GOseq errors egorleg RNA Sequencing 6 11-29-2012 02:09 PM
installing goseq chknbio Bioinformatics 2 05-29-2012 02:00 PM

Reply
 
Thread Tools
Old 07-03-2014, 09:08 AM   #1
mparida85
Member
 
Location: 52241

Join Date: Jan 2014
Posts: 17
Default goseq errors

Hi All
I am using R 2.14.2 version. I have tried running the goseq tutorial code and it fails to perform the probability weighting function calculation (pwf).
I am not sure what is going on, here is the part I am stuck at:

> library("goseq")
Loading required package: BiasedUrn
Loading required package: geneLenDataBase
> library("edgeR")
Loading required package: limma
> table.summary=read.table(system.file("extdata","Li_sum.txt",package='goseq'),
+ sep='\t',header=TRUE,stringsAsFactors=FALSE)
> counts=table.summary[,-1]
> rownames(counts)=table.summary[,1]
> grp=factor(rep(c("Control","Treated"),times=c(4,3)))
> summarized=DGEList(counts,lib.size=colSums(counts),group=grp)
> disp=estimateCommonDisp(summarized)
> disp$common.dispersion
[1] 0.05688364
> tested=exactTest(disp)
> topTags(tested)
Comparison of groups: Treated-Control
logFC logCPM PValue FDR
ENSG00000127954 11.557868 6.680782 2.574972e-80 1.274766e-75
ENSG00000151503 5.398963 8.499425 1.781732e-65 4.410322e-61
ENSG00000096060 4.897600 9.446635 7.983756e-60 1.317479e-55
ENSG00000091879 5.737627 6.281841 1.207655e-54 1.494654e-50
ENSG00000132437 -5.880436 7.951978 2.950042e-52 2.920896e-48
ENSG00000166451 4.564246 8.458263 7.126763e-52 5.880292e-48
ENSG00000131016 5.254737 6.607187 1.066807e-51 7.544766e-48
ENSG00000163492 7.085400 5.126627 2.716461e-45 1.681014e-41
ENSG00000113594 4.051053 8.602951 9.272066e-44 5.100255e-40
ENSG00000116285 4.108522 7.864828 6.422468e-43 3.179507e-39
> genes=as.integer(p.adjust(tested$table$PValue[tested$table$logFC!=0],
+ method="BH")<.05)
> names(genes)=row.names(tested$table[tested$table$logFC!=0,])
> table(genes)
genes
0 1
19535 3208
> pwf=nullp(genes,"hg19","ensGene")
Loading hg19 length data...
Error in pcls(G) : initial parameters not feasible

I will appreciate any help on this matter.
Rocky
mparida85 is offline   Reply With Quote
Old 07-03-2014, 04:03 PM   #2
mparida85
Member
 
Location: 52241

Join Date: Jan 2014
Posts: 17
Default

I just ran this on R 2.14.1, windows 7 and it works great. No errors until the last step.
mparida85 is offline   Reply With Quote
Old 07-03-2014, 08:43 PM   #3
liuqiangwer
Junior Member
 
Location: Beijing, China

Join Date: Jul 2014
Posts: 5
Default

Hi
I met the same error when doing goseq, but it worked well before, I can't figure out what's going on now, have you solved it yet?
liuqiangwer is offline   Reply With Quote
Old 07-04-2014, 04:46 AM   #4
sazz
Member
 
Location: Istanbul, Turkey

Join Date: Oct 2012
Posts: 28
Default

Weird, 2 days ago I got the same error and I thought I was doing something wrong, I hope it is about the version of R.
sazz is offline   Reply With Quote
Old 07-04-2014, 04:56 AM   #5
liuqiangwer
Junior Member
 
Location: Beijing, China

Join Date: Jul 2014
Posts: 5
Default

Hi sazz,
My R version: "R version 3.1.0 (2014-04-10)". I used Linux and Mac both have the same error. If you figure out the reason, please let me know. Thank you a lot.
liuqiangwer is offline   Reply With Quote
Old 07-04-2014, 06:09 AM   #6
liuqiangwer
Junior Member
 
Location: Beijing, China

Join Date: Jul 2014
Posts: 5
Default

Hi sazz,
I don't think it came from wrong code. And I check the record I did before, at May 13th, the same code and input data but had no error. And also the same R version(3.1.0).
Now the error trace showed:
5 stop("initial parameters not feasible")
4 pcls(G)
3 makespline(bias.data[w], DEgenes[w])
2 nullp(gene.vector, bias.data = countbias, plot.fit = T)
Hope this can be a hint for you.
liuqiangwer is offline   Reply With Quote
Old 07-05-2014, 01:44 AM   #7
sazz
Member
 
Location: Istanbul, Turkey

Join Date: Oct 2012
Posts: 28
Default

I updated my R version (3.1.0) and it works now. Hope this helps..
sazz is offline   Reply With Quote
Old 07-05-2014, 03:13 AM   #8
liuqiangwer
Junior Member
 
Location: Beijing, China

Join Date: Jul 2014
Posts: 5
Default

Hi sazz
Yes. I re-installed my R(the same version as before 3.1.0), and it works now. Thank you very much!
liuqiangwer is offline   Reply With Quote
Old 07-05-2014, 05:20 PM   #9
liuqiangwer
Junior Member
 
Location: Beijing, China

Join Date: Jul 2014
Posts: 5
Default

Hi,
After I changed to goseq's new version(1.16.2), without re-install R(because it already the latest version), the error gone. So maybe goseq version is also important. Thanks all!
liuqiangwer is offline   Reply With Quote
Reply

Tags
goseq, pwf

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 03:43 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO