SEQanswers

Go Back   SEQanswers > Applications Forums > RNA Sequencing



Similar Threads
Thread Thread Starter Forum Replies Last Post
tophat problem: no accepted_hits.bam generated RNAer Bioinformatics 9 08-30-2013 09:41 AM
Does accepted_hits.bam include unmapped.bam reads erichpeterson Bioinformatics 2 11-21-2012 07:08 AM
Cuffdiff won't open TopHat accepted_hits.bam Richard Barker RNA Sequencing 12 08-14-2012 10:14 AM
tophat problem: no accepted_hits.bam generated RNAer Bioinformatics 0 07-19-2011 12:18 PM
TOPHAT EMPTY accepted_hits.bam ISSUE waterboy Bioinformatics 1 11-16-2010 08:48 AM

Reply
 
Thread Tools
Old 03-07-2013, 01:35 AM   #1
offspring
Member
 
Location: Lund, Sweden

Join Date: Mar 2013
Posts: 32
Default Tophat: merging accepted_hits.bam and unmapped.bam

Hi everyone,

I would like to merge the Tophat output files accepted_hits.bam and unmapped.bam into one file for subsequent analysis. The files contain paired-end Illumina reads.

I used a naive approach of just calling samtools merge:

Code:
samtools merge merged.bam accepted_hits.bam unmapped.bam
Using the resulting merged.bam file with any Picard tool results in an error however:

Code:
INFO	2013-03-07 10:29:53	AddOrReplaceReadGroups	Processed    39,000,000
records.  Elapsed time: 00:11:07s.  Time for last 1,000,000:   16s.
Last read position: chrX:153,627,857
[Thu Mar 07 10:29:55 CET 2013] net.sf.picard.sam.AddOrReplaceReadGroups
done. Elapsed time: 11.16 minutes.
Runtime.totalMemory()=1110376448
FAQ:  http://sourceforge.net/apps/mediawiki/picard/index.php?title=Main_Page
Exception in thread "main" net.sf.samtools.SAMFormatException: SAM
validation error: ERROR: Record 39136746, Read name
HWI-ST587_0094:4:1101:7158:1939.ATCACGA/1, Mapped mate should have mate
reference name
	at net.sf.samtools.SAMUtils.processValidationErrors(SAMUtils.java:448)
	at
net.sf.samtools.BAMFileReader$BAMFileIterator.advance(BAMFileReader.java:541)
	at
net.sf.samtools.BAMFileReader$BAMFileIterator.next(BAMFileReader.java:522)
	at
net.sf.samtools.BAMFileReader$BAMFileIterator.next(BAMFileReader.java:481)
	at
net.sf.samtools.SAMFileReader$AssertableIterator.next(SAMFileReader.java:672)
	at
net.sf.samtools.SAMFileReader$AssertableIterator.next(SAMFileReader.java:650)
	at
net.sf.picard.sam.AddOrReplaceReadGroups.doWork(AddOrReplaceReadGroups.java:98)
	at
net.sf.picard.cmdline.CommandLineProgram.instanceMain(CommandLineProgram.java:177)
	at
net.sf.picard.cmdline.CommandLineProgram.instanceMainWithExit(CommandLineProgram.java:119)
	at
net.sf.picard.sam.AddOrReplaceReadGroups.main(AddOrReplaceReadGroups.java:66)
The files were created with a Tophat version prior to 2.0.7, so the unmapped reads still have /1 and /2 suffixes. However, removing the suffixes before calling samtools merge results in the same error down the line.

The reads picard complains about look like this:

Code:
samtools view merged.bam | grep "HWI-ST587_0094:4:1101:7158:1939.ATCACGA"
HWI-ST587_0094:4:1101:7158:1939.ATCACGA	1177	chr3	129324900
50	38M	*	0	0	CTAGCCCCACGGTGGACGCGTTCGGGTGGTTGGCCGCC
FFFFHJJJHJJJJJJJJJJJJJJJJHHHHHFFFFFCCC	AS:i:0	XN:i:0	XM:i:0	XO:i:0
XG:i:0	NM:i:0	MD:Z:38	YT:Z:UU	XS:A:-	NH:i:1
HWI-ST587_0094:4:1101:7158:1939.ATCACGA/1	69	*	0	255	*	*	0	0
TGNGTGTTCTCGAAGCGGTGGTCCTCCAGGCTGCGGTTGCGCGGGAAGAAGGNGCTGCCGTAACCGGTGTACGTGNCGCCCACGAGCAGGCGGCTGCCCC
CC!4ADDFHHHHHJJIJJGHJHIJJJJJJJJJJJJJFHIJJIJGDBDDDDDD!,8?BDDDDDDDDDD>B>CDDCC!+8?BBBDDDDDDDDDDDB)&(28<
Software versions used:
Tophat: 2.0.6
Picard: 1.85
samtools: 0.1.18

Has anyone done this successfully?

Thanks a lot,

Chris

Last edited by offspring; 03-07-2013 at 03:55 AM.
offspring is offline   Reply With Quote
Old 03-08-2013, 12:26 AM   #2
offspring
Member
 
Location: Lund, Sweden

Join Date: Mar 2013
Posts: 32
Default

I have modified the unmapped reads as follows now:

- Removed the /1 and /2 suffixes
- Changes MAPQ from 255 to 0
- For unmapped reads with a mapped mate, set RNAME and POS to the same value as the mapped mate

However, even with these changes I get the "Mapped mate should have mate reference name" error from Picard.

Here is read pair it stumbles upon now:

Code:
HWI-ST587_0094:4:1101:7158:1939.ATCACGA	69	chr3	129324900	0	*	*	0	0	TGNGTGTTCTCGAAGCGGTGGTCCTCCAGGCTGCGGTTGCGCGGGAAGAAGGNGCTGCCGTAACCGGTGTACGTGNCGCCCACGAGCAGGCGGCTGCCCCCC!4ADDFHHHHHJJIJJGHJHIJJJJJJJJJJJJJFHIJJIJGDBDDDDDD!,8?BDDDDDDDDDD>B>CDDCC!+8?BBBDDDDDDDDDDDB)&(28<
HWI-ST587_0094:4:1101:7158:1939.ATCACGA	1177	chr3	129324900	50	38M	*	0	0	CTAGCCCCACGGTGGACGCGTTCGGGTGGTTGGCCGCC	FFFFHJJJHJJJJJJJJJJJJJJJJHHHHHFFFFFCCC	AS:i:0	XN:i:0	XM:i:0	XO:i:0	XG:i:0	NM:i:0	MD:Z:38	YT:Z:UU	XS:A:-	NH:i:1
Any clue would be appreciated!

Chris

Last edited by offspring; 03-08-2013 at 12:31 AM.
offspring is offline   Reply With Quote
Old 03-08-2013, 02:20 AM   #3
dariober
Senior Member
 
Location: Cambridge, UK

Join Date: May 2010
Posts: 311
Default

Quote:
Originally Posted by offspring View Post
I have modified the unmapped reads as follows now:

- Removed the /1 and /2 suffixes
- Changes MAPQ from 255 to 0
- For unmapped reads with a mapped mate, set RNAME and POS to the same value as the mapped mate

However, even with these changes I get the "Mapped mate should have mate reference name" error from Picard.

Here is read pair it stumbles upon now:

Code:
HWI-ST587_0094:4:1101:7158:1939.ATCACGA	69	chr3	129324900	0	*	*	0	0	TGNGTGTTCTCGAAGCGGTGGTCCTCCAGGCTGCGGTTGCGCGGGAAGAAGGNGCTGCCGTAACCGGTGTACGTGNCGCCCACGAGCAGGCGGCTGCCCCCC!4ADDFHHHHHJJIJJGHJHIJJJJJJJJJJJJJFHIJJIJGDBDDDDDD!,8?BDDDDDDDDDD>B>CDDCC!+8?BBBDDDDDDDDDDDB)&(28<
HWI-ST587_0094:4:1101:7158:1939.ATCACGA	1177	chr3	129324900	50	38M	*	0	0	CTAGCCCCACGGTGGACGCGTTCGGGTGGTTGGCCGCC	FFFFHJJJHJJJJJJJJJJJJJJJJHHHHHFFFFFCCC	AS:i:0	XN:i:0	XM:i:0	XO:i:0	XG:i:0	NM:i:0	MD:Z:38	YT:Z:UU	XS:A:-	NH:i:1
Flag 69 means read unmapped and mate mapped, so Picard expects a chromosome name assigned to the mate of the unmapped read. Since the read flagged 69 has * for the chromosome of the mate, Picard complains.

Probably this inconsistency has nothing to do with the quality of your data (unless it happens quite a lot) and I think it is just a small bug in the way Tophat sets flags. So the easy way around it is to run picard with option VALIDATION_STRINGENCY=LENIENT so that it will report the errors but it will ignore them.

Hope this helps
Dario
dariober is offline   Reply With Quote
Old 03-08-2013, 11:12 PM   #4
offspring
Member
 
Location: Lund, Sweden

Join Date: Mar 2013
Posts: 32
Default

Quote:
Originally Posted by dariober View Post
Flag 69 means read unmapped and mate mapped, so Picard expects a chromosome name assigned to the mate of the unmapped read. Since the read flagged 69 has * for the chromosome of the mate, Picard complains.

Probably this inconsistency has nothing to do with the quality of your data (unless it happens quite a lot) and I think it is just a small bug in the way Tophat sets flags. So the easy way around it is to run picard with option VALIDATION_STRINGENCY=LENIENT so that it will report the errors but it will ignore them.

Hope this helps
Dario
Hi Dario,

thanks for the input. VALIDATION_STRINGENCY=LENIENT was not really an option for me, since that would defeat the purpose of merging the two files in the first place (it would throw out all unmapped reads with a mapped mate in this case).

However I finally got it to work, part of the problem is a bug in Tophat (already reported to the Tophat team). Here is how I had to modify unmapped.bam to make it work:

1. Remove /1 and /2 suffixes from all reads (not necessary with Tophat version 2.0.7 and newer)
2. Change MAPQ from 255 to 0 for all reads
3. For unmapped reads with a mapped mate:
- set RNAME and RNEXT of unmapped read to RNAME of mapped mate
- set POS to POS of mapped mate
- set PNEXT to 0
4. For paired-end reads where both ends are unmapped, Tophat does not set the "mate is unmapped" (0x8) SAM flag on either read. This has to be fixed manually.

After making these changes, the merged file of accepted_hits.bam and unmapped.bam could be processed by Picard tools.

Chris
offspring is offline   Reply With Quote
Old 04-04-2013, 02:40 AM   #5
offspring
Member
 
Location: Lund, Sweden

Join Date: Mar 2013
Posts: 32
Default

In case it's useful for anyone else, here's the script I use to fix the unmapped reads:

https://github.com/cbrueffer/misc_bi...apped_reads.py

Chris
offspring is offline   Reply With Quote
Old 04-09-2013, 10:40 PM   #6
zaki
Member
 
Location: Malaysia

Join Date: Dec 2012
Posts: 15
Default

Dear Chris,

I was attempting to merge unmapped + mapped tophat output as well.

Very excited to see your script! but somehow it returns an error when I tried running it?

Code:
$ ~/bin/bin/python2.7 fix_unmapped.py outdir/
Traceback (most recent call last):
  File "fix_unmapped.py", line 104, in <module>
    main(sys.argv[1])
  File "fix_unmapped.py", line 53, in main
    if read.qname.index("/") != -1:
ValueError: substring not found
Not sure if this could be the reason - I am using ssh to log into a linux server, and if i type import os, or any of the other import, the error below will show up.

Code:
import: unable to open X server `'.
zaki is offline   Reply With Quote
Old 04-09-2013, 10:54 PM   #7
offspring
Member
 
Location: Lund, Sweden

Join Date: Mar 2013
Posts: 32
Default

Hi,

good to see it's useful to others. The problem is an error in the script, either replace the "index" with "find" or use the updated version from github.

The second issue seems to be that you're typing "import os" in the shell instead of in Python. The import you're executing right now is part of the ImageMagick package.

Chris

Quote:
Originally Posted by zaki View Post
Dear Chris,

I was attempting to merge unmapped + mapped tophat output as well.

Very excited to see your script! but somehow it returns an error when I tried running it?

Code:
$ ~/bin/bin/python2.7 fix_unmapped.py outdir/
Traceback (most recent call last):
  File "fix_unmapped.py", line 104, in <module>
    main(sys.argv[1])
  File "fix_unmapped.py", line 53, in main
    if read.qname.index("/") != -1:
ValueError: substring not found
Not sure if this could be the reason - I am using ssh to log into a linux server, and if i type import os, or any of the other import, the error below will show up.

Code:
import: unable to open X server `'.
offspring is offline   Reply With Quote
Old 04-09-2013, 11:53 PM   #8
zaki
Member
 
Location: Malaysia

Join Date: Dec 2012
Posts: 15
Default

Thanks Chris!

Your script worked wonderfully!!

I am assuming you then proceed to merge the unmapped_fixed.bam & mapped.bam using samtools merge?

Wondering if you have encountered picard MergeBAMAliginment tool?

Thanks to your lovely script I managed to merge using samtools and proceed using picard tools. However I think MergeBAMAlignment returns an error if I attempt to merge unmapped.bam + accepted_hits.bam... and also returns the same error if using unmapped_fixed.bam + accepted_hits.bam

Quote:
Exception in thread "main" net.sf.picard.PicardException: Program Record ID already in use in unmapped BAM file.
Would you have any idea why this might be?
zaki is offline   Reply With Quote
Old 04-10-2013, 12:48 AM   #9
offspring
Member
 
Location: Lund, Sweden

Join Date: Mar 2013
Posts: 32
Default

Good to hear! I use "samtools merge" afterwards, indeed. I've never used MergeBamAlignment, so I'm not sure what the error means. It would be interesting to find out though, I'll test it with one of our datafiles in the next couple of days.

If you figure out what the problem is in the meantime, please let me know.

Chris
offspring is offline   Reply With Quote
Old 05-06-2013, 06:51 PM   #10
vivienne_lovely
Member
 
Location: China

Join Date: Oct 2011
Posts: 20
Red face

Quote:
Originally Posted by offspring View Post
Good to hear! I use "samtools merge" afterwards, indeed. I've never used MergeBamAlignment, so I'm not sure what the error means. It would be interesting to find out though, I'll test it with one of our datafiles in the next couple of days.

If you figure out what the problem is in the meantime, please let me know.

Chris
Hi Chris,
I processed the tophat output with your instructions. I merged the accepted_hits.bam and unmapped_fixup.bam with "samtools merge", then I gave the merged bam file to "AddOrReplaceReadGroups.jar" to replace the header. But I received the error like follow:
Code:
INFO	2013-05-06 12:31:53	AddOrReplaceReadGroups	Processed    11,000,000 records.  Elapsed time: 00:03:33s.  Time for last 1,000,000:   19s.  Last read position: chr11:56,940,830
INFO	2013-05-06 12:32:13	AddOrReplaceReadGroups	Processed    12,000,000 records.  Elapsed time: 00:03:53s.  Time for last 1,000,000:   19s.  Last read position: chr11:64,878,216
[Mon May 06 12:32:14 CST 2013] net.sf.picard.sam.AddOrReplaceReadGroups done. Elapsed time: 3.93 minutes.
Runtime.totalMemory()=813891584
To get help, see http://picard.sourceforge.net/index.shtml#GettingHelp
Exception in thread "main" java.lang.NullPointerException
	at net.sf.samtools.SAMRecord.isValid(SAMRecord.java:1646)
	at net.sf.samtools.BAMFileReader$BAMFileIterator.advance(BAMFileReader.java:540)
	at net.sf.samtools.BAMFileReader$BAMFileIterator.next(BAMFileReader.java:522)
	at net.sf.samtools.BAMFileReader$BAMFileIterator.next(BAMFileReader.java:481)
	at net.sf.samtools.SAMFileReader$AssertableIterator.next(SAMFileReader.java:672)
	at net.sf.samtools.SAMFileReader$AssertableIterator.next(SAMFileReader.java:650)
	at net.sf.picard.sam.AddOrReplaceReadGroups.doWork(AddOrReplaceReadGroups.java:98)
	at net.sf.picard.cmdline.CommandLineProgram.instanceMain(CommandLineProgram.java:177)
	at net.sf.picard.cmdline.CommandLineProgram.instanceMainWithExit(CommandLineProgram.java:119)
	at net.sf.picard.sam.AddOrReplaceReadGroups.main(AddOrReplaceReadGroups.java:66)
Is this pipeline right? what should I do with this error?
Thank you for your help.
Vivienne

Last edited by vivienne_lovely; 05-06-2013 at 08:30 PM.
vivienne_lovely is offline   Reply With Quote
Old 05-06-2013, 09:29 PM   #11
offspring
Member
 
Location: Lund, Sweden

Join Date: Mar 2013
Posts: 32
Default

Hi Vivienne,

try running ReorderSam on your merged file (same as with accepted_hits.bam before).

Chris
offspring is offline   Reply With Quote
Old 05-06-2013, 09:39 PM   #12
vivienne_lovely
Member
 
Location: China

Join Date: Oct 2011
Posts: 20
Default

Hi Chris,
I tried the ReorderSam just now, but the mistake is the same as before.
Vivienne
Quote:
Originally Posted by offspring View Post
Hi Vivienne,

try running ReorderSam on your merged file (same as with accepted_hits.bam before).

Chris
vivienne_lovely is offline   Reply With Quote
Old 05-06-2013, 10:29 PM   #13
offspring
Member
 
Location: Lund, Sweden

Join Date: Mar 2013
Posts: 32
Default

Quote:
Originally Posted by vivienne_lovely View Post
Hi Chris,
I tried the ReorderSam just now, but the mistake is the same as before.
Vivienne
I can't think of anything else that might cause this at the moment... I have used this workflow on more than 200 tophat runs without issues.

To be clear, I use the following:

1. fix up unmapped.bam
2. merge accepted_hits.bam and unmapped_fixup.bam (samtools merge)
3. reorder merged file (Picard ReorderSam)
4. add RG header to merged file (Picard AddOrReplaceReadGroups)
5. create SAM index for merged file (samtools index)
6. run RNA-SeQC

Steps 1-3 can be varied, depending on the original sorting of the files. I don't think the order you have done things in should make a difference.

Chris
offspring is offline   Reply With Quote
Old 08-19-2013, 09:45 AM   #14
id0
Senior Member
 
Location: USA

Join Date: Sep 2012
Posts: 130
Default

Quote:
Originally Posted by offspring View Post
4. For paired-end reads where both ends are unmapped, Tophat does not set the "mate is unmapped" (0x8) SAM flag on either read. This has to be fixed manually.
What is a good way to fix this manually?

How come this step was not included in the linked fix_tophat_unmapped_reads.py script? Is there some caveat?
id0 is offline   Reply With Quote
Old 08-19-2013, 10:50 AM   #15
offspring
Member
 
Location: Lund, Sweden

Join Date: Mar 2013
Posts: 32
Default

Quote:
Originally Posted by id0 View Post
What is a good way to fix this manually?

How come this step was not included in the linked fix_tophat_unmapped_reads.py script? Is there some caveat?
It's included, lines 85-89 in the current version. However, the bug has been fixed in TopHat 2.0.9.
offspring is offline   Reply With Quote
Old 08-19-2013, 01:48 PM   #16
id0
Senior Member
 
Location: USA

Join Date: Sep 2012
Posts: 130
Default

Quote:
Originally Posted by offspring View Post
It's included, lines 85-89 in the current version. However, the bug has been fixed in TopHat 2.0.9.
That's what it looked like. However, I tried running this earlier today on TopHat 2.0.9 data. The script ran successfully. When I ran Picard on the merged file, I got "Mapped mate should have mate reference name" errors.

Eventually, Picard terminated with this:
Code:
Exception in thread "main" net.sf.samtools.SAMException: Exception when processing alignment for BAM index HISEQ01:514:H812AADXX:1:2105:9732:29000 1/2 51b unmapped read.
	at net.sf.samtools.BAMFileWriter.writeAlignment(BAMFileWriter.java:120)
	at net.sf.samtools.SAMFileWriterImpl.addAlignment(SAMFileWriterImpl.java:168)
	at net.sf.picard.sam.AddOrReplaceReadGroups.doWork(AddOrReplaceReadGroups.java:100)
	at net.sf.picard.cmdline.CommandLineProgram.instanceMain(CommandLineProgram.java:177)
	at net.sf.picard.cmdline.CommandLineProgram.instanceMainWithExit(CommandLineProgram.java:119)
	at net.sf.picard.sam.AddOrReplaceReadGroups.main(AddOrReplaceReadGroups.java:66)
Caused by: net.sf.samtools.SAMException: Exception creating BAM index for record HISEQ01:514:H812AADXX:1:2105:9732:29000 1/2 51b unmapped read.
	at net.sf.samtools.BAMIndexer.processAlignment(BAMIndexer.java:94)
	at net.sf.samtools.BAMFileWriter.writeAlignment(BAMFileWriter.java:117)
	... 5 more
I went back to this thread and the only problem I could think of was that last step. If that's not the issue, do you know what may be? This is my first attempt to merge and process TopHat BAM files.

Last edited by id0; 08-19-2013 at 01:50 PM.
id0 is offline   Reply With Quote
Old 08-19-2013, 11:27 PM   #17
offspring
Member
 
Location: Lund, Sweden

Join Date: Mar 2013
Posts: 32
Default

Quote:
Originally Posted by id0 View Post
That's what it looked like. However, I tried running this earlier today on TopHat 2.0.9 data. The script ran successfully. When I ran Picard on the merged file, I got "Mapped mate should have mate reference name" errors.

Eventually, Picard terminated with this:
Code:
Exception in thread "main" net.sf.samtools.SAMException: Exception when processing alignment for BAM index HISEQ01:514:H812AADXX:1:2105:9732:29000 1/2 51b unmapped read.
	at net.sf.samtools.BAMFileWriter.writeAlignment(BAMFileWriter.java:120)
	at net.sf.samtools.SAMFileWriterImpl.addAlignment(SAMFileWriterImpl.java:168)
	at net.sf.picard.sam.AddOrReplaceReadGroups.doWork(AddOrReplaceReadGroups.java:100)
	at net.sf.picard.cmdline.CommandLineProgram.instanceMain(CommandLineProgram.java:177)
	at net.sf.picard.cmdline.CommandLineProgram.instanceMainWithExit(CommandLineProgram.java:119)
	at net.sf.picard.sam.AddOrReplaceReadGroups.main(AddOrReplaceReadGroups.java:66)
Caused by: net.sf.samtools.SAMException: Exception creating BAM index for record HISEQ01:514:H812AADXX:1:2105:9732:29000 1/2 51b unmapped read.
	at net.sf.samtools.BAMIndexer.processAlignment(BAMIndexer.java:94)
	at net.sf.samtools.BAMFileWriter.writeAlignment(BAMFileWriter.java:117)
	... 5 more
I went back to this thread and the only problem I could think of was that last step. If that's not the issue, do you know what may be? This is my first attempt to merge and process TopHat BAM files.
Hmm, the mate unmapped problem looks like the culprit then indeed. You can check your unmapped.bam file with the following command:

Code:
samtools view -f 0x8 unmapped.bam
If the file is OK, there should be at least a couple of read pairs (e.g. two reads with the same name) in there. I'll re-check what TopHat does and follow up with a new bug report to the developers if needed.

I disabled this specific piece of fixup code for TopHat > 2.0.8. You can enable it manually by simply changing "False" to "True" on line 43 for now.

EDIT: I can confirm that the bug in TopHat is still there. I've updated the script to make the fixup code unconditional again.

Last edited by offspring; 08-20-2013 at 05:21 AM.
offspring is offline   Reply With Quote
Old 08-20-2013, 07:01 AM   #18
id0
Senior Member
 
Location: USA

Join Date: Sep 2012
Posts: 130
Default

Quote:
Originally Posted by offspring View Post
Hmm, the mate unmapped problem looks like the culprit then indeed. You can check your unmapped.bam file with the following command:

Code:
samtools view -f 0x8 unmapped.bam
If the file is OK, there should be at least a couple of read pairs (e.g. two reads with the same name) in there. I'll re-check what TopHat does and follow up with a new bug report to the developers if needed.

I disabled this specific piece of fixup code for TopHat > 2.0.8. You can enable it manually by simply changing "False" to "True" on line 43 for now.

EDIT: I can confirm that the bug in TopHat is still there. I've updated the script to make the fixup code unconditional again.
Looks like you already checked yourself, but just to confirm, I am not getting any reads with that flag. The BAM file has over 100,000,000 reads, so that should definitely be plenty.

Thanks for the quick follow-up! I'll try the updated script and see how it goes.

Also, I tried running Picard on the faulty merged file without CREATE_INDEX argument. It still spits out "Mapped mate should have mate reference name" errors, but completes without terminating. Indexing with samtools works. The merged file still has the same number of reads before and after Picard processing, so the erroneous reads are not being thrown away. The old script might still be useable.
id0 is offline   Reply With Quote
Old 08-20-2013, 07:17 AM   #19
id0
Senior Member
 
Location: USA

Join Date: Sep 2012
Posts: 130
Default

I am still getting Picard "Mapped mate should have mate reference name" errors with the new fixed unmapped.bam. Perhaps that particular step is not the culprit.
id0 is offline   Reply With Quote
Old 08-27-2013, 06:13 AM   #20
offspring
Member
 
Location: Lund, Sweden

Join Date: Mar 2013
Posts: 32
Default

Quote:
Originally Posted by id0 View Post
I am still getting Picard "Mapped mate should have mate reference name" errors with the new fixed unmapped.bam. Perhaps that particular step is not the culprit.
Yes, this error occurred for files generated with TopHat < 2.0.7. Basically I messed up the order in which the processing steps should be performed. The updated version should fix this.
offspring is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 08:16 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO