SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Solution found: For Cuffdiff/links 2.0.2 Make cufflinks FPKM match Cuffdiff FPKM NGSfan RNA Sequencing 4 04-16-2013 08:10 AM
cufflinks FPKM >>> Cuffdiff FPKM peromhc Bioinformatics 6 10-17-2012 02:07 PM
How to decide FPKM fo known genes zun RNA Sequencing 4 12-02-2010 04:41 PM
filtering out reads from abundant transcripts before using velevt Marco Bioinformatics 2 02-03-2010 10:54 AM

Reply
 
Thread Tools
Old 02-15-2013, 12:36 PM   #1
uniportdb
Junior Member
 
Location: san diego

Join Date: Jun 2011
Posts: 5
Default CuffDiff: genes with highly abundant reads have FPKM 0.

I just started learning rna-seq data anlaysis following Nature Protocols 7, 562–578 (2012).
I used CuffDiff after tophat, but the genes with highly abundant reads have FPKM 0.
I tried all the different normalization options in CuffDiff, and --max-bundle-frags 2000000, but still FPKM 0 for the genes with the largest number of mapped reads. Is there any upper bound like Microarray excludes the saturated spots ?

I added example below,
In sample A, it has FPKM 0, because it has the most number of reads, but the same gene in sample B has FPKM 3789, because it's in the confidence zone in sample B ? Please, help me to get FPKM for those genes with highly abundant reads. How can I get FPKM for PM_0405A60 from the example below?
Thanks,


Both examples below were sorted by the # reads in the descending order.
I counted the number of reads using 'htseq-count'

Sample A

Gene | # reads | FPKM
PYYM_0405060 | 1447079 | 0
PYYM_1351050 | 675926 | 0
PYYM_1007060 | 559162 | 0
PYYM_1209040 | 421148 | 29315.7

Sample: B
Gene | # reads | FPKM
PYYM_0501060 | 1633262 | 0
PYYM_1351050 | 757339 | 0
PYYM_0405060 | 552553 | 3789.85

CuffDiff –verbose printed the below; PM_0405A60’s loci is PyYM_04_v1:214849-216007


Inspecting bundle PyYM_04_v1:206968-210685 with 5956 reads
Inspecting bundle PyYM_04_v1:211950-212458 with 368 reads
Inspecting bundle PyYM_04_v1:213051-213787 with 2864 reads

Inspecting bundle PyYM_04_v1:214849-216007 with 943663 reads

Inspecting bundle PyYM_04_v1:218737-223186 with 746 reads
Inspecting bundle PyYM_04_v1:223748-224267 with 889 reads
Inspecting bundle PyYM_04_v1:225620-226957 with 399 reads
Inspecting bundle PyYM_04_v1:227958-238759 with 10900 reads

Last edited by uniportdb; 02-18-2013 at 04:50 PM.
uniportdb is offline   Reply With Quote
Old 02-15-2013, 06:35 PM   #2
paulk
Junior Member
 
Location: Toronto, Canada

Join Date: Nov 2010
Posts: 4
Default

I encountered something like this last year, where I was getting transcripts flagged as HIDATA in Cufflinks output.

You might try increasing the --max-bundle-frags setting in from its default setting to get around this issue. See:

--max-bundle-frags <int> Sets the maximum number of fragments a locus may have before being skipped. Skipped loci are listed in skipped.gtf. Default: 1000000

http://cufflinks.cbcb.umd.edu/manual.html
paulk is offline   Reply With Quote
Old 02-15-2013, 09:44 PM   #3
kadircaner
Member
 
Location: Houston,TX

Join Date: Jun 2011
Posts: 13
Default

I'm having the same problem but in my case there are no genes in the skipped.gtf file, so it's not because of HIDATA flag but there is another problem that I couldnt figure out yet... Any help would be really appreciated!!
kadircaner is offline   Reply With Quote
Old 02-16-2013, 10:09 PM   #4
uniportdb
Junior Member
 
Location: san diego

Join Date: Jun 2011
Posts: 5
Default

Thank you, PaulK.

I tried --max-bundle-frags 2000000, but still 0 FPKM.
And then I tried --max-bundle-frags 3000000, at last I have none-zero FPKM 107219.
I guess it's paired-end, so the max should be > 2 * No. reads.

Last edited by uniportdb; 02-18-2013 at 04:59 PM.
uniportdb is offline   Reply With Quote
Reply

Tags
cuffdiff, cufflinks, fpkm, reads

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 05:32 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO