SEQanswers

Go Back   SEQanswers > Sequencing Technologies/Companies > Illumina/Solexa



Similar Threads
Thread Thread Starter Forum Replies Last Post
Masurca error - assembler deleted prior to being run AeonJeffJ Bioinformatics 2 06-06-2018 12:41 AM
MaSuRCA error bsp017 Illumina/Solexa 18 05-15-2016 11:23 PM
Minimus2 error at step 41 k2bhide Bioinformatics 5 04-18-2014 02:31 AM
MaSuRCA install error Volklor Bioinformatics 6 01-22-2014 07:10 AM
Error during Bfast match step James W. MacDonald Bioinformatics 2 01-05-2011 07:15 AM

Reply
 
Thread Tools
Old 11-20-2015, 02:03 PM   #1
crd1859
Junior Member
 
Location: Virginia

Join Date: Dec 2012
Posts: 1
Default MaSuRCA error during CA scaffolding step

I'm trying to use MaSuRCA v.3.1.3 for an assembly of a genome with an approximate size of .5Gb, composed of Illumina HiSeq and MiSeq reads. I have used the same machine and setup to assemble genomes both a quarter and half this size with no issues, composed of both HiSeq only, MiSeq only, and HiSeq and MiSeq. The assembly proceeds normally until the scaffolding stage, at which point an error of the following sort occurs and is reported in runCA3.out:

Last few lines of the relevant log file (/home/assemblies/masurca/CA/7-0-CGW/cgw.out):

...processed 19900000 unitigs.
...processed 20000000 unitigs.
...processed 20100000 unitigs.
...processed 20200000 unitigs.
...processed 20300000 unitigs.
...processed 20400000 unitigs.
...processed 20500000 unitigs.
...processed 20600000 unitigs.
...processed 20700000 unitigs.
...processed 20800000 unitigs.
...processed 20900000 unitigs.
...processed 21000000 unitigs.
...processed 21100000 unitigs.
...processed 21200000 unitigs.
...processed 21300000 unitigs.
...processed 21400000 unitigs.
...processed 21500000 unitigs.
...processed 21600000 unitigs.
ERROR: Unitig 21631200 has no placement; probably not run through consensus.
cgw: Input_CGW.C:117: int ProcessInput(int, int, char**): Assertion `1 == GetNumIntUnitigPoss(uma->u_list)' failed.

----------------------------------------
Failure message:

scaffolder failed

This error message is somewhat generic to runCA but is suggested to have been a bug fixed in newer versions of Celera. I also tried the fixes described in the following post, with no luck:

http://sourceforge.net/p/wgs-assembl...sage/30881670/

Thanks in advance for any suggestions you might provide.
crd1859 is offline   Reply With Quote
Old 01-09-2018, 08:25 AM   #2
svitlana
Member
 
Location: Brussels

Join Date: Jun 2017
Posts: 14
Default

Hello crd1859! Did you find a solution for your problem? I have the same issue with my Illumina HiSeq data (MaSuRCA version 3.2.2).
svitlana is offline   Reply With Quote
Old 01-11-2018, 04:23 AM   #3
svitlana
Member
 
Location: Brussels

Join Date: Jun 2017
Posts: 14
Default

I finally contacted MaSuRCA developers and they explained that it is a weakness of Celera assembler appearing when the coverage is too high. They propose two workarounds when it happens:
1. decrease the coverage;
2. use SOAPdenovo2 for contigging/scaffolding by setting SOAP_ASSEMBLY to 1.
svitlana is offline   Reply With Quote
Old 02-13-2018, 02:31 PM   #4
milw
Director NGS Services, Lucigen
 
Location: Madison WI USA

Join Date: Dec 2013
Posts: 11
Default

So is there any chance it was fixed in the latest MaSuRCA 3.2.5 released Feb 13 2018? I suppose I should check the changelogs!
__________________
Scott Monsma
Sr Scientist at Lucigen
milw is offline   Reply With Quote
Old 02-16-2018, 10:21 AM   #5
svitlana
Member
 
Location: Brussels

Join Date: Jun 2017
Posts: 14
Default

Hello milw,

I don't think this problem is fixed in the latest version since it is a problem in Celera assembler (and not in MaSuRCA itself). But it seems that it only occurs when running assemblies on Illumina data only. For hybrid assemblies MaSuRCA uses another version of Celera, which is more stable to unitig consensus failures.
svitlana is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 09:46 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO