SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to speed up Mosaikaligner on Helicos reads? feng Bioinformatics 0 06-27-2011 07:39 PM
GAII low number of mapped reads aligenie Bioinformatics 3 06-22-2011 12:55 AM
Help me!!!!! low % of properly paired reads!!! Trudy Bioinformatics 1 05-25-2011 12:26 AM
low percentage of reads mapped rahilsethi SOLiD 3 09-13-2010 07:01 AM
MosaikAligner hsmart Bioinformatics 0 12-09-2009 05:51 AM

Reply
 
Thread Tools
Old 01-29-2010, 08:18 AM   #1
bre
Member
 
Location: United States

Join Date: Dec 2009
Posts: 11
Question MosaikAligner: Low reads/sec

I recently decided on using the Mosaik tools as they support Sanger-sequenced data. However, when I run MosaikAligner on a relatively small query set (1.9MB with 1000 sequences) on a cluster with 48 cores, I have a problem with the number of reads per second processed. When MosaikAligner starts out, I have a read rate of 15 reads/sec but this number continuously drops to below .1 reads/sec at which rate even such a small subset of my reads will take over an hour to align. I tested the aligner first using only a 10 sequence query file from the same data set and the alignment was almost instantaneous. Has anyone else used the Mosaik tools and experienced similar problems?
bre is offline   Reply With Quote
Old 01-29-2010, 08:49 AM   #2
bre
Member
 
Location: United States

Join Date: Dec 2009
Posts: 11
Default

I should mention I'm using these parameters:
-bw 51 -hs 15 -m all -p 48 -mmp .2 -dh
and using a jump database for the reference genome.
bre is offline   Reply With Quote
Old 01-29-2010, 08:59 AM   #3
shahid.manzoor
Junior Member
 
Location: uppsala, sweden

Join Date: Jun 2009
Posts: 8
Default

I want to use Mosaik API but when i execute make command in c++ or perl it give error like MosaikAlignment.h:441: error: ‘uint64_t’ does not name a type
MosaikAlignment.h:442: error: ‘uint64_t’ does not name a type
MosaikAlignment.h:444: error: ‘uint64_t’ does not name a type
MosaikAlignment.h:495: error: ‘uint64_t’ does not name a type
MosaikAlignment.h:497: error: ‘uint64_t’ does not name a type
MosaikAlignment.h:527: error: ‘uint64_t’ does not name a type
MosaikAlignment.h:528: error: ‘uint64_t’ does not name a type
MosaikAlignment.h:579: error: ‘uint64_t’ does not name a type
MosaikAlignment.h:582: error: ‘uint64_t’ does not name a type
MosaikAlignment.h:584: error: ‘uint64_t’ does not name a type
MosaikAlignment.h:585: error: ‘uint64_t’ does not name a type
make: *** [MosaikConversionMain.o] Error 1
so any body can help me how i can use API for c++ or perl.
shahid.manzoor is offline   Reply With Quote
Old 03-19-2010, 05:49 AM   #4
dakl
Member
 
Location: sweden

Join Date: May 2009
Posts: 15
Default

shahid.manzoor, you should start a new thread with your question instead of adding to threads regarding other topics...

Anyway, back to bre's question. I have the exact same problem. I have Illumina 76-mers from exome-capture experments and aligning 1M reads to chr 21 of hg19 using the parameters

Code:
-mm 12 -act 35 -p 6 -bw 29
on my 8-core, 108Gb machine. The alignment is roughly 15reads/sec initally but slowly falling to <1 read/sec. I'm not using a jump database for this.

Anyone else seen and/or solved this?

Thanks
Daniel
dakl is offline   Reply With Quote
Old 03-19-2010, 11:44 AM   #5
bre
Member
 
Location: United States

Join Date: Dec 2009
Posts: 11
Default

Ultimately I decided Mosaik wasn't suited to my needs so unfortunately I can't give you a solution...
bre is offline   Reply With Quote
Reply

Tags
mosaik, mosaikaligner, reads per sec

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 04:40 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO