SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
TGICL for denovo transcriptome gfmgfm Bioinformatics 16 01-24-2013 03:59 PM
TGICL fasta vs refdb Daniel Fernandez Bioinformatics 0 11-29-2011 08:25 PM
Need help for installation of AMOS-2.0.8 ketan_bnf Bioinformatics 1 11-30-2010 07:23 AM
MAQ installation ketan_bnf Bioinformatics 1 11-13-2010 07:41 AM
CAP3 parameters within TGICL pipeline AndreaB Bioinformatics 7 11-04-2010 10:01 AM

Reply
 
Thread Tools
Old 11-19-2011, 10:00 PM   #1
Daniel Fernandez
Member
 
Location: Lima. Perú

Join Date: Nov 2011
Posts: 31
Default TGICL installation

Hi everyone

This is my problem, I've tried to install TGICL for clustering EST, from
http://sourceforge.net/projects/tgicl/
My machine is Linux 32-bits, Ubuntu 11.10

I decompress the file perl-tgicl_2.1-1_all.deb: tar xcvf perl-tgicl_2.1-1_all.deb
Then I copied all files from perl-tgicl_2.1-1_all/usr/bin to /usr/local/bin (executables and perl scripts)

But when I try to run tgicl in the console appear

Can't locate TGI/Mailer.pm in @INC (@INC contains: /usr/local/bin /etc/perl /usr/local/lib/perl/5.12.4 /usr/local/share/perl/5.12.4 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.12 /usr/share/perl/5.12 /usr/local/lib/site_perl .) at /usr/local/bin/tgicl line 12.
BEGIN failed--compilation aborted at /usr/local/bin/tgicl line 12.

Well I'm confuse whit this, please can you help me with this.

Thanks

Daniel Fernandez
Daniel Fernandez is offline   Reply With Quote
Old 11-21-2011, 05:37 AM   #2
sklages
Senior Member
 
Location: Berlin, DE

Join Date: May 2008
Posts: 628
Default

Point PERL5LIB to the path where TGI::Mailer.pm is located, e.g.

Code:
export PERL5LIB=/usr/share/perl5:$PERL5LIB
or wherever your Mailer.pm containing folder (TGI) is located. To find yours,

Code:
find /usr/ -type d -name TGI 2>/dev/null
should work.

Then you should be able to start tgicl (or get the next error ;-) )

hth,
Sven
sklages is offline   Reply With Quote
Old 11-21-2011, 08:48 AM   #3
Daniel Fernandez
Member
 
Location: Lima. Perú

Join Date: Nov 2011
Posts: 31
Default TGICL installation, new error

Well I did

$ find / -type d -name TGI 2>/dev/null
/home/dnl/Genetics/Tools/TGICL/tgicl/usr/share/perl5/TGI
/home/dnl/.local/share/Trash/files/perl-tgicl_2.1-1_all/usr/share/perl5/TGI

So

Code:
export PERL5LIB=/home/dnl/Genetics/Tools/TGICL/tgicl/usr/share/perl5:$PERL5LIB
And it get me the follow error

Code:
Use of :locked is deprecated at /home/dnl/Genetics/Tools/TGICL/tgicl/usr/share/perl5/TGI/DBDrv.pm line 36.
Can't locate File/HomeDir.pm in @INC (@INC contains: /usr/local/bin /home/dnl/Genetics/Tools/TGICL/tgicl/usr/share/perl5 /etc/perl /usr/local/lib/perl/5.12.4 /usr/local/share/perl/5.12.4 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.12 /usr/share/perl/5.12 /usr/local/lib/site_perl .) at /home/dnl/Genetics/Tools/TGICL/tgicl/usr/share/perl5/TGI/Util.pm line 32.
BEGIN failed--compilation aborted at /home/dnl/Genetics/Tools/TGICL/tgicl/usr/share/perl5/TGI/Util.pm line 32.
Compilation failed in require at /usr/local/bin/tgicl line 14.
BEGIN failed--compilation aborted at /usr/local/bin/tgicl line 14.

I tried copying the HomeDir.pm file into TGI directory
My original HomeDir.pm file is in:
$ find / -name HomeDir.pm 2>/dev/null
/home/dnl/.cpan/build/File-HomeDir-0.98-wwI0wc/lib/File/HomeDir.pm
/home/dnl/.cpan/build/File-HomeDir-0.98-wwI0wc/blib/lib/File/HomeDir.pm

But the terminal get me the same error.
What can I do?
Daniel Fernandez is offline   Reply With Quote
Old 11-21-2011, 12:05 PM   #4
sklages
Senior Member
 
Location: Berlin, DE

Join Date: May 2008
Posts: 628
Default

Hi Daniel,

install File::HomeDir correctly via apt-get/synaptic and retry (libfile-homedir-perl).

saludos, Sven
sklages is offline   Reply With Quote
Old 11-21-2011, 12:46 PM   #5
Daniel Fernandez
Member
 
Location: Lima. Perú

Join Date: Nov 2011
Posts: 31
Default

Thanks, that eliminated the second error, but the DBDrv.pm line 36 still generates an error.

Code:
$ tgicl AlpEST.fasta 
Use of :locked is deprecated at /home/dnl/Genetics/Tools/TGICL/tgicl/usr/share/perl5/TGI/DBDrv.pm line 36.

Package main, File /usr/local/bin/tgicl, Line 29 == 
Package main, File /usr/local/bin/tgicl, Line 30 == Failed to find tgicl.cfg config file in ./tgicl.cfg /home/dnl/tgicl.cfg /etc/tgicl.cfg 
[ TGI::Exception has been thrown ]


Package main, File /usr/local/bin/tgicl, Line 29 == 
Package main, File /usr/local/bin/tgicl, Line 30 == Failed to find tgicl.cfg config file in ./tgicl.cfg /home/dnl/tgicl.cfg /etc/tgicl.cfg 
[ TGI::Exception has been thrown ]


Package main, File /usr/local/bin/tgicl, Line 29 == 
Package main, File /usr/local/bin/tgicl, Line 30 == Failed to find tgicl.cfg config file in ./tgicl.cfg /home/dnl/tgicl.cfg /etc/tgicl.cfg 
[ TGI::Exception has been thrown ]
Daniel Fernandez is offline   Reply With Quote
Old 11-21-2011, 01:03 PM   #6
Daniel Fernandez
Member
 
Location: Lima. Perú

Join Date: Nov 2011
Posts: 31
Default

The BDBrv.pm line 36 gets me an error:

line 36: sub new :locked {

And the tgicl lines:

Line 29: eval {
Line 30: $gConfig = loadConfig( "tgicl.cfg" );
Line 31: };

My tgicl.cfg file is in /home/dnl/Genetics/Tools/TGICL/tgicl/etc/tgicl.cfg
I'm confused
Daniel Fernandez is offline   Reply With Quote
Old 11-21-2011, 01:17 PM   #7
sklages
Senior Member
 
Location: Berlin, DE

Join Date: May 2008
Posts: 628
Default

Quote:
Originally Posted by Daniel Fernandez View Post
The BDBrv.pm line 36 gets me an error:

line 36: sub new :locked {

And the tgicl lines:

Line 29: eval {
Line 30: $gConfig = loadConfig( "tgicl.cfg" );
Line 31: };

My tgicl.cfg file is in /home/dnl/Genetics/Tools/TGICL/tgicl/etc/tgicl.cfg
I'm confused
The first one is just a warning; TGICL is veeery old.

About loading the config file just have a look at the message where the config is searched:
Code:
./tgicl.cfg /home/dnl/tgicl.cfg /etc/tgicl.cfg
I'd keep the configs on a "per-assembly-basis"; copy the default config in the current dir, edit an then rerun tgicl.

Hopefully you are not trying to cluster a few illumina lanes with tgicl :-)

cheers,
Sven
sklages is offline   Reply With Quote
Old 11-21-2011, 03:41 PM   #8
Daniel Fernandez
Member
 
Location: Lima. Perú

Join Date: Nov 2011
Posts: 31
Default

Thanks, yes I try cluster few reads.
I copied the tgicl.cfg in /etc , but when I run tgicl

Code:
$ tgicl AlpEST.fasta 
Use of :locked is deprecated at /home/dnl/Genetics/Tools/TGICL/tgicl/usr/share/perl5/TGI/DBDrv.pm line 36.
Error: cannot find input file ''
And my input is correct.
Daniel Fernandez is offline   Reply With Quote
Old 11-22-2011, 12:49 AM   #9
sklages
Senior Member
 
Location: Berlin, DE

Join Date: May 2008
Posts: 628
Default

How does your cfg look like? Do you have an empty entry for DB_FILE in the cfg file?
sklages is offline   Reply With Quote
Old 11-22-2011, 05:01 AM   #10
Daniel Fernandez
Member
 
Location: Lima. Perú

Join Date: Nov 2011
Posts: 31
Default

Yes, DB_FILE have a empty entry

DB_FILE =

Code:
# TGICL Configuration file
#

# Generate HTML reports. Default value 'no'
HTML_REPORT = yes

# The sequence file in fasta format 
DB_FILE =

# Quality file
#DB_QUALITY =

# performs more restrictive, layout-based clustering
# instead of simple transitive closure. Default value 'no'
#CLUSTER_LAYOUT = yes

#keep only sequence names with prefix SEQ_FILTER_PREFIX
# SEQ_FILTER_PREFIX = 

# skip the mgblast searches (assumed done) but restrict 
# further clustering analysis to only the sequences in <seq_list>
#
#SEQ_RESTRICT_LIST = 

# pass the ASM_PARAM_FILE as the custom parameter file 
# to the assembly program <asmprog.psx>
#ASM_PARAM_FILE =       

# A number means to use the specified number of CPUs on
# the local machine. A file name means to use the list of
# PVM nodes given in that file. Default value 1.
#PVM_OR_CPU_LIST =

# user to send email notifications.
# USER_MAIL =

# maximum length of unmatched overhangs. Default value 30.
OVERHANG_LEN = 30

# miminum overlap length. Default value 40.
MIN_OVERLAP = 40

# minimum percent identity for overlaps  (PID). Default value 94.
MIN_OVERLAP_PID = 94

# only run the distributed pairwise searches and exit.
# That is no sorting of the pairwise overlaps and no
# clusters generated. Default value 'no'
SEARCHING_ONLY = no

# only run the distributed pairwise searches 
# and create the sorted & compressed *_hits.Z file.
# Default value 'no'
SEARCH_AND_SORT = no

# use given CAP3_OPTIONS instead of the default ones
#CAP3_OPTIONS =

# use CLONE_LIST_FILE to put in the same cluster all sequence names
# from the same line.
#CLONE_LIST_FILE =

# ignore lower-case masking in <fasta_db> sequences. Default value 'no'
IGNORE_MASKING = no

# store gap information for all pairwise alignments. Default value 'no'
STORE_GAP_INFO = no

# do not perform all-vs-all search, but search DB_FILE against 
# TARGET_DB_FILE instead. Stops after the pairwise hits are generated.
# TARGET_DB_FILE =
Daniel Fernandez is offline   Reply With Quote
Old 11-22-2011, 05:09 AM   #11
sklages
Senior Member
 
Location: Berlin, DE

Join Date: May 2008
Posts: 628
Default

Just comment that line out and give it a try with your command line used ...
sklages is offline   Reply With Quote
Old 11-22-2011, 06:58 AM   #12
Daniel Fernandez
Member
 
Location: Lima. Perú

Join Date: Nov 2011
Posts: 31
Default

Thanks, it works but

1. Is it necessary to write the input in the tgicl.cfg?
DB_FILE = AlpEST.fasta
Because I thought it work only with "tgicl AlpEST.fasta" (apart from other parameters)

2. The tgicl only run when my fasta is in file without spaces in the name. e.g.
When my fasta is in "TEST1/AlpEST.fasta" => Ok, it work
When my fasta is in "TEST 1/AlpEST.fasta" => ERROR, dont work

Code:
../TEST1$ tgicl AlpEST.fasta 
Use of :locked is deprecated at /home/dnl/Genetics/Tools/TGICL/tgicl/usr/share/perl5/TGI/DBDrv.pm line 36.
tgicl (AlpEST.fasta) finished on machine 
                 in /home/dnl/Genetics/LAB/Results/TGICL1, without a detectable error.
Code:
.../TEST 1$ tgicl AlpEST.fasta 
Use of :locked is deprecated at /home/dnl/Genetics/Tools/TGICL/tgicl/usr/share/perl5/TGI/DBDrv.pm line 36.
tgicl (AlpEST.fasta) encountered an error at step clustering
                 Working directory was /home/dnl/Genetics/LAB/Results/TGICL 1.
Daniel Fernandez is offline   Reply With Quote
Old 11-22-2011, 11:36 PM   #13
sklages
Senior Member
 
Location: Berlin, DE

Join Date: May 2008
Posts: 628
Default

Quote:
Originally Posted by Daniel Fernandez View Post
Thanks, it works but

1. Is it necessary to write the input in the tgicl.cfg?
DB_FILE = AlpEST.fasta
Because I thought it work only with "tgicl AlpEST.fasta" (apart from other parameters)

2. The tgicl only run when my fasta is in file without spaces in the name. e.g.
When my fasta is in "TEST1/AlpEST.fasta" => Ok, it work
When my fasta is in "TEST 1/AlpEST.fasta" => ERROR, dont work

Code:
../TEST1$ tgicl AlpEST.fasta 
Use of :locked is deprecated at /home/dnl/Genetics/Tools/TGICL/tgicl/usr/share/perl5/TGI/DBDrv.pm line 36.
tgicl (AlpEST.fasta) finished on machine 
                 in /home/dnl/Genetics/LAB/Results/TGICL1, without a detectable error.
Code:
.../TEST 1$ tgicl AlpEST.fasta 
Use of :locked is deprecated at /home/dnl/Genetics/Tools/TGICL/tgicl/usr/share/perl5/TGI/DBDrv.pm line 36.
tgicl (AlpEST.fasta) encountered an error at step clustering
                 Working directory was /home/dnl/Genetics/LAB/Results/TGICL 1.

1. I thought you have commented out the DB_FILE entry in tgicl.cfg? Then it should work as intented, "tgicl AlpEST.fasta"

2. Just don't use spaces in names when you are working with command line software. It sometimes may work if you are familiar with correct quoting, assuming the software itself is also aware of potential whitespaces in file names. ... Just don't use whitespaces in file names :-)

hth,
Sven
sklages is offline   Reply With Quote
Old 11-23-2011, 08:12 AM   #14
Daniel Fernandez
Member
 
Location: Lima. Perú

Join Date: Nov 2011
Posts: 31
Default TGICL installation (SOLVED)

Thanks very much, sorry for a lot of question, finally it run ...

But only one question more, it's about packages, you tell me about libfile-homedir-perl, I try other method (sudo dpkg -i perl-tgicl.deb) in this method I need libfile-homedir-perl, libfile-spec-perl, lib32z1 and libc6-i386 packages, I installed the first two, but lib32z1 and libc6-i386 I don't find this packages.

Code:
$ sudo dpkg -i perl-tgicl_2.1-1_all.deb 
Selecting previously deselected package perl-tgicl.
(Reading database ... 168568 files and directories currently installed.)
Unpacking perl-tgicl (from perl-tgicl_2.1-1_all.deb) ...
dpkg: dependency problems prevent configuration of perl-tgicl:
 perl-tgicl depends on lib32z1 (>= 1:1.1.4); however:
  Package lib32z1 is not installed.
 perl-tgicl depends on libc6-i386 (>= 2.3); however:
  Package libc6-i386 is not installed.
dpkg: error processing perl-tgicl (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
 perl-tgicl
When I run tgicl with my fasta, the result is the same, so is necessary this packages lib32z1 and libc6.i386, because I don't have any similar package like them (I used apt-cache search). I used sudo apt-get -f install and then I tried search this package again and no result, then I install again (sudo spkg -i ...deb) and the same result, this packages are not installed. Are this packages needed?
Daniel Fernandez is offline   Reply With Quote
Old 11-23-2011, 08:34 AM   #15
sklages
Senior Member
 
Location: Berlin, DE

Join Date: May 2008
Posts: 628
Default

Both are available in current Ubuntu:

libc6-i386: http://packages.ubuntu.com/oneiric/libs/libc6-i386
lib32z1: http://packages.ubuntu.com/oneiric/libs/lib32z1

If these libraries are considered important for TGICL, just install them :-)

cheers,
Sven
sklages is offline   Reply With Quote
Old 11-24-2011, 06:19 AM   #16
Daniel Fernandez
Member
 
Location: Lima. Perú

Join Date: Nov 2011
Posts: 31
Default

I do that you tell me, but when I wrote ./configure the last line have a error

Code:
$ ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... gcc
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
configure: error: you must configure in a separate build directory
and make

Code:
$ make
Makeconfig:85: sysdeps/../config.make: No such file or directory
The GNU C library has not been configured.
Run `configure' to configure it before building.
Try `configure --help' for more details.
make: Failed to remake makefile `sysdeps/../config.make'.
Daniel Fernandez is offline   Reply With Quote
Old 11-24-2011, 06:48 AM   #17
sklages
Senior Member
 
Location: Berlin, DE

Join Date: May 2008
Posts: 628
Default

Quote:
Originally Posted by Daniel Fernandez View Post
I do that you tell me, but when I wrote ./configure the last line have a error

Code:
$ ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... gcc
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
configure: error: you must configure in a separate build directory
and make

Code:
$ make
Makeconfig:85: sysdeps/../config.make: No such file or directory
The GNU C library has not been configured.
Run `configure' to configure it before building.
Try `configure --help' for more details.
make: Failed to remake makefile `sysdeps/../config.make'.
You should find both libraries in your Ubuntu repos; have a look at the links I sent, in which one you wil have to search ...

If you really want to compile on your own, create an extra build dir:

mkdir build
cd build
../src/configure --help

or whatever ...
sklages is offline   Reply With Quote
Old 11-26-2011, 09:45 PM   #18
Daniel Fernandez
Member
 
Location: Lima. Perú

Join Date: Nov 2011
Posts: 31
Default

Well, when I run the tgicl, the first cluster have more than 1700 reads (and these are assembled in more than 200 contigs) and the rest have less than 100 reads.

I only run: tgicl AlpEST.fasta

I check the tgicl.cfg, may be here is the problem. I thought the tgicl compared with all Gene Index Database from TIGR by default, or I can wrote the database (all mammals for example)

-----------------------
# do not perform all-vs-all search, but search DB_FILE against
# TARGET_DB_FILE instead. Stops after the pairwise hits are generated.
# TARGET_DB_FILE =
-----------------------
Daniel Fernandez is offline   Reply With Quote
Old 11-27-2011, 02:24 AM   #19
sklages
Senior Member
 
Location: Berlin, DE

Join Date: May 2008
Posts: 628
Default

Quote:
Originally Posted by Daniel Fernandez View Post
Well, when I run the tgicl, the first cluster have more than 1700 reads (and these are assembled in more than 200 contigs) and the rest have less than 100 reads.

I only run: tgicl AlpEST.fasta

I check the tgicl.cfg, may be here is the problem. I thought the tgicl compared with all Gene Index Database from TIGR by default, or I can wrote the database (all mammals for example)

-----------------------
# do not perform all-vs-all search, but search DB_FILE against
# TARGET_DB_FILE instead. Stops after the pairwise hits are generated.
# TARGET_DB_FILE =
-----------------------
Not sure what you are trying to accomplish ... if you just want to cluster and assemble your sequences you did it the right way. Maybe you want to alter a few parameters?
sklages is offline   Reply With Quote
Old 10-05-2012, 12:16 PM   #20
Kate.W
Member
 
Location: Canada

Join Date: Aug 2012
Posts: 10
Default TGICL installation

Quote:
Originally Posted by sklages View Post
1. I thought you have commented out the DB_FILE entry in tgicl.cfg? Then it should work as intented, "tgicl AlpEST.fasta"



hth,
Sven
Hello,

I have been trying to make TGICL work. I get the same error as Daniel Fernandez, after commented out the DB_FILE entry in tgicl.cfg, when I try

$ tgicl test.fasta

Use of :locked is deprecated at .... /perl5/TGI/DBDrv.pm line 36.
tgicl (test.fasta) finished on machine
in /test, without a detectable error.

Seems to work for Daniel Fernandez, but not for me. Any idea? Or any alternative to TGICL? Thanks!
Kate.W is offline   Reply With Quote
Reply

Tags
clustering, est, tgicl

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 11:27 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO