SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
'Properly paired' reads in sam flag from TopHat mapping AdamB Bioinformatics 9 03-08-2012 08:30 AM
Help me!!!!! low % of properly paired reads!!! Trudy Bioinformatics 1 05-25-2011 12:26 AM
SAM file for paired-end ECHo RNA Sequencing 0 04-21-2011 11:55 PM
How to check if reads are properly paired in mate-pair data? genepool_bee Bioinformatics 2 02-22-2011 02:07 AM
Paired read names / SAM qname format misko Bioinformatics 2 06-30-2010 11:14 AM

Reply
 
Thread Tools
Old 06-25-2010, 04:07 PM   #1
jlfmssm
Member
 
Location: Boston

Join Date: Apr 2010
Posts: 14
Smile How to check read are properly paired from SAM file?

I am new for NGS data.
How to check reads are properly paired from SAM file?
It is appreciated someone can point me some programs?

Thanks,
Aimin
jlfmssm is offline   Reply With Quote
Old 06-25-2010, 04:15 PM   #2
nilshomer
Nils Homer
 
nilshomer's Avatar
 
Location: Boston, MA, USA

Join Date: Nov 2008
Posts: 1,285
Default

Quote:
Originally Posted by jlfmssm View Post
I am new for NGS data.
How to check reads are properly paired from SAM file?
It is appreciated someone can point me some programs?

Thanks,
Aimin
Use 'samtools view -X <in.bam>'. All reads with a capital "P" in the flag field are properly paired.
nilshomer is offline   Reply With Quote
Old 06-25-2010, 05:41 PM   #3
jlfmssm
Member
 
Location: Boston

Join Date: Apr 2010
Posts: 14
Default

Thanks, I tried, but I got this error:

[aimin@node01 all_sam_data]$ samtools view -X 1382_1.sam/1382_1.sam
[bam_header_read] EOF marker is absent.
[main_samview] fail to read the header.
jlfmssm is offline   Reply With Quote
Old 06-25-2010, 06:00 PM   #4
nilshomer
Nils Homer
 
nilshomer's Avatar
 
Location: Boston, MA, USA

Join Date: Nov 2008
Posts: 1,285
Default

Quote:
Originally Posted by jlfmssm View Post
Thanks, I tried, but I got this error:

[aimin@node01 all_sam_data]$ samtools view -X 1382_1.sam/1382_1.sam
[bam_header_read] EOF marker is absent.
[main_samview] fail to read the header.
Use the "-S" flag to specify that you are inputting a SAM file (not a BAM file). Please read the documentation, including the output when no options/input is specified.
nilshomer is offline   Reply With Quote
Old 06-25-2010, 08:13 PM   #5
jlfmssm
Member
 
Location: Boston

Join Date: Apr 2010
Posts: 14
Default

but I got this:
[aimin@node01 all_sam_data]$ samtools view -S -X 1382_1.sam/1382_1.sam -o 1382_1_test.out
[samopen] no @SQ lines in the header.
[sam_read1] missing header? Abort!
What I should do now?
jlfmssm is offline   Reply With Quote
Old 06-25-2010, 11:23 PM   #6
nilshomer
Nils Homer
 
nilshomer's Avatar
 
Location: Boston, MA, USA

Join Date: Nov 2008
Posts: 1,285
Default

Quote:
Originally Posted by jlfmssm View Post
but I got this:
[aimin@node01 all_sam_data]$ samtools view -S -X 1382_1.sam/1382_1.sam -o 1382_1_test.out
[samopen] no @SQ lines in the header.
[sam_read1] missing header? Abort!
What I should do now?
The lines "no @SQ lines in the header" and "missing header?" should tell you to check the header in the SAM file. Is there one? If not, you have to feed in your reference with the "-T" option.
nilshomer is offline   Reply With Quote
Reply

Tags
paired end

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 01:33 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO