SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Library size exact definition please AurelieMLB Bioinformatics 1 04-14-2016 02:56 AM
perl script to exact sequences by name list pony2001mx Bioinformatics 6 11-12-2013 05:35 PM
exact match with bowtie2 papori General 0 06-04-2013 02:44 AM
How to use Fisher's exact test in R beefeng123 Bioinformatics 1 07-18-2012 12:12 AM
Fishers Exact test blast2go detq182 Bioinformatics 0 02-29-2012 02:57 PM

Reply
 
Thread Tools
Old 01-31-2017, 08:58 AM   #1
sbcn
Member
 
Location: spain

Join Date: Oct 2012
Posts: 16
Default RIPSeeker "Error in NSBS(i, x, exact = exact, upperBoundIsStrict = !allow.append) : .

Hi all,

I am using ripSeek function from RIPSeeker package (on a RIP-seq data set), the following way:

seekOut <- ripSeek(bamPath=mybamfiles,
cNAME="EXP",
strandType="-",
biomart="ENSEMBL_MART_ENSEMBL",
biomaRt_dataset="hsapiens_gene_ensembl",
host="oct2016.archive.ensembl.org",
goAnno="org.Hs.eg.db",
annotateFormat="txt",
uniqueHit=T,
outDir="results",
exportFormat="BED",
multicore=T
)

It stops with an error, the last lines of the output being:

*** 1 do not have any alignment.
*** 2 do not have any alignment.
*** 3 do not have any alignment.
*** 4 do not have any alignment.
*** 5 do not have any alignment.
*** 6 do not have any alignment.
*** 7 do not have any alignment.
*** 8 do not have any alignment.
*** 9 do not have any alignment.
*** 10 do not have any alignment.
*** 11 do not have any alignment.
*** 12 do not have any alignment.
*** 13 do not have any alignment.
*** 14 do not have any alignment.
*** 15 do not have any alignment.
*** 16 do not have any alignment.
*** 17 do not have any alignment.
*** 18 do not have any alignment.
*** 19 do not have any alignment.
*** 20 do not have any alignment.
*** 21 do not have any alignment.
*** 22 do not have any alignment.
*** X do not have any alignment.
*** Y do not have any alignment.
*** MT do not have any alignment.

Error in NSBS(i, x, exact = exact, upperBoundIsStrict = !allow.append) :
subscript contains NAs or out-of-bounds indices

I have checked different threads and can get rid off the "NSBS.." error when I set strandType to NULL.
But I guess it is a bug? Should I be confident about my results without the strand information?

Also I still get the "... do not have any alignement" output, while the reads I input align to those chromosomes.

Does anyone know what is happening there?

Thanks!

sessionInfo()

R version 3.3.0 (2016-05-03)
Platform: x86_64-redhat-linux-gnu (64-bit)
Running under: Scientific Linux release 6.5 (Carbon)

locale:
[1] LC_CTYPE=en_US.UTF-8 LC_NUMERIC=C
[3] LC_TIME=en_US.UTF-8 LC_COLLATE=en_US.UTF-8
[5] LC_MONETARY=en_US.UTF-8 LC_MESSAGES=en_US.UTF-8
[7] LC_PAPER=en_US.UTF-8 LC_NAME=C
[9] LC_ADDRESS=C LC_TELEPHONE=C
[11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C

attached base packages:
[1] grid stats4 parallel stats graphics grDevices utils
[8] datasets methods base

other attached packages:
[1] GO.db_3.2.2 org.Hs.eg.db_3.2.3
[3] AnnotationDbi_1.32.3 biomaRt_2.26.1
[5] ChIPpeakAnno_3.4.6 RSQLite_1.1-2
[7] VennDiagram_1.6.17 futile.logger_1.4.3
[9] RIPSeeker_1.10.0 rtracklayer_1.30.4
[11] GenomicAlignments_1.6.3 Rsamtools_1.22.0
[13] Biostrings_2.38.4 XVector_0.10.0
[15] SummarizedExperiment_1.0.2 Biobase_2.30.0
[17] GenomicRanges_1.22.4 GenomeInfoDb_1.6.3
[19] IRanges_2.4.8 S4Vectors_0.8.11
[21] BiocGenerics_0.16.1 limma_3.26.9

loaded via a namespace (and not attached):
[1] Rcpp_0.12.8 AnnotationHub_2.2.5
[3] BiocInstaller_1.20.3 regioneR_1.2.3
[5] GenomicFeatures_1.22.13 bitops_1.0-6
[7] futile.options_1.0.0 tools_3.3.0
[9] zlibbioc_1.16.0 digest_0.6.11
[11] memoise_1.0.0 lattice_0.20-33
[13] BSgenome_1.38.0 Matrix_1.2-6
[15] graph_1.48.0 shiny_1.0.0
[17] DBI_0.5-1 httr_1.2.1
[19] multtest_2.26.0 R6_2.2.0
[21] XML_3.98-1.5 survival_2.40-1
[23] RBGL_1.46.0 BiocParallel_1.4.3
[25] ensembldb_1.2.2 lambda.r_1.1.9
[27] matrixStats_0.51.0 htmltools_0.3.5
[29] splines_3.3.0 MASS_7.3-45
[31] xtable_1.8-2 mime_0.5
[33] interactiveDisplayBase_1.8.0 httpuv_1.3.3
[35] RCurl_1.95-4.8
sbcn is offline   Reply With Quote
Reply

Tags
rip-seq, ripseek, ripseeker

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 01:16 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO