SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fastq groomer from command line Giles Bioinformatics 4 12-14-2011 12:04 AM
Want to use extract_genomic_dna in command line louis7781x Bioinformatics 2 12-04-2011 05:51 AM
galaxy command line error gfmgfm Bioinformatics 1 12-28-2010 10:38 PM
SAMtools command line ??? Pawan Noel Bioinformatics 6 11-16-2010 10:42 AM
Tophat command line options ice RNA Sequencing 6 09-02-2010 03:25 PM

Reply
 
Thread Tools
Old 08-16-2010, 11:24 AM   #1
lamasmi
Junior Member
 
Location: san diego

Join Date: Aug 2010
Posts: 3
Default SIFT on the command line

Hi, I am attempting to get sift.jcvi.org to work on our own local machine as a web page, but first let's just talk about getting it to work on the command line.

I went through the README and attempted to run SIFT with their test files like so:

$ bin/SIFT_for_submitting_fasta_seq.csh test/lacI.fasta /projects/cgl/data/swiss.uni test/lacI.subst 2.75

and the result is this:
tail is lacI.fasta
query is /projects/cgl/projects/sift/sift4.0.3/tmp/lacI.fasta.query
cp: cannot access /projects/cgl/projects/sift/sift4.0.3/tmp/lacI.fasta.query
/projects/cgl/misc/biotools/blast-2.2.10/bin/blastpgp: Invalid argument
exiting because stauts not equal to 0
/projects/cgl/projects/sift/sift4.0.3/bin/info_on_seqs: Invalid argument
Output in /projects/cgl/projects/sift/sift4.0.3/tmp/lacI.SIFTprediction

I have searched for what the cp: line might mean, but I haven't gotten anywhere. Any suggestions would be appreciated.

Emily
lamasmi is offline   Reply With Quote
Old 08-17-2010, 09:12 AM   #2
anjana.vr
Junior Member
 
Location: Washington DC

Join Date: May 2010
Posts: 7
Default

Did you check the permissions?
It should have execute permission on all the directories leading to the file.
anjana.vr is offline   Reply With Quote
Old 08-17-2010, 09:32 AM   #3
lamasmi
Junior Member
 
Location: san diego

Join Date: Aug 2010
Posts: 3
Default

Yes, all directories have rwxr-xr-x, rwxr-xr-t. I did some more searching and found that the problem is that when blastpgp runs, no matter what I do I get an "Invalid Argument" returned.
lamasmi is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 03:55 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO