SEQanswers

Go Back   SEQanswers > Applications Forums > RNA Sequencing



Similar Threads
Thread Thread Starter Forum Replies Last Post
Boost library error, running Tophat Aholton RNA Sequencing 17 03-20-2015 05:20 AM
How to make sense of Tophat's output file 'junctions.bed' gsinghal RNA Sequencing 4 09-03-2012 06:49 AM
what wrong with boost? feng Bioinformatics 3 10-16-2011 09:50 AM
Tophat 1.2.0 make error mabentley86 Bioinformatics 0 05-13-2011 01:44 AM
tophat 1.2.0 make error limericksean Bioinformatics 4 04-20-2011 04:16 AM

Reply
 
Thread Tools
Old 12-27-2012, 04:35 AM   #1
wjyzidane
Member
 
Location: beijing

Join Date: Dec 2012
Posts: 13
Default fail to make tophat 2.0.7 because of boost

while i am making tophat after correct configuring:

make: Warning: File `Makefile' has modification time 1.5e+03 s in the future
make all-recursive
make[1]: Entering directory `/data1/qwu/tophat-2.0.7'
make[1]: Warning: File `Makefile' has modification time 1.5e+03 s in the future
Making all in src
make[2]: Entering directory `/data1/qwu/tophat-2.0.7/src'
make[2]: Warning: File `Makefile' has modification time 1.5e+03 s in the future
g++ -Wall -Wno-strict-aliasing -g -gdwarf-2 -Wuninitialized -O3 -DNDEBUG -pthread -I/data1/qwu/boost/boost/boost_1_52_0/boost/include -I/data1/qwu/samtools/include -I./SeqAn-1.3 -o segment_juncs -L/data1/qwu/boost/boost/boost_1_52_0/boost/lib -L/data1/qwu/samtools/lib segment_juncs.o ../src/libtophat.a -lbam -lz -L/data1/qwu/boost/boost/boost_1_52_0/stage/lib
segment_juncs.o: In function `__static_initialization_and_destruction_0':
/data1/qwu/boost/boost/boost_1_52_0/boost/system/error_code.hpp:214: undefined reference to `boost::system::generic_category()'
/data1/qwu/boost/boost/boost_1_52_0/boost/system/error_code.hpp:215: undefined reference to `boost::system::generic_category()'
/data1/qwu/boost/boost/boost_1_52_0/boost/system/error_code.hpp:216: undefined reference to `boost::system::system_category()'
segment_juncs.o: In function `driver(std::basic_istream<char, std::char_traits<char> >&, _IO_FILE*, _IO_FILE*, _IO_FILE*, _IO_FILE*, std::basic_string<char, std::char_traits<char>, std::allocator<char> >&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >&, std::vector<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >&, std::vector<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >&)':
/data1/qwu/tophat-2.0.7/src/segment_juncs.cpp:4949: undefined reference to `boost::thread::join()'
segment_juncs.o: In function `~thread':
/data1/qwu/boost/boost/boost_1_52_0/boost/thread/detail/thread.hpp:179: undefined reference to `boost::thread::detach()'
segment_juncs.o: In function `driver(std::basic_istream<char, std::char_traits<char> >&, _IO_FILE*, _IO_FILE*, _IO_FILE*, _IO_FILE*, std::basic_string<char, std::char_traits<char>, std::allocator<char> >&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >&, std::vector<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >&, std::vector<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >&)':
/data1/qwu/tophat-2.0.7/src/segment_juncs.cpp:5026: undefined reference to `boost::thread::join()'
segment_juncs.o: In function `~thread':
/data1/qwu/boost/boost/boost_1_52_0/boost/thread/detail/thread.hpp:179: undefined reference to `boost::thread::detach()'
segment_juncs.o: In function `thread_exception':
/data1/qwu/boost/boost/boost_1_52_0/boost/thread/exceptions.hpp:49: undefined reference to `boost::system::system_category()'
/data1/qwu/boost/boost/boost_1_52_0/boost/thread/exceptions.hpp:49: undefined reference to `boost::system::system_category()'
segment_juncs.o: In function `~thread_data':
/data1/qwu/boost/boost/boost_1_52_0/boost/thread/detail/thread.hpp:54: undefined reference to `boost::detail::thread_data_base::~thread_data_base()'
/data1/qwu/boost/boost/boost_1_52_0/boost/thread/detail/thread.hpp:54: undefined reference to `boost::detail::thread_data_base::~thread_data_base()'
/data1/qwu/boost/boost/boost_1_52_0/boost/thread/detail/thread.hpp:54: undefined reference to `boost::detail::thread_data_base::~thread_data_base()'
/data1/qwu/boost/boost/boost_1_52_0/boost/thread/detail/thread.hpp:54: undefined reference to `boost::detail::thread_data_base::~thread_data_base()'
segment_juncs.o: In function `thread_data_base':
/data1/qwu/boost/boost/boost_1_52_0/boost/thread/pthread/thread_data.hpp:125: undefined reference to `vtable for boost::detail::thread_data_base'
segment_juncs.o: In function `thread_exception':
/data1/qwu/boost/boost/boost_1_52_0/boost/thread/exceptions.hpp:49: undefined reference to `boost::system::system_category()'
/data1/qwu/boost/boost/boost_1_52_0/boost/thread/exceptions.hpp:49: undefined reference to `boost::system::system_category()'
segment_juncs.o: In function `thread_data':
/data1/qwu/boost/boost/boost_1_52_0/boost/thread/detail/thread.hpp:72: undefined reference to `boost::detail::thread_data_base::~thread_data_base()'
segment_juncs.o: In function `thread<SegmentSearchWorker>':
/data1/qwu/boost/boost/boost_1_52_0/boost/thread/detail/thread.hpp:223: undefined reference to `boost::thread::start_thread()'
segment_juncs.o.rodata._ZTIN5boost6detail11thread_dataI19SegmentSearchWorkerEE[typeinfo for boost::detail::thread_data<SegmentSearchWorker>]+0x10): undefined reference to `typeinfo for boost::detail::thread_data_base'
collect2: ld returned 1 exit status
make[2]: *** [segment_juncs] Error 1
make[2]: Leaving directory `/data1/qwu/tophat-2.0.7/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/data1/qwu/tophat-2.0.7'
make: *** [all] Error 2


i try to add export LD_LIBRARY_PATH=/data1/qwu/bin:$LD_LIBRARY_PATH
to my .bash_profile, but it doesnt work.
desperately ask for help, thanks!
wjyzidane is offline   Reply With Quote
Old 12-27-2012, 07:32 AM   #2
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 7,059
Default

Have you installed the boost libraries from: http://www.boost.org/ and made sure they are in your default path?
GenoMax is offline   Reply With Quote
Old 12-27-2012, 05:58 PM   #3
wjyzidane
Member
 
Location: beijing

Join Date: Dec 2012
Posts: 13
Default

yes, i have installed the boost in the path /data1/qwu/boost/boost/boost_1_52_0

my configure command is:
./configure --prefix=/data1/qwu/tophat_new --with-boost=/data1/qwu/boost/boost/boost_1_52_0/ --with-bam=/data1/qwu/samtools

it seems that the makefile doesn't match the boost path
wjyzidane is offline   Reply With Quote
Old 12-28-2012, 04:51 AM   #4
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 7,059
Default

Quote:
Originally Posted by wjyzidane View Post
yes, i have installed the boost in the path /data1/qwu/boost/boost/boost_1_52_0

my configure command is:
./configure --prefix=/data1/qwu/tophat_new --with-boost=/data1/qwu/boost/boost/boost_1_52_0/ --with-bam=/data1/qwu/samtools

it seems that the makefile doesn't match the boost path
The boost library files are likely down a level below the main boost directory. Try exporting the library path as below (make sure the "lib" directory is there):

export LD_LIBRARY_PATH=/data1/qwu/boost/boost/boost_1_52_0/lib:$LD_LIBRARY_PATH
GenoMax is offline   Reply With Quote
Old 12-28-2012, 05:13 AM   #5
wjyzidane
Member
 
Location: beijing

Join Date: Dec 2012
Posts: 13
Default

i changed it, but it still doesn't work.
my bash_profile is like this:
# .bash_profile

# Get the aliases and functions
if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

# User specific environment and startup programs

PATH=$PATH:$HOME/bin
#Cufflinks
export LIBS="-L/data1/qwu/boost/boost/boost_1_52_0/stage/lib"
export CPPFLAGS="-I/data1/qwu/boost/boost/boost_1_52_0/"
export LD_LIBRARY_PATH=/data1/qwu/boost/boost/boost_1_52_0/stage/lib:$LD_LIBRARY_PATH


export PATH


data1/qwu/boost/boost/boost_1_52_0/stage/lib is the library that contains many files ending up with .so or .a

another problem is that I find the readout (as show before) contains
-I/data1/qwu/boost/boost/boost_1_52_0/boost/include
-L/data1/qwu/boost/boost/boost_1_52_0/boost/lib

but actually i don't have these two directories in my system.

and the most strange thing is that it can be made successfully if I operate on the node where I LOGIN, but fail if I rsh to another node.(I am not the administer so i install all these softwares under my account)
wjyzidane is offline   Reply With Quote
Old 12-28-2012, 05:36 AM   #6
alec
Member
 
Location: Cambridge, MA

Join Date: Apr 2011
Posts: 18
Default

Just a guess, but I think rsh loads your bashrc file rather than bash_profile. If that doesn't work, try printing your environment with rsh and comparing to the local environment.
alec is offline   Reply With Quote
Old 12-28-2012, 05:58 AM   #7
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 7,059
Default

Quote:
Originally Posted by wjyzidane View Post

and the most strange thing is that it can be made successfully if I operate on the node where I LOGIN, but fail if I rsh to another node.(I am not the administer so i install all these softwares under my account)
Since it can be made successfully on the login node means you have all the pieces available there.

What kind of a cluster is this? Can you explicitly source your bash profile like "source ~/.bash_profile" after you rsh?
GenoMax is offline   Reply With Quote
Old 12-28-2012, 06:13 AM   #8
wjyzidane
Member
 
Location: beijing

Join Date: Dec 2012
Posts: 13
Default

Quote:
Originally Posted by alec View Post
Just a guess, but I think rsh loads your bashrc file rather than bash_profile. If that doesn't work, try printing your environment with rsh and comparing to the local environment.
so you mean i need to add it to my bashrc file?
wjyzidane is offline   Reply With Quote
Old 12-28-2012, 06:18 AM   #9
alec
Member
 
Location: Cambridge, MA

Join Date: Apr 2011
Posts: 18
Default

Quote:
Originally Posted by wjyzidane View Post
so you mean i need to add it to my bashrc file?
Yes, or set your environment some other way after you rsh (like `source ~/.bash_profile` as GenoMax suggested)
alec is offline   Reply With Quote
Old 12-28-2012, 06:18 AM   #10
wjyzidane
Member
 
Location: beijing

Join Date: Dec 2012
Posts: 13
Default

Quote:
Originally Posted by GenoMax View Post
Since it can be made successfully on the login node means you have all the pieces available there.

What kind of a cluster is this? Can you explicitly source your bash profile like "source ~/.bash_profile" after you rsh?
i wrote and sourced it after i rsh.
we have one host for administration and multiple host computers for compute. so i login on the administration host first and rsh to computational node to operate.
wjyzidane is offline   Reply With Quote
Old 12-28-2012, 06:51 AM   #11
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 7,059
Default

Quote:
Originally Posted by wjyzidane View Post
i wrote and sourced it after i rsh.
we have one host for administration and multiple host computers for compute. so i login on the administration host first and rsh to computational node to operate.
Interesting. So this is not a real cluster with a job queuing system/cluster OS?

Did "source"ing the bash_profile work?
GenoMax is offline   Reply With Quote
Old 01-03-2013, 03:31 AM   #12
wjyzidane
Member
 
Location: beijing

Join Date: Dec 2012
Posts: 13
Default

Quote:
Originally Posted by alec View Post
Yes, or set your environment some other way after you rsh (like `source ~/.bash_profile` as GenoMax suggested)
sorry for replying late as i cannot login our server during the new year holiday.
I tried but faild.
wjyzidane is offline   Reply With Quote
Old 01-03-2013, 03:36 AM   #13
wjyzidane
Member
 
Location: beijing

Join Date: Dec 2012
Posts: 13
Default

Quote:
Originally Posted by GenoMax View Post
Interesting. So this is not a real cluster with a job queuing system/cluster OS?

Did "source"ing the bash_profile work?
sorry for replying late as i cannot login our server during the new year holiday.
it failed and i give up to install this new version of TOPHAT, and try to map with the older version (2.0.6). it worked fine if i remove the -G option(removing the annotation gtf file).

I install the new one previously becausue the mapping faild and reported as below:
[2012-12-27 17:25:26] Joining segment hits
[FAILED]
Error running 'long_spanning_reads':Warning: 74283 malformed closure
wjyzidane is offline   Reply With Quote
Old 01-03-2013, 07:56 AM   #14
lucapinello
Junior Member
 
Location: Boston

Join Date: Jan 2013
Posts: 1
Smile Solution!

I found a solution.

I installed first BOOST from scarch in my home using the --prefix=/path/to/yourhome option

then I installed tophat using
./configure --with-boost=/path/to/yourhome --prefix=/path/to/yourhome


Hope this help

Luca

http://about.me/lucapinello
lucapinello is offline   Reply With Quote
Old 01-23-2015, 04:03 PM   #15
JamieHeather
@jamimmunology
 
Location: London

Join Date: Nov 2012
Posts: 96
Default

Quote:
Originally Posted by lucapinello View Post

then I installed tophat using
./configure --with-boost=/path/to/yourhome --prefix=/path/to/yourhome
Just for future reference, this thread describes the same problem I was having, and this solution got me past the same block.
JamieHeather is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 06:40 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO