SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
samtools faidx Segmentation fault baohua100 Bioinformatics 19 04-19-2016 07:09 AM
samtools view segmentation fault Axel Bioinformatics 10 07-09-2014 02:06 AM
Segmentation fault with samtools rmdup Azazel Bioinformatics 1 09-05-2013 08:48 AM
samtools mpileup segmentation fault adrian Bioinformatics 8 10-05-2012 07:17 AM
samtools segmentation fault pileup biochemMScstudent Bioinformatics 1 08-14-2012 11:31 AM

Reply
 
Thread Tools
Old 06-17-2014, 02:30 PM   #1
AnushaC
Member
 
Location: San Diego

Join Date: Sep 2013
Posts: 78
Default Samtools Segmentation error while using samtools index

Hi ,
I did re header my bam file and I did sort my file and trying to index my new bam file it is giving me the segmentation error .

################
@SQ SN:chr1 LN:249250621
@SQ SN:chr2 LN:243199373
@SQ SN:chr3 LN:198022430
@SQ SN:chr4 LN:191154276
@SQ SN:chr5 LN:180915260
@SQ SN:chr6 LN:171115067
@SQ SN:chr7 LN:159138663
@SQ SN:chrX LN:155270560
@SQ SN:chr8 LN:146364022
@SQ SN:chr9 LN:141213431
@SQ SN:chr10 LN:135534747
@SQ SN:chr11 LN:135006516
@SQ SN:chr12 LN:133851895
@SQ SN:chr13 LN:115169878
@SQ SN:chr14 LN:107349540
@SQ SN:chr15 LN:102531392
@SQ SN:chr16 LN:90354753
@SQ SN:chr17 LN:81195210
@SQ SN:chr18 LN:78077248
@SQ SN:chr20 LN:63025520
@SQ SN:chrY LN:59373566
@SQ SN:chr19 LN:59128983
@SQ SN:chr22 LN:51304566
@SQ SN:chr21 LN:48129895
@RG ID:SRR203401 PL:ROADMAP PUGF LB:brain.SRR203401 SM:brain.SRR203401
achimmiri@idash-cloud-707:/mnt/oncogxA/anusha/ReadGroup_Bam$
##############
this is my header , I checked with samtools flagstat my new bam file after I did reheader

15158685 + 0 in total (QC-passed reads + QC-failed reads)
0 + 0 duplicates
13730482 + 0 mapped (90.58%:-nan%)
0 + 0 paired in sequencing
0 + 0 read1
0 + 0 read2
0 + 0 properly paired (-nan%:-nan%)
0 + 0 with itself and mate mapped
0 + 0 singletons (-nan%:-nan%)
0 + 0 with mate mapped to a different chr
0 + 0 with mate mapped to a different chr (mapQ>=5)

I checked my bam file manually but I don't see any problem . I am not sure why I am getting segmentation error
AnushaC is offline   Reply With Quote
Old 06-18-2014, 12:16 AM   #2
dpryan
Devon Ryan
 
Location: Freiburg, Germany

Join Date: Jul 2011
Posts: 3,480
Default

Please give the exact command that produced this and the version of samtools that you're using.
dpryan is offline   Reply With Quote
Old 06-18-2014, 01:33 AM   #3
vishnuamaram
Member
 
Location: india

Join Date: Jun 2013
Posts: 42
Default

hey anusha,

there is no error in general while using samtools index, the command line is very simple. let us know what command r u using.

Cross verify whether ur previous steps of samtools are correct or not.
vishnuamaram is offline   Reply With Quote
Old 06-18-2014, 07:01 AM   #4
AnushaC
Member
 
Location: San Diego

Join Date: Sep 2013
Posts: 78
Default

Hi,
Thanks it is working . Bam header is not sorted that why it give segmentation error .
AnushaC is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 09:32 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO