SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
mismatches in maqView (why > 2) saima Bioinformatics 4 03-23-2010 08:10 AM
MaqView RockChalkJayhawk Bioinformatics 2 01-31-2010 09:11 AM
Help with using maqview please lindseyjane Bioinformatics 6 08-25-2009 02:34 AM
Maqview Reference Sequence unionicola Bioinformatics 1 06-11-2009 07:21 AM
maqview upper and lower case AnamikaDarwin Bioinformatics 3 03-21-2009 12:45 AM

Reply
 
Thread Tools
Old 09-04-2009, 08:45 AM   #41
Yu_Sun
Junior Member
 
Location: Uppsala

Join Date: Sep 2009
Posts: 1
Default "bus error" in maqindex

Hi everyone,

I still have the "bus error" problem when I tried to use maqindex command "maqindex -i all.map" . The error message showed as below:

-- Indexing the alignment file 'all.map' ... Bus error

My maqview is the latest version 0.2.6. When I used the previous version 0.2.5, no such bug showed up in the index process. I successfully finished indexing the map file and run maqview. But when I did a few click in the maqview window, an error with Bus error showed up and end the maqview automatically.

I use mac os x 10.5.8. Great thanks to any helpful comments!
Yu_Sun is offline   Reply With Quote
Old 06-04-2010, 07:14 AM   #42
Lspoor
Member
 
Location: Fife, Scotland

Join Date: Mar 2010
Posts: 18
Default Same problem but still no joy following the answer to the thread

Quote:
Originally Posted by Albert N View Post
Heeeelp!

I have some troubles triying to compile maqview-0.2.6 (sorry I'm a beginner).
Install file says: "To compile it, just run"./autogen.sh; ./configure; make"......but when I type ./autogen this is the output:
albert@mambara:~/maqview$ ./autogen.sh
running: aclocal
eval: 1: aclocal: not found
error: while running 'aclocal'

Somebody knows what am I doing wrong?
I had the same problem as Albert N. I followed the instructions in the thread. MaqView is trying to install and the initial configuration seems to go ok but I get the following error messages after I type "make", but I'm not sure what they mean:
g++ -g -O2 -o maqview read_cache.o view_goto.o view_panel.o gl_gui.o MainFrame.o btree.o maqmap_index.o zrio.o stdhashc.o cns_cache.o const.o adler32.o compress.o crc32.o deflate.o gzio.o inffast.o inflate.o infback.o inftrees.o trees.o uncompr.o zutil.o -lGL -lglut -lm
view_panel.o: In function `resetPickMatrixs':
/usr/local/bin/maqview/view_panel.c:270: undefined reference to `gluPickMatrix'
collect2: ld returned 1 exit status
make[1]: *** [maqview] Error 1
make[1]: Leaving directory `/usr/local/bin/maqview'
make: *** [all] Error 2

Any ideas?
Lspoor is offline   Reply With Quote
Old 06-04-2010, 07:16 AM   #43
Lspoor
Member
 
Location: Fife, Scotland

Join Date: Mar 2010
Posts: 18
Default SImilar problem in Maqview installation

Iam also getting the following error when typing in the "make" command as the last step to install the latest version of MAQVIEW, does anyone know what it means?

g++ -g -O2 -o maqview read_cache.o view_goto.o view_panel.o gl_gui.o MainFrame.o btree.o maqmap_index.o zrio.o stdhashc.o cns_cache.o const.o adler32.o compress.o crc32.o deflate.o gzio.o inffast.o inflate.o infback.o inftrees.o trees.o uncompr.o zutil.o -lGL -lglut -lm
view_panel.o: In function `resetPickMatrixs':
/usr/local/bin/maqview/view_panel.c:270: undefined reference to `gluPickMatrix'
collect2: ld returned 1 exit status
make[1]: *** [maqview] Error 1
make[1]: Leaving directory `/usr/local/bin/maqview'
make: *** [all] Error 2
Lspoor is offline   Reply With Quote
Old 06-04-2010, 07:21 AM   #44
sigusn
Member
 
Location: Cambridge, MA

Join Date: Aug 2008
Posts: 19
Default

Hi
I gave up on using maqview. Use this free tool instead, The Integrative Genomics Viewer (IGV).
http://www.broadinstitute.org/igv/
sigusn is offline   Reply With Quote
Old 06-04-2010, 08:18 AM   #45
Lspoor
Member
 
Location: Fife, Scotland

Join Date: Mar 2010
Posts: 18
Question integrative genome viewer

Hi I had a look at this but from what I could see I could only choose from the listed genomes? Mine wasn't in there and I couldn't see a way of uploading your own genome in there?

I'm aligning Illumina paired end reads for bacterial isolates against a related reference genome in MAQ, then trying to view the aligned reads against their reference genome, so that I can visually identify SNPs and the aligned reads. I was using a program called Tablet quite nicely until I updated to the latest version when I encountered problems with uploading my assembly.

Does anyone know of a program that could do similar? I'm giving up on Maqview unless a miracle happens!
Lspoor is offline   Reply With Quote
Old 06-04-2010, 08:27 AM   #46
sigusn
Member
 
Location: Cambridge, MA

Join Date: Aug 2008
Posts: 19
Default

Hi
You can upload your own genomes into the IGV. Just upload the exact same fasta file as you aligned to using MAQ.
sigusn is offline   Reply With Quote
Old 06-04-2010, 09:35 AM   #47
Lspoor
Member
 
Location: Fife, Scotland

Join Date: Mar 2010
Posts: 18
Default

Thanks, I'll have a go!
Lspoor is offline   Reply With Quote
Old 06-04-2010, 06:43 PM   #48
Torst
Senior Member
 
Location: The University of Melbourne, AUSTRALIA

Join Date: Apr 2008
Posts: 275
Default

Quote:
Originally Posted by Lspoor View Post
g++ -g -O2 -o maqview read_cache.o view_goto.o view_panel.o gl_gui.o MainFrame.o btree.o maqmap_index.o zrio.o stdhashc.o cns_cache.o const.o adler32.o compress.o crc32.o deflate.o gzio.o inffast.o inflate.o infback.o inftrees.o trees.o uncompr.o zutil.o -lGL -lglut -lm
view_panel.o: In function `resetPickMatrixs':
/usr/local/bin/maqview/view_panel.c:270: undefined reference to 'gluPickMatrix'
You probably don't have the "glut" libraries installed, or an old version of them. If you are on an RPM based system (Redhat/Suse/...) you may need to install the "mesa-libGLU-devel" package, or equivalent.
Torst is offline   Reply With Quote
Old 06-05-2010, 06:23 AM   #49
Lspoor
Member
 
Location: Fife, Scotland

Join Date: Mar 2010
Posts: 18
Default

I have freeglut3-dev and assoc packages installed on the newest version of Ubuntu? Not sure if I need to try another type of GLUT-dev package?
Lspoor is offline   Reply With Quote
Old 06-30-2010, 07:52 AM   #50
nshrine
Junior Member
 
Location: Leicester, UK

Join Date: Jun 2010
Posts: 1
Default

Quote:
Originally Posted by Lspoor View Post
Iam also getting the following error when typing in the "make" command as the last step to install the latest version of MAQVIEW, does anyone know what it means?

g++ -g -O2 -o maqview read_cache.o view_goto.o view_panel.o gl_gui.o MainFrame.o btree.o maqmap_index.o zrio.o stdhashc.o cns_cache.o const.o adler32.o compress.o crc32.o deflate.o gzio.o inffast.o inflate.o infback.o inftrees.o trees.o uncompr.o zutil.o -lGL -lglut -lm
view_panel.o: In function `resetPickMatrixs':
/usr/local/bin/maqview/view_panel.c:270: undefined reference to `gluPickMatrix'
collect2: ld returned 1 exit status
make[1]: *** [maqview] Error 1
make[1]: Leaving directory `/usr/local/bin/maqview'
make: *** [all] Error 2
I found that you have to add "-lGLU" to get it to compile, change this line in the Makefile:
GLLIBS = -lGL -lglut -lm

to this:
GLLIBS = -lGL -lglut -lGLU -lm
nshrine is offline   Reply With Quote
Old 07-21-2010, 08:51 PM   #51
Ms@New
Member
 
Location: california

Join Date: Jun 2010
Posts: 17
Default

Hi everyone,

I'm trying to install maqview, but I get the

I have the same problem
view_panel.o: In function `resetPickMatrixs':
/home/athena/Desktop/TMP/runHMAQ/maqview-0.2.1/view_panel.c:270: undefined reference to `gluPickMatrix'
collect2: ld returned 1 exit status
make[1]: *** [maqview] Error 1


changing it to GLLIBS = -lGL -lglut -lGLU -lm didn't help

any idea?

I'm new to all this, and I'm trying to install 0.2.1 version. and I'm using a 32 bit ubuntu

Thanks, I'm stuck!
----
later : Actually it did help!
I was just running everything from scratch eachtime
every time u run ./configure, it makes Makefile again,, so after running ./configure. change Makefile, and then run make, or I'm guessing change makefile.generic, so the new makefile would be the modified version

Last edited by Ms@New; 07-21-2010 at 09:53 PM.
Ms@New is offline   Reply With Quote
Reply

Tags
maq, maqview

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 03:22 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO