SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
mismatches in maqView (why > 2) saima Bioinformatics 4 03-23-2010 08:10 AM
MaqView RockChalkJayhawk Bioinformatics 2 01-31-2010 09:11 AM
Help with using maqview please lindseyjane Bioinformatics 6 08-25-2009 02:34 AM
Maqview Reference Sequence unionicola Bioinformatics 1 06-11-2009 07:21 AM
maqview upper and lower case AnamikaDarwin Bioinformatics 3 03-21-2009 12:45 AM

Reply
 
Thread Tools
Old 10-28-2008, 06:33 AM   #1
cgjkjk
Member
 
Location: Roskilde

Join Date: Oct 2008
Posts: 14
Default How to use MAQVIEW?

Hi,
I use this MAQVIEW command "./maqview alo1564.map", to display the alignment. but system replies:

"freeglut (./maqview):unable to creat direct context rendering for window 'M.A.Q View'.
This may hurt performance.
Cannot open view on alo1564.map"


Is there anyone know what wrong is?
cgjkjk is offline   Reply With Quote
Old 10-28-2008, 07:47 AM   #2
ECO
--Site Admin--
 
Location: SF Bay Area, CA, USA

Join Date: Oct 2007
Posts: 1,358
Default

Did you index the map with maqindex -c XXXX.cns YYYY.map ?
ECO is offline   Reply With Quote
Old 10-28-2008, 03:28 PM   #3
cgjkjk
Member
 
Location: Roskilde

Join Date: Oct 2008
Posts: 14
Default

Yes, I did.
Also ran ./zrio make XXXXX.map
cgjkjk is offline   Reply With Quote
Old 10-28-2008, 03:30 PM   #4
ECO
--Site Admin--
 
Location: SF Bay Area, CA, USA

Join Date: Oct 2007
Posts: 1,358
Default

I've had this error when trying to use a newer version of maqview to view .map files from older versions of maq.
ECO is offline   Reply With Quote
Old 11-24-2008, 07:27 AM   #5
xuer
Member
 
Location: germany

Join Date: Sep 2008
Posts: 17
Default

I got a "Segmentation fault" error when i tried
./maqindex -v input.map chrI:1-200

or ./maqindex -i input.map.


Is there anybody could help me?
xuer is offline   Reply With Quote
Old 12-08-2008, 11:59 PM   #6
ester
Member
 
Location: Israel

Join Date: Jun 2008
Posts: 10
Default

I tried running maqindex with maq output from versions 0.6.8 and 0.7.1, in either case there is a segmentation error

%maqindex -i -c consensus.cns all.map
-- Indexing the alignment file 'all.map' ... Segmentation fault

Can anybody help?
ester is offline   Reply With Quote
Old 12-10-2008, 08:45 AM   #7
lh3
Senior Member
 
Location: Boston

Join Date: Feb 2008
Posts: 693
Default

Jue has just uploaded a new maqview-0.2.5. This version works with 0.7.x. Sorry for the late update.
lh3 is offline   Reply With Quote
Old 01-10-2009, 07:54 AM   #8
baohua100
Senior Member
 
Location: Canada

Join Date: Jun 2008
Posts: 103
Default

You can use MapView to view any format alignment results.

http://evolution.sysu.edu.cn/english...re/mapview.htm

Now can be downloaded from our lab website.

View short reads alignment

input file:
1. Reference sequence file and
2. Eland , SOAP, MAQ, SeqMap ... any formated alignment results file

MapView converts the input files to MSF format file.

MapView loads the MSF file,then you can view the alignment and SNPs.
baohua100 is offline   Reply With Quote
Old 01-14-2009, 08:19 AM   #9
xuer
Member
 
Location: germany

Join Date: Sep 2008
Posts: 17
Red face again maqview

I am sorry, is it because I made some mistake? with maqview -0.2.5, I got a blank window showing nothing sequence
after i close the window, I got a error:
freeglut_structure.c:439: fgEnumWindows: Assertion `fgState.Initialised' failed.

any one else have such problem ?
xuer is offline   Reply With Quote
Old 01-15-2009, 04:45 PM   #10
sigusn
Member
 
Location: Cambridge, MA

Join Date: Aug 2008
Posts: 19
Default

Hi
I just downloaded the latest MAQ and MAQviewer, and when I try to view my alignments, MAQview shuts down after few mouse clicks and scrolling with the message: "Bus error". Is there a limitation for the number of alignments that MAQview can handle ?
sigusn is offline   Reply With Quote
Old 01-16-2009, 11:30 AM   #11
seqfast
Member
 
Location: SF Bay Area

Join Date: Aug 2008
Posts: 16
Default

same for me, just downloaded and installed, and ran the maqdemo on phiX (~6kb)

new MAQ 7.1, new maqview 2.5

rhel5, 16Gb RAM

2.6.18-92.1.18.el5 #1 SMP Wed Nov 5 09:00:19 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

/MAQ_BWA/maqview/maqindex -i -c consensus.cns all.map
-- Indexing the alignment file 'all.map' ... Segmentation fault


Incidentally I segfault while trying to build indexes with SOAPalign for anything larger than ~15Mbases.
seqfast is offline   Reply With Quote
Old 02-18-2009, 08:54 PM   #12
Torst
Senior Member
 
Location: The University of Melbourne, AUSTRALIA

Join Date: Apr 2008
Posts: 275
Default

I too am getting a segmentation fault. It happens with all combinations of maqview 0.23/0.25 with maq 0.6/0.7.1

maqindex -i neg.map
-- Indexing the alignment file 'neg.map' ... Segmentation fault

This is on Centos 5.x, Xeon SMP 64 bit CPU, 64 GB RAM.
Torst is offline   Reply With Quote
Old 03-06-2009, 06:50 AM   #13
AnamikaDarwin
Member
 
Location: Boston

Join Date: Nov 2008
Posts: 26
Question maqview freeglut error

Quote:
Originally Posted by ECO View Post
Did you index the map with maqindex -c XXXX.cns YYYY.map ?


Hello,

I am having similar issues like other users, i.e. get the following error message:


maqview s512.3diff.mapMerge
freeglut /maqview/bin/maqview: relocation error: /maqview/bin/maqview: symbol __fprintf_chk, version GLIBC_2.3.4 not defined in file libc.so.6 with link time reference


I have indexed my .map and .cns file as suggested by ECO.

The .map and .cns files are generated by the 0.7.1 version of maq and I am using the latest version of maqview, 0.2.5.


Thanks!
Anamika
AnamikaDarwin is offline   Reply With Quote
Old 03-17-2009, 12:26 PM   #14
fadista
Member
 
Location: Malm

Join Date: Sep 2008
Posts: 37
Default

Hi,

Did you get your problem solved? I am having the same problem...
fadista is offline   Reply With Quote
Old 03-17-2009, 12:27 PM   #15
fadista
Member
 
Location: Malm

Join Date: Sep 2008
Posts: 37
Default

I am having the same problem. Did you find a way to solve the problem?
fadista is offline   Reply With Quote
Old 03-21-2009, 06:47 AM   #16
ruanjue
Junior Member
 
Location: China

Join Date: Mar 2009
Posts: 4
Default

Please have a test. If you are running maqview on 32-bit machine, hope this new version helps.

Note: maqview-0.2.6 haven't been released in sourceforge, this package is just for test, if you find any new bug, please reply.
Attached Files
File Type: gz maqview-0.2.6.tar.gz (184.1 KB, 181 views)
ruanjue is offline   Reply With Quote
Old 03-27-2009, 08:42 AM   #17
lparsons
Member
 
Location: NJ

Join Date: Nov 2008
Posts: 28
Default

The 0.2.6 version fixed the "Bus error" on my 64-bit Mac. Thank you for the fix and the excellent viewer. Let me know if I can help with testing, etc.
lparsons is offline   Reply With Quote
Old 03-27-2009, 07:51 PM   #18
ruanjue
Junior Member
 
Location: China

Join Date: Mar 2009
Posts: 4
Default

I am happy that it works fine

maqview-0.2.6 added `depth view`
<F1> basic alignment view
<F2> colored alignment view
<F3> line reads view
<F4> depths view
ruanjue is offline   Reply With Quote
Old 03-30-2009, 07:37 AM   #19
lparsons
Member
 
Location: NJ

Join Date: Nov 2008
Posts: 28
Default

I was able to see line reads, though I'm a bit confused as to what the color scheme for the reference and reads means.

Also, I wasn't able to see depths view. Pressing F4 seems to have no effect.
lparsons is offline   Reply With Quote
Old 03-31-2009, 06:36 AM   #20
bosTau2
Member
 
Location: Antwerp, BE or Cambrigde, UK

Join Date: Nov 2008
Posts: 12
Default compiling errors

I compiled maqview-0.2.6 in two Linux machines, which did not have problems before. Now I got errors in 'make'.
I tried on
Linux 2.6.18-8.el5, x86_64 x86_64 x86_64 GNU/Linux
Linux 2.6.5--286tg3susesfs, x86_64 GNU/Linux

Here is a make output.

#portal maqview>make
make all-am
make[1]: Entering directory `/cluster/home/maqview2/maqview'
if gcc -DHAVE_CONFIG_H -I. -I. -I. -DHAVE_FREEGLUT -g -O2 -Wall -W -lm -DMAQ_
LONGREADS -MT zrio_main.o -MD -MP -MF ".deps/zrio_main.Tpo" -c -o zrio_main.o zr
io_main.c; \
then mv -f ".deps/zrio_main.Tpo" ".deps/zrio_main.Po"; else rm -f ".deps
/zrio_main.Tpo"; exit 1; fi
gcc: -lm: linker input file unused because linking not done
gcc: -lm: linker input file unused because linking not done
if gcc -DHAVE_CONFIG_H -I. -I. -I. -DHAVE_FREEGLUT -g -O2 -Wall -W -lm -DMAQ_
LONGREADS -MT btree.o -MD -MP -MF ".deps/btree.Tpo" -c -o btree.o btree.c; \
then mv -f ".deps/btree.Tpo" ".deps/btree.Po"; else rm -f ".deps/btree.T
po"; exit 1; fi
gcc: -lm: linker input file unused because linking not done
gcc: -lm: linker input file unused because linking not done
if gcc -DHAVE_CONFIG_H -I. -I. -I. -DHAVE_FREEGLUT -g -O2 -Wall -W -lm -DMAQ_
LONGREADS -MT maqmap_index.o -MD -MP -MF ".deps/maqmap_index.Tpo" -c -o maqmap_i
ndex.o maqmap_index.c; \
then mv -f ".deps/maqmap_index.Tpo" ".deps/maqmap_index.Po"; else rm -f
".deps/maqmap_index.Tpo"; exit 1; fi
gcc: -lm: linker input file unused because linking not done
In file included from maqmap.h:28,
from maqmap_index.h:5,
from maqmap_index.c:2:
const.h:11: error: conflicting types for
/usr/include/sys/types.h:198: error: previous declaration of was here
maqmap_index.c: In function :
maqmap_index.c:178: warning: passing argument 3 of from incompatible pointer t
ype
maqmap_index.c: In function :
maqmap_index.c:432: warning: comparison between signed and unsigned
maqmap_index.c:434: warning: format expects type , but argument 3 has type
make[1]: *** [maqmap_index.o] Error 1
make[1]: Leaving directory `/cluster/home/maqview2/maqview'
make: *** [all] Error 2
bosTau2 is offline   Reply With Quote
Reply

Tags
maq, maqview

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 02:48 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO