SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
bug in samtools view -s? jkzebrafish Bioinformatics 3 11-06-2017 01:40 PM
samtools mpileup possible bug Ravaf Bioinformatics 4 08-07-2015 05:19 AM
Bug Report For Samtools View Tlexander Bioinformatics 1 12-16-2013 12:33 PM
Possible samtools view bug leecbaker Bioinformatics 7 10-30-2012 10:37 AM
A samtools v0.1.11 bug??? nturay Bioinformatics 0 04-28-2011 03:52 AM

Reply
 
Thread Tools
Old 01-02-2020, 12:05 PM   #1
drdna
Member
 
Location: Kentucky

Join Date: May 2012
Posts: 75
Default samtools mpileup bug

It seems to me that the samtools indeed calling function is very buggy. Recently called indels on a dataset where all indels were reported with massive forward strand bias. Two output examples are shown here:

Quote:
Chr1 122767 . ACCC ACCCC 132.468 . INDEL;IDV=40;IMF=0.909091;DP=44;VDB=0.0700215;SGB=-0.692352;MQ0F=0;AF1=1;AC1=1;DP4=0,0,21,0;MQ=41;FQ=-999 GT:PL 1:170,63,0
Chr1 122924 . TGGGG TGGGGG 76.4669 . INDEL;IDV=18;IMF=0.818182;DP=22;VDB=0.0508436;SGB=-0.676189;MQ0F=0;AF1=1;AC1=1;DP4=0,0,11,0;MQ=37;FQ=-999 GT:PL 1:114,33,0
Direct interrogation of the reads revealed that there are plenty of reads from the reverse strand that support the indel. Therefore, we reverse-complemented the fastq dataset and re-called the exact same data mapped to the reverse strand. Again massive forward strand bias, despite the fact that the program had just called the reverse reads prior to them being reverse-complemented:

Quote:
Chr1 122767 . ACCC ACCCC 134.468 . INDEL;IDV=50;IMF=0.909091;DP=55;VDB=0.132339;SGB=-0.693021;MQ0F=0;AF1=1;AC1=1;DP4=0,0,27,0;MQ=42;FQ=-999 GT:PL 1:172,81,0
Chr1 122924 . TGGGG TGGGGG 120.467 . INDEL;IDV=29;IMF=0.852941;DP=34;VDB=0.245878;SGB=-0.692352;MQSB=0.473684;MQ0F=0;AF1=1;AC1=1;DP4=0,0,19,2;MQ=37;FQ=-999 GT:PL 1:158,63,0
Option runs were:
Code:
samtools mpileup -uf
Code:
bcftools --ploidy 1 -v -c
samtools version 1.9

I can't think of any possible option that would cause this behavior, so I'm suspecting a bug. Thoughts?
drdna is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 01:47 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO