SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
help with trinity and jellyfish bongbimit Bioinformatics 2 05-13-2015 02:01 AM
Trinity installation error on Mac OSX Marvericks Agrias Bioinformatics 0 03-07-2014 10:31 AM
Trinity Help dmacmillan De novo discovery 5 05-11-2012 11:20 AM
Using Trinity package aevgup RNA Sequencing 8 02-04-2012 02:15 AM
trinity error ECHo Bioinformatics 3 11-30-2011 12:29 PM

Reply
 
Thread Tools
Old 08-05-2014, 11:22 PM   #1
cli
Member
 
Location: USA

Join Date: Mar 2011
Posts: 29
Default help with Trinity installation

Dear all,

We want to install Trinity on our cluster, which is under x86_64-redhat-linux, Thread model: posix, gcc version 4.1.2 20080704 (Red Hat 4.1.2-50). When I tried to compile Trinity, I got errors:

Use of inherited AUTOLOAD for non-method Autom4te::XFile::msg() is deprecated at /usr/share/autoconf/Autom4te/XFile.pm line 238.
Can't locate auto/Autom4te/XFile/msg.al in @INC (@INC contains: /usr/share/autoconf /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 .) at /usr/share/autoconf/Autom4te/XFile.pm line 238
aclocal-1.9: autom4te failed with exit status: 1
make[1]: *** [aclocal.m4] Error 1
make[1]: Leaving directory `/ocean/rhome/lichenhong/trinityrnaseq_r20140413p1/Inchworm'
make: *** [inchworm_target] Error 2

Does anyone know what was the problem and how to fix it? Or if you have compiled executables that we could use, it would be greatly appreciated. We really need the cluster to do the job in time. Thank you in advance.
cli is offline   Reply With Quote
Old 08-06-2014, 12:00 AM   #2
WhatsOEver
Senior Member
 
Location: Germany

Join Date: Apr 2012
Posts: 215
Default

Something like:
Quote:
Originally Posted by cli View Post
Can't locate auto/Autom4te/XFile/msg.al in @INC...
normally tells you that some perl libraries are missing/cannot be found.
I found a similar (but quite old) bug report on this (https://bugzilla.redhat.com/show_bug.cgi?id=494042) with a possible fix by adding: "use Autom4te::Channels qw(msg);" to .../lib/Autom4te/XFile.pm.

It seems to be a problem specific to installations on a server/cluster; At least I haven't had this error when I installed trinity 2 weeks ago on a local workstation.

Hope this helps somehow.
WhatsOEver is offline   Reply With Quote
Old 08-16-2014, 07:11 PM   #3
cli
Member
 
Location: USA

Join Date: Mar 2011
Posts: 29
Default

Thank you, WhatsOEver!

We have fixed the problem by point the compiler to gcc 44. Since we can't mess with the root system, here are what we did. Hope it can help someone facing similar problem.

1. adding alias 'gcc=/usr/bin/gcc44' alias 'g++=/usr/bin/g++44' in .bashrc file

2. modify the jellyfish plugin / Makefile, find jellyfish configure=XXX and change it into configure=usr/bin/gcc44
cli is offline   Reply With Quote
Old 05-14-2015, 02:17 AM   #4
kurban910
Member
 
Location: urumqi

Join Date: Jul 2014
Posts: 58
Default error with trinity installation

hello everyone,

i have rent server from school computer center, and trying to install Trinity on it via SSH. but i got the following error message:
Code:
[email protected]:~/trinityrnaseq-2.0.6> make
Using gnu compiler for Inchworm and Chrysalis
cd Inchworm && (test -e configure || autoreconf) \
                && sh ./configure --prefix=`pwd`  && make install
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for g++... g++
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking for library containing cos... none required
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing depfiles commands
make[1]: Entering directory `/public/home/kurban910/trinityrnaseq-2.0.6/Inchworm'
make[1]: Warning: File `Makefile' has modification time 5e+04 s in the future
Making install in src
make[2]: Entering directory `/public/home/kurban910/trinityrnaseq-2.0.6/Inchworm/src'
make[2]: Warning: File `.deps/string_util.Po' has modification time 4.9e+04 s in the future
g++ -DHAVE_CONFIG_H -I. -I..    -std=c++0x -pedantic -fopenmp -Wall -Wextra -Wno-deprecated -m64 -g -O2 -MT Fasta_entry.o -MD -MP -MF .deps/Fasta_entry.Tpo -c -o Fasta_entry.o Fasta_entry.cpp
cc1plus: error: unrecognized command line option "-std=c++0x"
cc1plus: error: unrecognized command line option "-fopenmp"
make[2]: *** [Fasta_entry.o] Error 1
make[2]: Leaving directory `/public/home/kurban910/trinityrnaseq-2.0.6/Inchworm/src'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/public/home/kurban910/trinityrnaseq-2.0.6/Inchworm'
make: *** [inchworm_target] Error 2
[email protected]:~/trinityrnaseq-2.0.6>
i am still new at linux operation. could anyone give me some sugessions what have gone wrong here?
kurban910 is offline   Reply With Quote
Old 05-14-2015, 03:35 AM   #5
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,795
Default

Which version of gcc are you using?

Code:
$ gcc -v
GenoMax is offline   Reply With Quote
Old 05-14-2015, 03:38 AM   #6
kurban910
Member
 
Location: urumqi

Join Date: Jul 2014
Posts: 58
Default

Code:
[email protected]:~/trinityrnaseq-2.0.6> gcc -v
Using built-in specs.
Target: x86_64-suse-linux
Configured with: ../configure --enable-threads=posix --prefix=/usr --with-local-prefix=/usr/local --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib64 --libexecdir=/usr/lib64 --enable-languages=c,c++,objc,fortran,obj-c++,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.1.2 --enable-ssp --disable-libssp --disable-libgcj --with-slibdir=/lib64 --with-system-zlib --enable-shared --enable-__cxa_atexit --enable-libstdcxx-allocator=new --program-suffix= --enable-version-specific-runtime-libs --without-system-libunwind --with-cpu=generic --host=x86_64-suse-linux
Thread model: posix
gcc version 4.1.2 20070115 (SUSE Linux)
kurban910 is offline   Reply With Quote
Old 05-14-2015, 03:45 AM   #7
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,795
Default

That is a pretty old version of gcc. You will need a new(er) version of gcc to compile trinity. Ask your admins if gcc (v. 4.3 or newer) is available.
GenoMax is offline   Reply With Quote
Old 05-14-2015, 03:53 AM   #8
kurban910
Member
 
Location: urumqi

Join Date: Jul 2014
Posts: 58
Default

thanks GenoMax,
is there anyway can i update gcc without contacting with the people who is responsible for the server? coz, it's time for off-work here in uqumqi. if i wait untill tomorrow i will wait like another 15 hours.
kurban910 is offline   Reply With Quote
Old 05-14-2015, 04:18 AM   #9
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,795
Default

You won't be able to update system gcc (only admins can do that). It appears that you are using SUSE linux (is this openSUSE or something else?).
GenoMax is offline   Reply With Quote
Old 05-14-2015, 04:24 AM   #10
kurban910
Member
 
Location: urumqi

Join Date: Jul 2014
Posts: 58
Default

[email protected]:~/trinityrnaseq-2.0.6> cat /proc/version
Linux version 2.6.16.60-0.21-smp ([email protected]) (gcc version 4.1.2 20070115 (SUSE Linux)) #1 SMP Tue May 6 12:41:02 UTC 2008
[email protected]:~/trinityrnaseq-2.0.6> lsb_release-a
-bash: lsb_release-a: command not found
[email protected]:~/trinityrnaseq-2.0.6> cat /etc/issue

Welcome to SUSE Linux Enterprise Server 10 SP2 (x86_64) - Kernel \r (\l).


[email protected]:~/trinityrnaseq-2.0.6>

from the info. above can we know its open suse or not ?

Last edited by kurban910; 05-14-2015 at 04:26 AM.
kurban910 is offline   Reply With Quote
Old 05-14-2015, 04:39 AM   #11
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,795
Default

Sorry I have not worked with SUSE so can't give you specific directions on how to get a newer version of gcc installed. See if something here works: https://forums.opensuse.org/showthre...g-gcc-compiler
GenoMax is offline   Reply With Quote
Old 05-14-2015, 06:27 AM   #12
kurban910
Member
 
Location: urumqi

Join Date: Jul 2014
Posts: 58
Default

thanks , i will look into that.
kurban910 is offline   Reply With Quote
Old 05-20-2015, 04:41 PM   #13
andrewm
Junior Member
 
Location: vancouver, canada

Join Date: Nov 2010
Posts: 8
Default

In case this is still an issue for anyone, its possible the problem is the filesystem you are compiling on.

Try a local filesystem as opposed to an NFS mount.

https://bugzilla.redhat.com/show_bug.cgi?id=494042
andrewm is offline   Reply With Quote
Old 10-07-2018, 08:45 PM   #14
gen2prot
Member
 
Location: Hyderabad, India

Join Date: Apr 2010
Posts: 64
Default Help with trinity installation

Hello,

I followed the instructions on installing Trinity. I gave the following commands

Code:
make
make plugins
It works fine upto here. When I give the next command,

Code:
make install
I get an error as I do not have permission to write to /usr/local/bin, as it is owned by "root"

How do I solve this?

I have tried the following, all getting errors

Code:
make prefix=/path/to/installationdir install
make -C /path/to/installationdir install
Thanks in advance
-Abhijit
gen2prot is offline   Reply With Quote
Old 10-07-2018, 11:14 PM   #15
yueluo
Member
 
Location: Guangzhou China

Join Date: Aug 2013
Posts: 82
Default

You don't need to run 'make install' for Trinity to work. Just execute /path/to/Trinity .
yueluo is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 02:46 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO