SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Filtering SAM files by base quality (QUAL)? JPreston Bioinformatics 13 04-17-2014 05:34 PM
TopHat generates accepted_hits.bam files for some of my samples, but for other shirley0818 RNA Sequencing 1 02-03-2014 06:55 AM
cuffdiff generates empty files potato84 RNA Sequencing 1 10-08-2012 01:02 AM
SAM format. Strange encoding in QUAL field -no ASCII tomjan Bioinformatics 9 04-26-2012 08:08 AM
Tophat: some .sam files empty and some not oliviera RNA Sequencing 0 07-13-2010 04:35 AM

Reply
 
Thread Tools
Old 11-18-2015, 05:33 AM   #1
srikant_verma
Junior Member
 
Location: India

Join Date: Sep 2014
Posts: 7
Default TopHat v2.0.13 generates SAM files with few alignment records having empty QUAL field

Hi all,

I have obsereved that a couple of alignment records as generated by TopHat has empty QUAL field (11th column) in SAM file.
This results the following error while converting this SAM file to BAM using samtools 1.0 (view):
[W::sam_read] parse error at line 83974818
[main_samview] truncated file.

It would be great if you let me know what could be the reason for the empty QUAL field.

Thanks,
Srikant
srikant_verma is offline   Reply With Quote
Old 11-18-2015, 06:42 AM   #2
blancha
Senior Member
 
Location: Montreal

Join Date: May 2013
Posts: 367
Default

First, I would start by offering my standard advice that you should upgrade to the latest version of the programs before reporting any potential bug.

Second, your post is confusing. TopHat directly outputs BAM files. How come you are using samtools view to convert a SAM file supposedly outputted by TopHat to a BAM file?
blancha is offline   Reply With Quote
Old 11-18-2015, 09:17 PM   #3
srikant_verma
Junior Member
 
Location: India

Join Date: Sep 2014
Posts: 7
Default

Thanks blancha for your suggestion.

According to the release related information available at https://ccb.jhu.edu/software/tophat/index.shtml, the problem mentioned above was solved/tried to solve in release TopHat 2.0.1 maintenance release 5/17/2012 and TopHat 2.0.7 release 1/23/2013. So I thought there could be other reason for the observation which I do not know.
Regarding your second query, there is the option '--no-convert-bam' in tophat which generates <output_dir>/accepted_hit.sam. I use this SAM file for some other purpose (using custom perl script). Anyway, the SAM file then can be converted to BAM using samtools view, and that can be used in down-stream analysis.

Again, thanks for your suggestion. I will use latest tophat and post the result.
srikant_verma is offline   Reply With Quote
Reply

Tags
qual field, tophat2

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 07:53 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO