SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Custom local blast results detq182 Bioinformatics 2 11-04-2014 03:53 AM
Blast database creation : Error kalyankpy Bioinformatics 11 02-10-2014 09:30 AM
BLAST+ creating custom blast database and using blast+ filtering features deniz Bioinformatics 2 10-26-2012 11:04 AM
BLAST+ database error nupurgupta Bioinformatics 7 06-08-2012 08:16 AM
BLAST database error - when changing to new BLAST+ local program biobio Bioinformatics 4 06-15-2011 05:20 AM

Reply
 
Thread Tools
Old 07-15-2012, 05:30 PM   #1
jgeahlen
Junior Member
 
Location: St. Louis

Join Date: Jul 2012
Posts: 3
Default error querying custom database using Blast+

So I am trying to query stomach ETS libraries for my gene of interest. I installed blast ncbi-blast-2.2.26+.dmg on mac OSX lion. I downloaded an ETS library as a .seq file which I converted to a .fsa file and made it into a blast database using makeblastdb which gave me the following files;

TSTOM2.fsa.nhr
TSTOM2.fsa.nin
TSTOM2.fsa.nnd
TSTOM2.fsa.nni
TSTOM2.fsa.nog
TSTOM2.fsa.nsd
TSTOM2.fsa.nsi
TSTOM2.fsa.nsq

These files are in /Users/jgeahlen/NCBI_Blast/db, which is a different directory than the blast files since my computer installed it in a directory I don't have permission to modify via command line.

When I try to blast that database using the script below;

Jessicas-MacBook-Air:db jgeahlen$ blastn -db TSTOM2 -query /Users/jgeahlen/NCBI_Blast/input/human3.fsa -out TSTOM2.out

I get the following error; BLAST Database error: No alias or index file found for nucleotide database [TSTOM2] in search path [/Users/jgeahlen/NCBI_Blast/db::/Users/jgeahlen/NCBI_Blast/db:]

but when I look in /Users/jgeahlen/NCBI_Blast/db, there they are

I have created a .ncbirc file and designated BLASTDB=/Users/jgeahlen/NCBI_Blast/db

Both my query and database were made from nucleotide sequences so that cannot be the issue. Please help!

Thanks,
-Jessie
jgeahlen is offline   Reply With Quote
Old 07-16-2012, 03:27 AM   #2
kmcarr
Senior Member
 
Location: USA, Midwest

Join Date: May 2008
Posts: 1,156
Default

You specified a database name TSTOM2 so BLAST is looking for an index file named TSTOM2.nin (or an alias file named TSTOM2.nal). Your BLAST database name is TSTOM2.fsa. Change your command to '-db TSTOM2.fsa'.
kmcarr is offline   Reply With Quote
Old 07-16-2012, 09:26 AM   #3
jgeahlen
Junior Member
 
Location: St. Louis

Join Date: Jul 2012
Posts: 3
Default

That seems to have solved the problem, thanks!!!
jgeahlen is offline   Reply With Quote
Old 12-29-2012, 10:48 AM   #4
sfyoung
Junior Member
 
Location: Washington State

Join Date: Mar 2010
Posts: 3
Default

Post withdrawn

Last edited by sfyoung; 12-29-2012 at 11:55 AM. Reason: Deleting to start new thread
sfyoung is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 01:27 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO