SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
A heretically simple approach to variant calling krawitz Bioinformatics 4 04-25-2012 03:01 AM
variant calling kjaja Bioinformatics 1 11-04-2011 07:16 AM
Samtools variant calling questions Chiel Bioinformatics 2 06-07-2011 09:10 AM
variant calling using samtools -v- bcftools ksc Bioinformatics 2 04-13-2011 06:44 AM
Variant Calling for Exome Capture Analysis sbaheti Bioinformatics 40 11-11-2010 10:35 AM

Reply
 
Thread Tools
Old 11-29-2011, 07:59 AM   #1
nexgengirl
Member
 
Location: Maryland

Join Date: Apr 2010
Posts: 31
Default BFAST and Variant Calling

Hi,

I have a question regarding variant calling with SOLiD data. For the mapping, I used BFAST and for variant calling I'm trying to use GATK.

The problem occurs when I run the quality score recalibration and also the unified genotyper. Whenever I run these I get an output that says many of my reads were filtered because they don't have a mapping quality (The MappingQualityUnavailableFilter contains nearly 90% of my reads, also see here: http://www.broadinstitute.org/gsa/wi...TK_release_1.1).

In other words the mapping quality was 255 which in a sam/bam file means the quality is unavailable.

Here (http://sourceforge.net/apps/mediawik...apping_Quality) it seems the mapping quality of 255 is actually very good.

I'm confused as to how to work around this problem. Any help would be appreciated. Thanks.
nexgengirl is offline   Reply With Quote
Old 11-29-2011, 08:06 AM   #2
Chipper
Senior Member
 
Location: Sweden

Join Date: Mar 2008
Posts: 324
Default

I had the same problem, my solution was to change the mapping quality. This issue is supposed to be fixed in the latest version of BFAST, so an better option would be to realign reads with mapQV 255. Or just use Samtools mpileup.
Chipper is offline   Reply With Quote
Old 11-29-2011, 08:47 AM   #3
nexgengirl
Member
 
Location: Maryland

Join Date: Apr 2010
Posts: 31
Default

Thanks Chipper.

If I may ask what did you find was an appropriate change for the mapping quality? Could it merely be changed to 254 or is it more complex than that? Thanks again.
nexgengirl is offline   Reply With Quote
Old 11-29-2011, 11:57 AM   #4
Chipper
Senior Member
 
Location: Sweden

Join Date: Mar 2008
Posts: 324
Default

As long as it is not 255 it is ok, but if the alignments with score 255 are unreliable it would be better to set it to a lower value.
Chipper is offline   Reply With Quote
Old 11-29-2011, 04:34 PM   #5
nilshomer
Nils Homer
 
nilshomer's Avatar
 
Location: Boston, MA, USA

Join Date: Nov 2008
Posts: 1,285
Default

Try upgrading to the newest version as Chipper suggests, then report back.
nilshomer is offline   Reply With Quote
Old 11-29-2011, 06:08 PM   #6
nexgengirl
Member
 
Location: Maryland

Join Date: Apr 2010
Posts: 31
Default

I will try again using the new version (0.7.0a). Before I used 0.6.5a. My only concern is that the manual for the new version on page 39 also says "If a read has one alignment, then the mapping quality is set to 255." Is there another option I should specify to avoid getting a score of 255?
nexgengirl is offline   Reply With Quote
Old 11-29-2011, 06:14 PM   #7
nilshomer
Nils Homer
 
nilshomer's Avatar
 
Location: Boston, MA, USA

Join Date: Nov 2008
Posts: 1,285
Default

I would welcome feedback, but I think the calculation should produce a lot fewer 255s. If you find that it does, perhaps I should update the manual.
nilshomer is offline   Reply With Quote
Old 12-03-2011, 07:23 AM   #8
nexgengirl
Member
 
Location: Maryland

Join Date: Apr 2010
Posts: 31
Default

Thanks Chipper and nilshomer! I reran using the new version and now there are no reads failing this filter: MappingQualityUnavailableFilter

It seems to be working much better now.

Thanks again.
nexgengirl is offline   Reply With Quote
Old 01-02-2013, 05:03 AM   #9
priesgo
Member
 
Location: Spain

Join Date: Aug 2012
Posts: 22
Default

Let me retake this old issue.

I am working with 1000 genomes project alignments data and they have done their SOLiD alignment with bfast 0.64e, so I have two options: I redo the alignment myself with a newer version of bfast as it is said above; or I try to handle the 255 before GATK.

Handling the 255 mapping qualities requires replacing this values with something else in the interval [0, 254]. Any ideas on this?

I am trying to do it with samtools calmd mapping quality capping option.
priesgo is offline   Reply With Quote
Reply

Tags
bfast, gatk, variant

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 05:56 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO