SEQanswers

Go Back   SEQanswers > Applications Forums > Metagenomics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trinity error around number of CPU's and Java virtual machine gwilymh Bioinformatics 4 10-06-2014 04:03 PM
Quick & dirty Galaxy installation in a virtual machine sam.paech Bioinformatics 1 08-21-2014 02:15 AM
tgicl running error on ubuntu owwa Bioinformatics 3 06-08-2014 04:12 AM
Tabix Error on Ubuntu 10.04 JMFA Bioinformatics 2 11-25-2010 05:06 AM
maq compile error on Ubuntu baozhi Bioinformatics 1 02-19-2009 01:28 PM

Reply
 
Thread Tools
Old 01-17-2017, 09:03 PM   #1
quokka
Junior Member
 
Location: oz

Join Date: Apr 2010
Posts: 9
Default megahit failing without an error message in (x)ubuntu virtual machine

Hi.

I can get megahit (v1.1) to work as expected (either by compiling it myself or using precompiled binaries) on our cluster with CentOS (6.8).

The same version of megahit initially appears to run on Ubuntu (14.04) but no contigs are assembled and there are no errors displayed. The command I am using for testing purposes is:

Code:
megahit -t 1 -m 1000000000 --verbose -r /home/input/readsInterleaved3.fa -o /home/output/assembly
On Ubuntu, the screen only displays:

Code:
MEGAHIT v1.1.1
--- [Wed Jan 18 15:32:08 2017] Start assembly. Number of CPU threads 1 ---
--- [Wed Jan 18 15:32:08 2017] Available memory: 2099187712, used: 1000000000
..and the resulting assembly folder is empty.

If I execute the same command line instructions as above on Centos (on our cluster) the screen displays:

Code:
MEGAHIT v1.1.1
--- [Wed Jan 18 15:45:15 2017] Start assembly. Number of CPU threads 1 ---
--- [Wed Jan 18 15:45:15 2017] Available memory: 126861316096, used: 1000000000
--- [Wed Jan 18 15:45:15 2017] Converting reads to binaries ---
...and lots more output as the program correctly executes and assembles the contigs.


I'm guessing that perhaps megahit is coded to abort if there is not a minimum amount of memory available on the machine??

Usually I like to construct pipelines etc on my small virtual machine before porting them over to the cluster, hence my attempts to get them to work on this low memory machine.

Have I come to the correct conclusion or is there some other possibility (and associated fix) that exists?

Last edited by quokka; 01-17-2017 at 10:11 PM.
quokka is offline   Reply With Quote
Reply

Tags
megahit, ubuntu

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 08:48 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO