SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Segmentation fault, cuffdiff labrat73 Bioinformatics 12 03-22-2018 12:00 PM
Maq Segmentation fault Seq84 Bioinformatics 3 07-13-2012 05:05 AM
soap segmentation fault scami Bioinformatics 6 04-17-2012 07:08 AM
Segmentation fault in sift4.03 nkwuji Bioinformatics 2 12-20-2011 11:35 PM
MAQ - Segmentation fault dukevn Bioinformatics 1 04-30-2009 01:07 PM

Reply
 
Thread Tools
Old 01-30-2012, 06:41 AM   #1
aquinom85
Research Bioinformaticist
 
Location: Boston

Join Date: Dec 2011
Posts: 19
Default Breakdancer -o (single chromosome) segmentation fault

Has anyone been able to figure out how to get breakdancer_max to run with the -o flag? Everywhere I've looked people have posted this same issue and I haven't seen any response to get it working and the devs don't respond to the issue, it's very frustrating.
aquinom85 is offline   Reply With Quote
Old 01-30-2012, 09:03 AM   #2
aquinom85
Research Bioinformaticist
 
Location: Boston

Join Date: Dec 2011
Posts: 19
Default

I think I might have figured it out, if you add the prefix chr to the number it seems to run without a segmentation fault. This seems like poor coding and even worse documentation.
aquinom85 is offline   Reply With Quote
Old 02-22-2012, 01:55 PM   #3
bwubb
Member
 
Location: Philadelphia

Join Date: Jan 2012
Posts: 58
Default

I have not gotten the -o flag to work at all. At first, it could not read my bam file index (because I did not have one). Once I solved that I tried running it with -o 17 or -o chr17.

Neither produced a result. No errors, just made empty files. For the moment I am stumped.
bwubb is offline   Reply With Quote
Old 02-22-2012, 02:17 PM   #4
aquinom85
Research Bioinformaticist
 
Location: Boston

Join Date: Dec 2011
Posts: 19
Default

I got -o to work in breakdancer-max1.2, apparently they fixed it there. However there are many unknown (UN) svs called and for some reason running each chr individually then running in -t mode is magnitudes of order faster than running the entire bam without -o or -t which is rather shocking.
aquinom85 is offline   Reply With Quote
Old 02-22-2012, 02:31 PM   #5
bwubb
Member
 
Location: Philadelphia

Join Date: Jan 2012
Posts: 58
Default

Interesting. Good to hear the issue is resolved.

It appears I will not be able to get their latest version because of the methods they describe for installing it. Very frustrating. Maybe if I ask my computing admins very nicely they will do it for me...
bwubb is offline   Reply With Quote
Old 02-22-2012, 02:44 PM   #6
aquinom85
Research Bioinformaticist
 
Location: Boston

Join Date: Dec 2011
Posts: 19
Default

Right, if you have your own Ubuntu machine or a vm it's easy but if your admins are anything like mine good luck because their github package is messed up and so source compiling doesn't work without a lot of work.
aquinom85 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 05:47 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO