SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
FLX vs Titanium, Lib-L vs Lib-A, Amplicon Libraries = confusion SeqTruth 454 Pyrosequencing 4 03-03-2012 01:08 PM
Trouble installing arachne kblanch Bioinformatics 0 02-06-2012 08:52 AM
pysam pileup wierdness mbreese Bioinformatics 1 06-29-2011 01:04 PM
Do proteins interfere with NGS or lib prep?? hmviit Sample Prep / Library Generation 1 05-08-2011 07:05 AM
Problem with pysam.Samfile mingyu Bioinformatics 5 10-26-2010 12:36 AM

Reply
 
Thread Tools
Old 05-13-2011, 11:59 AM   #1
kmkocot
Member
 
Location: Alabama

Join Date: Jun 2009
Posts: 48
Default Trouble installing NGS backbone (matplot lib and pysam)

Hi all,

I'm trying to install NGS backbone onto a system w/ 2 quad-core CPUs and 24GB of RAM running Ubuntu Linux 9.04.

When I try to install matplot lib using "sudo python2.6 setup.py install" from the matplotlib-1.0.1 folder, I get this:

Code:
basedirlist is: ['/usr/local', '/usr']
============================================================================
BUILDING MATPLOTLIB
            matplotlib: 1.0.1
                python: 2.6.2 (release26-maint, Apr 19 2009, 01:58:18)  [GCC
                        4.3.3]
              platform: linux2

REQUIRED DEPENDENCIES
                 numpy: 1.2.1
             freetype2: 9.20.3

OPTIONAL BACKEND DEPENDENCIES
                libpng: found, but unknown version (no pkg-config)
                        * Could not find 'libpng' headers in any of
                        * '/usr/local/include', '/usr/include', '.'
               Tkinter: no
                        * TKAgg requires Tkinter
              wxPython: no
                        * wxPython not found
            pkg-config: looking for pygtk-2.0 gtk+-2.0
                        * Package pygtk-2.0 was not found in the pkg-config
                        * search path. Perhaps you should add the directory
                        * containing `pygtk-2.0.pc' to the PKG_CONFIG_PATH
                        * environment variable No package 'pygtk-2.0' found
                        * Package gtk+-2.0 was not found in the pkg-config
                        * search path. Perhaps you should add the directory
                        * containing `gtk+-2.0.pc' to the PKG_CONFIG_PATH
                        * environment variable No package 'gtk+-2.0' found
                        * You may need to install 'dev' package(s) to
                        * provide header files.
                  Gtk+: no
                        * Could not find Gtk+ headers in any of
                        * '/usr/local/include', '/usr/include', '.'
       Mac OS X native: no
                    Qt: no
                   Qt4: no
                 Cairo: 1.4.12

OPTIONAL DATE/TIMEZONE DEPENDENCIES
              datetime: present, version unknown
              dateutil: 1.4.1
                  pytz: 2008h

OPTIONAL USETEX DEPENDENCIES
                dvipng: no
           ghostscript: 8.64
                 latex: 3.141592
               pdftops: 0.10.5

[Edit setup.cfg to suppress the above messages]
============================================================================
pymods ['pylab']
packages ['matplotlib', 'matplotlib.backends', 'matplotlib.backends.qt4_editor', 'matplotlib.projections', 'matplotlib.testing', 'matplotlib.testing.jpl_units', 'matplotlib.tests', 'mpl_toolkits', 'mpl_toolkits.mplot3d', 'mpl_toolkits.axes_grid', 'mpl_toolkits.axes_grid1', 'mpl_toolkits.axisartist', 'matplotlib.sphinxext', 'matplotlib.numerix', 'matplotlib.numerix.mlab', 'matplotlib.numerix.ma', 'matplotlib.numerix.linear_algebra', 'matplotlib.numerix.random_array', 'matplotlib.numerix.fft', 'matplotlib.tri', 'matplotlib.delaunay']
running install
running build
running build_py
copying lib/matplotlib/mpl-data/matplotlibrc -> build/lib.linux-x86_64-2.6/matplotlib/mpl-data
copying lib/matplotlib/mpl-data/matplotlib.conf -> build/lib.linux-x86_64-2.6/matplotlib/mpl-data
running build_ext
building 'matplotlib.ft2font' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -DPY_ARRAY_UNIQUE_SYMBOL=MPL_ARRAY_API -DPYCXX_ISO_CPP_LIB=1 -I/usr/lib/python2.6/dist-packages/numpy/core/include -I/usr/include/freetype2 -I/usr/local/include -I/usr/include -I. -I/usr/include/python2.6 -c src/ft2font.cpp -o build/temp.linux-x86_64-2.6/src/ft2font.o
cc1plus: warning: command line option "-Wstrict-prototypes" is valid for Ada/C/ObjC but not for C++
In file included from /usr/include/python2.6/unicodeobject.h:57,
                 from /usr/include/python2.6/Python.h:85,
                 from ./CXX/WrapPython.h:42,
                 from ./CXX/Extensions.hxx:37,
                 from src/ft2font.h:4,
                 from src/ft2font.cpp:1:
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isspace(PyObject*)’:
/usr/include/python2.6/ctype.h:9: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:9: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isalpha(PyObject*)’:
/usr/include/python2.6/ctype.h:15: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:15: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isalnum(PyObject*)’:
/usr/include/python2.6/ctype.h:21: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:21: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isdigit(PyObject*)’:
/usr/include/python2.6/ctype.h:27: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:27: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_islower(PyObject*)’:
/usr/include/python2.6/ctype.h:33: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:33: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isupper(PyObject*)’:
/usr/include/python2.6/ctype.h:39: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:39: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_istitle(PyObject*)’:
/usr/include/python2.6/ctype.h:45: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:45: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_lower(PyObject*)’:
/usr/include/python2.6/ctype.h:55: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:55: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:58: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_upper(PyObject*)’:
/usr/include/python2.6/ctype.h:67: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:67: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:70: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_title(PyObject*)’:
/usr/include/python2.6/ctype.h:79: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:79: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:82: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_capitalize(PyObject*)’:
/usr/include/python2.6/ctype.h:91: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:91: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:94: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_swapcase(PyObject*)’:
/usr/include/python2.6/ctype.h:103: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:103: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:106: error: ‘STRINGLIB_STR’ was not declared in this scope
In file included from /usr/include/c++/4.3/cctype:49,
                 from /usr/include/c++/4.3/bits/localefwd.h:49,
                 from /usr/include/c++/4.3/string:50,
                 from ./CXX/Python2/Exception.hxx:46,
                 from ./CXX/Exception.hxx:40,
                 from ./CXX/Python2/Objects.hxx:44,
                 from ./CXX/Python2/Extensions.hxx:52,
                 from ./CXX/Extensions.hxx:40,
                 from src/ft2font.h:4,
                 from src/ft2font.cpp:1:
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isspace(PyObject*)’:
/usr/include/python2.6/ctype.h:7: error: redefinition of ‘PyObject* stringlib_isspace(PyObject*)’
/usr/include/python2.6/ctype.h:7: error: ‘PyObject* stringlib_isspace(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:9: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:9: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isalpha(PyObject*)’:
/usr/include/python2.6/ctype.h:13: error: redefinition of ‘PyObject* stringlib_isalpha(PyObject*)’
/usr/include/python2.6/ctype.h:13: error: ‘PyObject* stringlib_isalpha(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:15: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:15: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isalnum(PyObject*)’:
/usr/include/python2.6/ctype.h:19: error: redefinition of ‘PyObject* stringlib_isalnum(PyObject*)’
/usr/include/python2.6/ctype.h:19: error: ‘PyObject* stringlib_isalnum(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:21: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:21: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isdigit(PyObject*)’:
/usr/include/python2.6/ctype.h:25: error: redefinition of ‘PyObject* stringlib_isdigit(PyObject*)’
/usr/include/python2.6/ctype.h:25: error: ‘PyObject* stringlib_isdigit(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:27: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:27: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_islower(PyObject*)’:
/usr/include/python2.6/ctype.h:31: error: redefinition of ‘PyObject* stringlib_islower(PyObject*)’
/usr/include/python2.6/ctype.h:31: error: ‘PyObject* stringlib_islower(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:33: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:33: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isupper(PyObject*)’:
/usr/include/python2.6/ctype.h:37: error: redefinition of ‘PyObject* stringlib_isupper(PyObject*)’
/usr/include/python2.6/ctype.h:37: error: ‘PyObject* stringlib_isupper(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:39: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:39: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_istitle(PyObject*)’:
/usr/include/python2.6/ctype.h:43: error: redefinition of ‘PyObject* stringlib_istitle(PyObject*)’
/usr/include/python2.6/ctype.h:43: error: ‘PyObject* stringlib_istitle(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:45: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:45: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_lower(PyObject*)’:
/usr/include/python2.6/ctype.h:52: error: redefinition of ‘PyObject* stringlib_lower(PyObject*)’
/usr/include/python2.6/ctype.h:52: error: ‘PyObject* stringlib_lower(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:55: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:55: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:58: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_upper(PyObject*)’:
/usr/include/python2.6/ctype.h:64: error: redefinition of ‘PyObject* stringlib_upper(PyObject*)’
/usr/include/python2.6/ctype.h:64: error: ‘PyObject* stringlib_upper(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:67: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:67: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:70: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_title(PyObject*)’:
/usr/include/python2.6/ctype.h:76: error: redefinition of ‘PyObject* stringlib_title(PyObject*)’
/usr/include/python2.6/ctype.h:76: error: ‘PyObject* stringlib_title(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:79: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:79: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:82: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_capitalize(PyObject*)’:
/usr/include/python2.6/ctype.h:88: error: redefinition of ‘PyObject* stringlib_capitalize(PyObject*)’
/usr/include/python2.6/ctype.h:88: error: ‘PyObject* stringlib_capitalize(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:91: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:91: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:94: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_swapcase(PyObject*)’:
/usr/include/python2.6/ctype.h:100: error: redefinition of ‘PyObject* stringlib_swapcase(PyObject*)’
/usr/include/python2.6/ctype.h:100: error: ‘PyObject* stringlib_swapcase(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:103: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:103: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:106: error: ‘STRINGLIB_STR’ was not declared in this scope
In file included from /usr/include/c++/4.3/bits/localefwd.h:49,
                 from /usr/include/c++/4.3/string:50,
                 from ./CXX/Python2/Exception.hxx:46,
                 from ./CXX/Exception.hxx:40,
                 from ./CXX/Python2/Objects.hxx:44,
                 from ./CXX/Python2/Extensions.hxx:52,
                 from ./CXX/Extensions.hxx:40,
                 from src/ft2font.h:4,
                 from src/ft2font.cpp:1:
/usr/include/c++/4.3/cctype: At global scope:
/usr/include/c++/4.3/cctype:71: error: ‘::isalnum’ has not been declared
/usr/include/c++/4.3/cctype:72: error: ‘::isalpha’ has not been declared
/usr/include/c++/4.3/cctype:73: error: ‘::iscntrl’ has not been declared
/usr/include/c++/4.3/cctype:74: error: ‘::isdigit’ has not been declared
/usr/include/c++/4.3/cctype:75: error: ‘::isgraph’ has not been declared
/usr/include/c++/4.3/cctype:76: error: ‘::islower’ has not been declared
/usr/include/c++/4.3/cctype:77: error: ‘::isprint’ has not been declared
/usr/include/c++/4.3/cctype:78: error: ‘::ispunct’ has not been declared
/usr/include/c++/4.3/cctype:79: error: ‘::isspace’ has not been declared
/usr/include/c++/4.3/cctype:80: error: ‘::isupper’ has not been declared
/usr/include/c++/4.3/cctype:81: error: ‘::isxdigit’ has not been declared
/usr/include/c++/4.3/cctype:82: error: ‘::tolower’ has not been declared
/usr/include/c++/4.3/cctype:83: error: ‘::toupper’ has not been declared
In file included from /usr/include/c++/4.3/cctype:49,
                 from /usr/include/c++/4.3/bits/locale_facets.h:47,
                 from /usr/include/c++/4.3/bits/basic_ios.h:44,
                 from /usr/include/c++/4.3/ios:50,
                 from /usr/include/c++/4.3/ostream:45,
                 from /usr/include/c++/4.3/iostream:45,
                 from ./CXX/Python2/Exception.hxx:47,
                 from ./CXX/Exception.hxx:40,
                 from ./CXX/Python2/Objects.hxx:44,
                 from ./CXX/Python2/Extensions.hxx:52,
                 from ./CXX/Extensions.hxx:40,
                 from src/ft2font.h:4,
                 from src/ft2font.cpp:1:
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isspace(PyObject*)’:
/usr/include/python2.6/ctype.h:7: error: redefinition of ‘PyObject* stringlib_isspace(PyObject*)’
/usr/include/python2.6/ctype.h:7: error: ‘PyObject* stringlib_isspace(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:9: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:9: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isalpha(PyObject*)’:
/usr/include/python2.6/ctype.h:13: error: redefinition of ‘PyObject* stringlib_isalpha(PyObject*)’
/usr/include/python2.6/ctype.h:13: error: ‘PyObject* stringlib_isalpha(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:15: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:15: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isalnum(PyObject*)’:
/usr/include/python2.6/ctype.h:19: error: redefinition of ‘PyObject* stringlib_isalnum(PyObject*)’
/usr/include/python2.6/ctype.h:19: error: ‘PyObject* stringlib_isalnum(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:21: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:21: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isdigit(PyObject*)’:
/usr/include/python2.6/ctype.h:25: error: redefinition of ‘PyObject* stringlib_isdigit(PyObject*)’
/usr/include/python2.6/ctype.h:25: error: ‘PyObject* stringlib_isdigit(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:27: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:27: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_islower(PyObject*)’:
/usr/include/python2.6/ctype.h:31: error: redefinition of ‘PyObject* stringlib_islower(PyObject*)’
/usr/include/python2.6/ctype.h:31: error: ‘PyObject* stringlib_islower(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:33: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:33: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_isupper(PyObject*)’:
/usr/include/python2.6/ctype.h:37: error: redefinition of ‘PyObject* stringlib_isupper(PyObject*)’
/usr/include/python2.6/ctype.h:37: error: ‘PyObject* stringlib_isupper(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:39: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:39: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_istitle(PyObject*)’:
/usr/include/python2.6/ctype.h:43: error: redefinition of ‘PyObject* stringlib_istitle(PyObject*)’
/usr/include/python2.6/ctype.h:43: error: ‘PyObject* stringlib_istitle(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:45: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h:45: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_lower(PyObject*)’:
/usr/include/python2.6/ctype.h:52: error: redefinition of ‘PyObject* stringlib_lower(PyObject*)’
/usr/include/python2.6/ctype.h:52: error: ‘PyObject* stringlib_lower(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:55: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:55: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:58: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_upper(PyObject*)’:
/usr/include/python2.6/ctype.h:64: error: redefinition of ‘PyObject* stringlib_upper(PyObject*)’
/usr/include/python2.6/ctype.h:64: error: ‘PyObject* stringlib_upper(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:67: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:67: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:70: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_title(PyObject*)’:
/usr/include/python2.6/ctype.h:76: error: redefinition of ‘PyObject* stringlib_title(PyObject*)’
/usr/include/python2.6/ctype.h:76: error: ‘PyObject* stringlib_title(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:79: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:79: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:82: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_capitalize(PyObject*)’:
/usr/include/python2.6/ctype.h:88: error: redefinition of ‘PyObject* stringlib_capitalize(PyObject*)’
/usr/include/python2.6/ctype.h:88: error: ‘PyObject* stringlib_capitalize(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:91: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:91: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:94: error: ‘STRINGLIB_STR’ was not declared in this scope
/usr/include/python2.6/ctype.h: In function ‘PyObject* stringlib_swapcase(PyObject*)’:
/usr/include/python2.6/ctype.h:100: error: redefinition of ‘PyObject* stringlib_swapcase(PyObject*)’
/usr/include/python2.6/ctype.h:100: error: ‘PyObject* stringlib_swapcase(PyObject*)’ previously defined here
/usr/include/python2.6/ctype.h:103: error: ‘STRINGLIB_LEN’ was not declared in this scope
/usr/include/python2.6/ctype.h:103: error: ‘STRINGLIB_NEW’ was not declared in this scope
/usr/include/python2.6/ctype.h:106: error: ‘STRINGLIB_STR’ was not declared in this scope
In file included from /usr/include/c++/4.3/bits/locale_facets.h:48,
                 from /usr/include/c++/4.3/bits/basic_ios.h:44,
                 from /usr/include/c++/4.3/ios:50,
                 from /usr/include/c++/4.3/ostream:45,
                 from /usr/include/c++/4.3/iostream:45,
                 from ./CXX/Python2/Exception.hxx:47,
                 from ./CXX/Exception.hxx:40,
                 from ./CXX/Python2/Objects.hxx:44,
                 from ./CXX/Python2/Extensions.hxx:52,
                 from ./CXX/Extensions.hxx:40,
                 from src/ft2font.h:4,
                 from src/ft2font.cpp:1:
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h: At global scope:
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h:53: error: ‘_ISupper’ was not declared in this scope
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h:54: error: ‘_ISlower’ was not declared in this scope
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h:55: error: ‘_ISalpha’ was not declared in this scope
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h:56: error: ‘_ISdigit’ was not declared in this scope
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h:57: error: ‘_ISxdigit’ was not declared in this scope
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h:58: error: ‘_ISspace’ was not declared in this scope
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h:59: error: ‘_ISprint’ was not declared in this scope
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h:60: error: ‘_ISalpha’ was not declared in this scope
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h:60: error: ‘_ISdigit’ was not declared in this scope
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h:60: error: ‘_ISpunct’ was not declared in this scope
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h:61: error: ‘_IScntrl’ was not declared in this scope
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h:62: error: ‘_ISpunct’ was not declared in this scope
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h:63: error: ‘_ISalpha’ was not declared in this scope
/usr/include/c++/4.3/x86_64-linux-gnu/bits/ctype_base.h:63: error: ‘_ISdigit’ was not declared in this scope
/usr/include/python2.6/ctype.h:7: warning: ‘PyObject* stringlib_isspace(PyObject*)’ defined but not used
/usr/include/python2.6/ctype.h:13: warning: ‘PyObject* stringlib_isalpha(PyObject*)’ defined but not used
/usr/include/python2.6/ctype.h:19: warning: ‘PyObject* stringlib_isalnum(PyObject*)’ defined but not used
/usr/include/python2.6/ctype.h:25: warning: ‘PyObject* stringlib_isdigit(PyObject*)’ defined but not used
/usr/include/python2.6/ctype.h:31: warning: ‘PyObject* stringlib_islower(PyObject*)’ defined but not used
/usr/include/python2.6/ctype.h:37: warning: ‘PyObject* stringlib_isupper(PyObject*)’ defined but not used
/usr/include/python2.6/ctype.h:43: warning: ‘PyObject* stringlib_istitle(PyObject*)’ defined but not used
/usr/include/python2.6/ctype.h:52: warning: ‘PyObject* stringlib_lower(PyObject*)’ defined but not used
/usr/include/python2.6/ctype.h:64: warning: ‘PyObject* stringlib_upper(PyObject*)’ defined but not used
/usr/include/python2.6/ctype.h:76: warning: ‘PyObject* stringlib_title(PyObject*)’ defined but not used
/usr/include/python2.6/ctype.h:88: warning: ‘PyObject* stringlib_capitalize(PyObject*)’ defined but not used
/usr/include/python2.6/ctype.h:100: warning: ‘PyObject* stringlib_swapcase(PyObject*)’ defined but not used
error: command 'gcc' failed with exit status 1
I get a similar error when I try to install pysam but that's another issue.


But I was able to install it using "sudo apt-get install python-matplotlib"
Now when I run that command, I get this:
Code:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python-matplotlib is already the newest version.
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.28-13-generic libavahi-qt3-1 kdelibs4c2a
  kdebase-runtime-data-common libxine1-x librdf0 libmodplug0c2 antlr
  libboost-program-options1.35.0 kdelibs5 libxcb-xv0 libantlr-java-gcj
  liblualib50 libexiv2-5 librasqal1 khelpcenter4 kdesudo libakonadiprivate1
  jikes libsoprano4 kde-icons-oxygen libclucene0ldbl csh raptor-utils gjdoc
  linux-headers-2.6.28-13 kdepimlibs-data libxine1-console libantlr-java
  soprano-daemon install-package libplasma3 gdebi-kde libxine1-misc-plugins
  kdepimlibs5 kdelibs-bin redland-utils libstreams0 libraptor1 exiv2
  kdelibs5-data kdebase-runtime kdelibs-data liblua50 libxcb-shape0
  libxcb-shm0 kdebase-runtime-data libmpcdec3 kdebase-runtime-bin-kde4 dialign
  libxine1-bin python-kde4 libstreamanalyzer0 libxine1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
BUT when I try to install NGS backbone using "python2.7 setup.py" I get this:
Code:
matplotlib is not installed, some statistics will fail
Some optional requirements were not met, do you want to continue the installation (y/n)? n
Installation aborted
Any advice would be greatly appreciated!

Thanks,
Kevin
kmkocot is offline   Reply With Quote
Old 05-17-2011, 11:44 PM   #2
Jose Blanca
Member
 
Location: Valencia, Spain

Join Date: Aug 2009
Posts: 70
Default

It seems that the problem is related to your different python versions. You have at least python2.6 and python 2.7. Each python version has its own libraries so when you have installed matplotlib with apt-get install python-matplotlib you've installed it in one of them (probable in python 2.6). Then you're trying to install ngs_backbone using python2.7 and in python 2.7 it seems that it is not installed.
You can always check if a dependency is installed by running python in the command line and importing the module:

Quote:
jose@porta:~$ python
Python 2.6.6 (r266:84292, Sep 15 2010, 15:52:39)
[GCC 4.4.5] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import matplotlib
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
ImportError: No module named matplotlib
I've got matplotlib installed but in other python version, so I can't import it in my standard python.
If you're trying to use just the read cleaning of the pipeline now we have a clean_reads utility that has only one dependency BioPython and it is much easier to install.
Jose Blanca is offline   Reply With Quote
Old 08-15-2011, 04:59 PM   #3
mskonan
Junior Member
 
Location: LA

Join Date: Mar 2010
Posts: 2
Default

Hi,

Did you figure out how to resolve this issue? I have the same message.
It'd be appreciated if you could share the experience.
Thanks.
mskonan is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 11:50 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO