SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error in dispersionPlot using cummeRbund nancysky Bioinformatics 1 07-22-2015 06:49 AM
CummeRbund error steindorff Bioinformatics 6 07-30-2013 06:37 AM
CummeRbund error NRiddiford RNA Sequencing 5 07-26-2013 12:18 PM
cummeRbund error emolinari Bioinformatics 0 06-15-2013 11:41 AM
CummeRbund error newbietonextgen Bioinformatics 1 06-15-2012 12:24 PM

Reply
 
Thread Tools
Old 11-10-2014, 05:14 AM   #1
frymor
Senior Member
 
Location: Germany

Join Date: May 2010
Posts: 148
Default error in cummeRbund dispersionPlot

Hi,

I am trying to run cummeRbund with the cuffdiff results.
these is my workflow:

Code:
library(cummeRbund)

setwd("cummeRbund/")

cuff <- readCufflinks(dir=cuffFile_dir, gtfFile="merged.gtf", genome="dm3" , rebuild=TRUE)
everything seems to run good. all tables are ok, but I am getting these warnings:
Code:
Warning messages:

1: attributes are not identical across measure variables; they will be dropped 
...
8: attributes are not identical across measure variables; they will be dropped
I have read here, that these messages can be ignored, so I am not sure they're connected to my problem.

I am than trying to execute the DispersionPlot commend. But this gives me an error:

Code:
> disp<-dispersionPlot(genes(cuff))
> disp
Error in seq.default(min, max, by = by) : 
  'from' cannot be NA, NaN or infinite

Does anyone have an idea why I get this error?
How can I prevent this from happening?

thanks

Assa

#####
> sessionInfo()
R version 3.1.1 (2014-07-10)
Platform: x86_64-apple-darwin13.1.0 (64-bit)

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] grid stats4 parallel stats graphics grDevices utils
[8] datasets methods base

other attached packages:
[1] mgcv_1.8-3 nlme_3.1-118 cummeRbund_2.8.2
[4] Gviz_1.10.2 rtracklayer_1.26.1 GenomicRanges_1.18.1
[7] GenomeInfoDb_1.2.2 IRanges_2.0.0 S4Vectors_0.4.0
[10] fastcluster_1.1.13 reshape2_1.4 ggplot2_1.0.0
[13] RSQLite_1.0.0 DBI_0.3.1 BiocGenerics_0.12.0

loaded via a namespace (and not attached):
[1] acepack_1.3-3.3 AnnotationDbi_1.28.1 base64enc_0.1-2
[4] BatchJobs_1.5 BBmisc_1.8 Biobase_2.26.0
[7] BiocParallel_1.0.0 biomaRt_2.22.0 Biostrings_2.34.0
[10] biovizBase_1.14.0 bitops_1.0-6 brew_1.0-6
[13] BSgenome_1.34.0 checkmate_1.5.0 cluster_1.15.3
[16] codetools_0.2-9 colorspace_1.2-4 dichromat_2.0-0
[19] digest_0.6.4 fail_1.2 foreach_1.4.2
[22] foreign_0.8-61 Formula_1.1-2 GenomicAlignments_1.2.1
[25] GenomicFeatures_1.18.2 gtable_0.1.2 Hmisc_3.14-5
[28] iterators_1.0.7 labeling_0.3 lattice_0.20-29
[31] latticeExtra_0.6-26 MASS_7.3-35 Matrix_1.1-4
[34] matrixStats_0.10.3 munsell_0.4.2 nnet_7.3-8
[37] plyr_1.8.1 proto_0.3-10 R.methodsS3_1.6.1
[40] RColorBrewer_1.0-5 Rcpp_0.11.3 RCurl_1.95-4.3
[43] rpart_4.1-8 Rsamtools_1.18.1 scales_0.2.4
[46] sendmailR_1.2-1 splines_3.1.1 stringr_0.6.2
[49] survival_2.37-7 tools_3.1.1 VariantAnnotation_1.12.3
[52] XML_3.98-1.1 XVector_0.6.0 zlibbioc_1.12.0

Last edited by frymor; 11-10-2014 at 05:22 AM.
frymor is offline   Reply With Quote
Old 12-03-2014, 01:22 AM   #2
jake13
Member
 
Location: San Francisco

Join Date: Aug 2013
Posts: 23
Default

I'm having the same issue if anyone has a solution?
jake13 is offline   Reply With Quote
Old 03-09-2015, 07:58 AM   #3
chodar
Junior Member
 
Location: Chile

Join Date: May 2014
Posts: 2
Default

Same issue for me. In other forum I read that "#" character in gtf file have to be removed. In my case I dont have # but still have the error.

Thanks.

Last edited by chodar; 03-09-2015 at 10:44 AM.
chodar is offline   Reply With Quote
Old 07-28-2015, 03:06 AM   #4
Greg Deakin
Junior Member
 
Location: UK

Join Date: Jul 2015
Posts: 1
Default

I had the same issue as well - it was caused by some extremely low dispersion (and count) values. Some were of the order of 10e-308, which is lower than the minimum floating point value supported by R (on my architecture anyway). I set these to 0 and the plot then worked.

I need to read up a bit more about cuffdiff - obviously it normalises the count values, but I can't see why any should be much less than 1.

Greg
Greg Deakin is offline   Reply With Quote
Old 09-03-2015, 04:16 AM   #5
zsanli
Junior Member
 
Location: china

Join Date: Jan 2015
Posts: 1
Default how to delete most 0 values

Quote:
Originally Posted by Greg Deakin View Post
I had the same issue as well - it was caused by some extremely low dispersion (and count) values. Some were of the order of 10e-308, which is lower than the minimum floating point value supported by R (on my architecture anyway). I set these to 0 and the plot then worked.

I need to read up a bit more about cuffdiff - obviously it normalises the count values, but I can't see why any should be much less than 1.

Greg
I have same trouble when I draw disperse graph. Do you know how to code to delete most small values and small counts e.g. 2e-168
zsanli is offline   Reply With Quote
Reply

Tags
cuffdiff, cufflinks, cummerbund

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 01:23 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO