SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bowtie: Ultrafast and memory-efficient alignment of short reads to the human genome Ben Langmead Literature Watch 2 03-04-2013 02:06 AM
Bowtie memory error polsum Bioinformatics 2 12-02-2011 12:17 PM
Warning message in bowtie mapping. djbezon Bioinformatics 0 02-08-2011 07:48 AM
Bowtie warning seq_GA Bioinformatics 1 06-10-2010 09:18 AM
Bowtie warning: skip solexa** because it is less than 4 characters. pythonlovesbowtie Bioinformatics 0 11-17-2009 11:11 PM

Reply
 
Thread Tools
Old 01-03-2012, 10:48 AM   #1
crh
Member
 
Location: tx

Join Date: Dec 2009
Posts: 46
Default bowtie memory warning

Hi

I'm mapping solid reads using bowtie and received the following warnings for MANY reads. Mapping % is very low as well.
Am I running out of memory?

command line:
bowtie -C -S -k 3 --best --un unmapped_list genome_index -f seq.csfasta -Q seq.qual bowtie.sam



Warning: Exhausted best-first chunk memory for read 301_728_1008_F3 (patid 11858997); skipping read

# reads processed: 19323816
# reads with at least one reported alignment: 4408352 (22.81%)
# reads that failed to align: 14915464 (77.19%)
Reported 5326165 alignments to 1 output stream(s)

Thanks

charles
crh is offline   Reply With Quote
Old 01-03-2012, 11:42 AM   #2
kopardev
Member
 
Location: VA, USA

Join Date: Oct 2011
Posts: 18
Default

I get similar warnings when I use paired end data. But if I align read1 and read2 separately, I do not get any warnings. Solutions/pointers are appreciated.
Thanks,
Vishal
kopardev is offline   Reply With Quote
Old 01-03-2012, 12:06 PM   #3
gntc
Member
 
Location: Phoenix, AZ

Join Date: Feb 2011
Posts: 17
Default

Yes, I believe you are running out of memory. If you use --chunkmbs 200 you should stop getting the warning. This may help improve your alignment statistics.
gntc is offline   Reply With Quote
Old 01-03-2012, 12:16 PM   #4
kopardev
Member
 
Location: VA, USA

Join Date: Oct 2011
Posts: 18
Default

In fact, I have tried using --chunkmbs 1000 and still managed to get these errors ... only for paired-end data though.
kopardev is offline   Reply With Quote
Old 01-03-2012, 12:25 PM   #5
gntc
Member
 
Location: Phoenix, AZ

Join Date: Feb 2011
Posts: 17
Default

Try higher I guess. 200 worked for me when working with non-paired end data.
gntc is offline   Reply With Quote
Old 01-04-2012, 06:25 AM   #6
crh
Member
 
Location: tx

Join Date: Dec 2009
Posts: 46
Default bowtie memory warning

All

Thanks for the advice:

Using --chunkmbs 200 eliminated the memory warnings.

I'm still not mapping a significant fraction of the reads. I'm going to trim the unmapped colorspace reads from 3'end to see if I can get any of these to map - other suggestions?

bowtie -C -S -k 3 --best


# reads processed: 19323816
# reads with at least one reported alignment: 4408352 (22.81%)
# reads that failed to align: 14915464 (77.19%)
Reported 5326165 alignments to 1 output stream(s)
crh is offline   Reply With Quote
Old 05-18-2012, 07:24 PM   #7
gladexp
Junior Member
 
Location: Ohio

Join Date: Mar 2012
Posts: 3
Default Bowtie: Memory error warning

Same as the quoted question. When I run the Bowtie command as below to generate SAM with the 1 best hit from fasta input, it has such warning messages,

$ bowtie -f -S -m 1 -k 1 --best h_sapiens_37_asm Input.fa > Output.sam
------------------
Warning: Exhausted best-first chunk memory for read seq_5023_1 (patid 5023); skipping read
Warning: Exhausted best-first chunk memory for read seq_5041_1 (patid 5041); skipping read
Warning: Exhausted best-first chunk memory for read seq_20071_1 (patid 20071); skipping read
......
------------------

Which flag options should I use?

Many thanks.

Ben


Quote:
Originally Posted by crh View Post
Hi

I'm mapping solid reads using bowtie and received the following warnings for MANY reads. Mapping % is very low as well.
Am I running out of memory?

command line:
bowtie -C -S -k 3 --best --un unmapped_list genome_index -f seq.csfasta -Q seq.qual bowtie.sam



Warning: Exhausted best-first chunk memory for read 301_728_1008_F3 (patid 11858997); skipping read

# reads processed: 19323816
# reads with at least one reported alignment: 4408352 (22.81%)
# reads that failed to align: 14915464 (77.19%)
Reported 5326165 alignments to 1 output stream(s)

Thanks

charles
gladexp is offline   Reply With Quote
Old 08-20-2012, 01:24 AM   #8
jay
Member
 
Location: Warwick, UK

Join Date: Feb 2009
Posts: 12
Default

I had this problem as well. I tried --chunkmbs 200 as well, and it didn't help, but --chunkmbs 2000 seems like it might have fixed the bug being reported, but I am still getting very low alignmment proportions (5% of reads).
jay is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 10:33 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO