SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
DSN-lite, RNase H and Ribo-Zero cook off Genohub Sample Prep / Library Generation 2 09-04-2013 06:25 PM
Wierd overlapping paired ends with bimodal paired end distance distance distribution Mouth_Breather Illumina/Solexa 12 08-24-2012 11:06 AM
turn-key next gen companies msincan General 8 08-11-2010 10:33 PM
Journal with fast turn-around? somanygenes General 5 05-04-2010 12:03 AM
Turn off KeyPass Filter? Ben 454 Pyrosequencing 0 04-22-2009 11:37 AM

Reply
 
Thread Tools
Old 10-28-2013, 06:22 AM   #1
Nelala
Junior Member
 
Location: Switzerland

Join Date: Oct 2013
Posts: 1
Default DESeDESeq2: How to turn off Cook’s distance testing?

Dear DESeq2 users,

I’m completely new to transcriptome analyses, and I’ve neither used R or DESeq2 before, so I apologize for the probably basic question...

I luckily managed to install & run the DESeq2 package with my own samples by using the "default" settings from the vignette.
Now I’d like to turn off Cook’s distance testing (by using the argument “cooksCutoff=FALSE”), but here is where I’m stuck: no matter what I try I get the error “unused argument (cooksCutoff = FALSE)”.

Here’s the script I’m using for the “default” analysis of my samples:

# Counts-Matrix
CountTableAC <- read.table("CountTableAC.txt", header=TRUE, row.names=1)
head(CountTableAC)

# column information as data.frame
DesignAC <- data.frame(
row.names = colnames( CountTableAC ),
condition = c( "A", "A", "C", "C" ) )
DesignAC


dds <- DESeqDataSetFromMatrix(countData = CountTableAC,
colData = DesignAC,
design = ~ condition)
colData(dds)$condition <- factor(colData(dds)$condition,
levels=c("A","C" ))

dds

#Differential Expression Analysis:
dds <- DESeq(dds)
res <- results(dds)
res <- res[order(res$padj),]
head(res)

plotMA(dds,ylim=c(-2,2),main="DESeq2")

Can anyone please tell me exactly where and what to change to disable Cook’s testing?

Thanks a lot for any advice!
Nelala
Nelala is offline   Reply With Quote
Old 11-05-2013, 07:49 AM   #2
Michael Love
Senior Member
 
Location: Boston

Join Date: Jul 2013
Posts: 333
Default

cooksCutoff moved from DESeq() to results() when you upgraded to Bioc 2.13. You can turn it off there.

Big changes like this are documented in the NEWS file. You can access this from R like this:

news(Version >= "1.1", package="DESeq2")

then you would have seen:

Changes in version 1.1.31:

o The adjustment of p-values and use of Cook's distance
for outlier detection is moved to results() function
instead of nbinomWaldTest(), nbinomLRT(), or DESeq().
This allows the user to change parameter settings
without having to refit the model.

Also, you should check the vignette of the current package version, instead of the one on the web:

vignette("DESeq2")

You can see what vignettes are available (for DESeq2 there is only the one above):

browseVignettes(package="DESeq2")
Michael Love is offline   Reply With Quote
Reply

Tags
cook's distance testing, deseq2

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 06:56 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO