SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with cummeRbund diffData() Enrique Zudaire RNA Sequencing 4 04-08-2016 08:07 AM
Problem with cummeRbund and RSQLite noplacetoh1de Bioinformatics 9 11-03-2014 02:33 PM
Problem with cummeRbund and RSQLite :( dadada4ever Bioinformatics 3 07-31-2013 10:13 AM
CummeRbund problem in R with segfault vd4mindia Bioinformatics 1 05-30-2013 07:03 PM
CummeRbund problem in R and RSQLite vd4mindia Bioinformatics 0 05-05-2013 03:40 AM

Reply
 
Thread Tools
Old 11-03-2014, 02:31 PM   #41
lgoff
Member
 
Location: Cambridge, MA

Join Date: Feb 2008
Posts: 82
Default

Hi all,
I think i've patched cummeRbund for RSQLite 1.0.0 compatibility. It now builds and runs on my machine. I pushed it up to BioC, but it may take a few days to get through the nightly build system.

If you would like to try and build it yourself, you can find the patched version (and the current development version) here:

https://github.com/gofflab/cummeRbund

You will have to:
1) clone the repository
2) R CMD BUILD cummeRbund
3) R CMD INSTALL cummeRbund

Please make sure that you have all the required dependencies installed (including RSQLite 1.0.0). The BioC installer checks this for you, but if you build yourself, it will fail if you do not have all the dependencies installed.

Also, please let me know if you continue to have errors. I don't check seqanswers all that often anymore due to time constraints, but I'll try to keep up on this specific thread.

Cheers,
Loyal
lgoff is offline   Reply With Quote
Old 11-03-2014, 02:35 PM   #42
axa9070
Member
 
Location: Rochester, NY

Join Date: Oct 2014
Posts: 11
Default

Thanks Loyal!

We appreciate your time and hard work!

^_^
axa9070 is offline   Reply With Quote
Old 11-04-2014, 06:18 AM   #43
Gonza
Member
 
Location: Ithaca, NY

Join Date: Mar 2013
Posts: 78
Default

Hi All,

is not working for me either. is other way to fix this other than uninstalling and reinstalling?

> cuff_data <-readCufflinks()
Creating database /Users/gonzalovillarino/Desktop/05Cuffdiff_novelgenes/cuffData.db
Error in FUN(c("\n-- Creator: MySQL Workbench 5.2.33/ExportSQLite plugin 2009.12.02\n-- Author: Loyal Goff\n-- Caption: New Model\n-- Project: Name of the project\n-- Changed: 2012-04-30 22:21\n-- Created: 2011-05-02 12:52\nPRAGMA foreign_keys = OFF", :
could not find function "sqliteQuickSQL"
> cuff_data <-readCufflinks()
> cuff_data
Error in sqliteSendQuery(con, statement, bind.data) :
error in statement: no such table: genes
Gonza is offline   Reply With Quote
Old 11-04-2014, 06:34 AM   #44
DonDolowy
Member
 
Location: Freiburg

Join Date: Oct 2012
Posts: 56
Default

Thanks a lot for the help, guys! Working here again.
DonDolowy is offline   Reply With Quote
Old 11-04-2014, 04:06 PM   #45
homeuser1
Junior Member
 
Location: alabama

Join Date: Oct 2014
Posts: 3
Default

Hi, any update regarding the cummerbund error? Thanks
homeuser1 is offline   Reply With Quote
Old 11-05-2014, 10:18 AM   #46
lgoff
Member
 
Location: Cambridge, MA

Join Date: Feb 2008
Posts: 82
Default

Hi All,
Quick update. The patched version of cummeRbund (release 2.8.2) is now up at bioconductor and passes all builds and checks:

http://www.bioconductor.org/checkRes...ST/cummeRbund/

So you should be able to update to this version using the bioconductor installer:

Quote:
source('http://www.bioconductor.org/biocLite.R')
biocLite('cummeRbund')
I have verified that most of the problems discussed in this thread have been handled, at least as far as I can test. There may be other functionality that has been broken that I have not come across yet. If you are still having problems, and you are certain that it pertains to the RSQLite compatibility, please let me know directly by email and I will try to work with you to get it resolved quickly.

Future development of cummeRbund will be done on Github:

http://github.com/gofflab/cummeRbund

So feel free to open an issue there or submit any pull requests you may have.

Thanks again for bearing with me, and apologies for not catching this change sooner!

Cheers,
Loyal
lgoff is offline   Reply With Quote
Old 01-22-2015, 05:13 PM   #47
qgong
Junior Member
 
Location: China

Join Date: Apr 2012
Posts: 1
Default

Thanks! I met the same problem and this solution works!

Quote:
Originally Posted by RomaChicken View Post
I think I may have solved problem. And you can try my steps。
First, upgrade biocLite:
>source("http://www.bioconductor.org/biocLite.R")
>biocLite("BiocUpgrade")

Then, install "cummeRbund"
>biocLite("cummeRbund")

Last, install or reinstall "RSQLite"
>biocLite("RSQLite")

I hope it works for you.
qgong is offline   Reply With Quote
Reply

Tags
cummerbund, rna-seq

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 12:33 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO