SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Expected bowtie2 to be in same directory with bowtie2-align nimrod337 Bioinformatics 4 04-11-2015 01:54 PM
Using Bowtie2 for to align paired end reads sewellh Bioinformatics 5 06-05-2014 10:50 AM
Bowtie2: rRNA data from Silva fail to align with Illumina PE reads jyuems Illumina/Solexa 3 05-07-2014 04:26 AM
Bowtie2 is unable to align query sequences that contain an intervening stretch of N's quokka Bioinformatics 2 10-03-2013 12:18 PM
How to align reads to multiple index in bowtie2 ssharma Bioinformatics 3 07-16-2013 03:13 AM

Reply
 
Thread Tools
Old 04-19-2015, 09:24 AM   #1
harijay
Junior Member
 
Location: Cambridge, MA

Join Date: Feb 2015
Posts: 4
Red face Error during bowtie2-align run , (ERR): bowtie2-align exited with value 139

I have a pipleline written in python that calls bowtie2-align. I am using bowtie2-align to align the same fastq.gz file against a set of amplicons.

I am testing the run on three machines with the exact same data

1) Linux box, Ubuntu 14.04 ,48 GB memory , everything works
2) Linux box2 ozy,Ubuntu 14.04 , 32 GB memory , segfaults with err 139
3) Macbook Pro, OSX 10.10.3 , 16 GB memory , everything works

The details of the bowtie2 on the working and non-working Linux box ( both had the same one) are given below.
On Linux box2 ozy, bowtie2-align crashes with the message:

Code:
Segmentation fault (core dumped)
(ERR): bowtie2-align exited with value 139
On this machine , I also tested with a compiled from source bowtie2 ( v 2.2.5 ) and it gave the same error (Value 139).

The command I am using for bowtie2 in all cases is :

Code:
align_cmd = 'bowtie2 --very-sensitive -k 2 -x amplicons -1 %s -2 %s -S initial_aligns.sam' % (read1_fastq, read2_fastq)
Can someone give me pointers on how to troubleshoot why the crash happens on only one machine and not the other two ?.

Thanks
Hari

hari@ozy:~$ bowtie2 --version
/usr/bin/bowtie2-align version 2.1.0
64-bit
Built on roseapple
Tue Jun 25 17:45:14 UTC 2013
Compiler: gcc version 4.8.1 (Ubuntu 4.8.1-4ubuntu2)
Options: -O3 -m64 -msse2 -funroll-loops -g3 -Wl,-Bsymbolic-functions
Sizeof {int, long, long long, void*, size_t, off_t}: {4, 8, 8, 8, 8, 8}



The compiled from source bowtie2 gives same error on Linux box 2:

hari@ozy:~/DEmultiplexed/analysis/VEGF1_S1$ bowtie2 --version
/home/hari/bowtie2-2.2.5/bowtie2-align-s version 2.2.5
64-bit
Built on ozymandias
Sun Apr 19 10:48:02 EDT 2015
Compiler: gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)
Options: -O3 -m64 -msse2 -funroll-loops -g3 -DPOPCNT_CAPABILITY
Sizeof {int, long, long long, void*, size_t, off_t}: {4, 8, 8, 8, 8, 8}

There Linux machines also have different kernel versions.

Working Kernel:
hari@UBUNTU01:~$ uname -a
Linux UBUNTU01 3.16.0-30-generic #40~14.04.1-Ubuntu SMP Thu Jan 15 17:43:14 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux


Segfault kernel:
hari@ozy:~$ uname -a
Linux ozymandias 3.13.0-43-generic #72-Ubuntu SMP Mon Dec 8 19:35:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Last edited by harijay; 04-19-2015 at 09:45 AM.
harijay is offline   Reply With Quote
Old 04-19-2015, 11:36 PM   #2
dpryan
Devon Ryan
 
Location: Freiburg, Germany

Join Date: Jul 2011
Posts: 3,480
Default

The only general way to debug this is to run bowtie2-align-s in a debugger (I think there's a bowtie2-align-debug-s or something like that that can be used for this purpose). I wonder if there's some quirky library on the "ozy" machine that's causing the segfault.
dpryan is offline   Reply With Quote
Old 02-08-2017, 01:24 AM   #3
Apex
Junior Member
 
Location: Denmark

Join Date: Mar 2011
Posts: 4
Default Same issue...

Hi harijay

Were you able to resolve this issue?

I'm having much the same problem. I have recently reinstalled my computer with Ubuntu 16.10 (Kubuntu) and installed Bowtie2 by running:
sudo apt-get install bowtie2

This works well and installs v. 2.2.9-4.

When I try to do an alignment, however I get an error-message after a short while:
Segmentation fault (core dumped)
(ERR): bowtie2-align exited with value 139

This also occurs when I try to rerun a previously made alignment using the same files and same command that worked on a previous installation, so it seems that something is wrong with the current installation. I have also downloaded the pre-compiled v. 2.3.0 but get the same message.

There is actually generated a truncated sam file ending abruptly like this:
...
@SQ SN:ENST00000557887.1 LN:2606
@SQ SN:ENST00000564967.1 LN:2199
@SQ SN:ENST00



Quote:
Originally Posted by harijay View Post
I have a pipleline written in python that calls bowtie2-align. I am using bowtie2-align to align the same fastq.gz file against a set of amplicons.

I am testing the run on three machines with the exact same data

1) Linux box, Ubuntu 14.04 ,48 GB memory , everything works
2) Linux box2 ozy,Ubuntu 14.04 , 32 GB memory , segfaults with err 139
3) Macbook Pro, OSX 10.10.3 , 16 GB memory , everything works

The details of the bowtie2 on the working and non-working Linux box ( both had the same one) are given below.
On Linux box2 ozy, bowtie2-align crashes with the message:

Code:
Segmentation fault (core dumped)
(ERR): bowtie2-align exited with value 139
On this machine , I also tested with a compiled from source bowtie2 ( v 2.2.5 ) and it gave the same error (Value 139).

The command I am using for bowtie2 in all cases is :

Code:
align_cmd = 'bowtie2 --very-sensitive -k 2 -x amplicons -1 %s -2 %s -S initial_aligns.sam' % (read1_fastq, read2_fastq)
Can someone give me pointers on how to troubleshoot why the crash happens on only one machine and not the other two ?.

Thanks
Hari

hari@ozy:~$ bowtie2 --version
/usr/bin/bowtie2-align version 2.1.0
64-bit
Built on roseapple
Tue Jun 25 17:45:14 UTC 2013
Compiler: gcc version 4.8.1 (Ubuntu 4.8.1-4ubuntu2)
Options: -O3 -m64 -msse2 -funroll-loops -g3 -Wl,-Bsymbolic-functions
Sizeof {int, long, long long, void*, size_t, off_t}: {4, 8, 8, 8, 8, 8}



The compiled from source bowtie2 gives same error on Linux box 2:

hari@ozy:~/DEmultiplexed/analysis/VEGF1_S1$ bowtie2 --version
/home/hari/bowtie2-2.2.5/bowtie2-align-s version 2.2.5
64-bit
Built on ozymandias
Sun Apr 19 10:48:02 EDT 2015
Compiler: gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)
Options: -O3 -m64 -msse2 -funroll-loops -g3 -DPOPCNT_CAPABILITY
Sizeof {int, long, long long, void*, size_t, off_t}: {4, 8, 8, 8, 8, 8}

There Linux machines also have different kernel versions.

Working Kernel:
hari@UBUNTU01:~$ uname -a
Linux UBUNTU01 3.16.0-30-generic #40~14.04.1-Ubuntu SMP Thu Jan 15 17:43:14 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux


Segfault kernel:
hari@ozy:~$ uname -a
Linux ozymandias 3.13.0-43-generic #72-Ubuntu SMP Mon Dec 8 19:35:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
Apex is offline   Reply With Quote
Reply

Tags
bowtie2, bowtie2 pipeline, ubuntu server

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 10:08 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO