SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics

Similar Threads
Thread Thread Starter Forum Replies Last Post
plotDEXseq failure- all log2fold values set to NA or NaN vplagnol RNA Sequencing 6 01-18-2013 04:45 AM
Calculating p-values from FPKM? Artur Jaroszewicz Bioinformatics 16 10-25-2012 01:04 PM
What is minimum spanning network? A_Morozov Bioinformatics 0 08-02-2012 12:30 AM
Tophat: find junction spanning reads thurisaz RNA Sequencing 4 11-14-2011 05:23 AM

Reply
 
Thread Tools
Old 11-28-2013, 11:59 PM   #1
zslee
Member
 
Location: shanghai of china

Join Date: May 2009
Posts: 29
Default Defuse Calculating spanning p-values Failure

Hey, could anyone help me with one problem:
when I run defuse to find gene fusions based on fastq data (illumina HISEQ, paired-end, trimed by trimglore), the software goes well until Calculating spanning p-values:

Importing fastq files
Splitting fastq files
Discordant alignments
Read Stats
Fragment mean 182.171678030117 stddev 43.6861609169054
Read length min 20 max 100
Generating discordant alignment clusters
Remove mitochondrial-genomic clusters
Generating maximum parsimony solution
Selecting fusion clusters
Preparing sequences for local realignment
Performing local realignment
Filtering concordant clusters
Generating spanning alignment regions file
Initializing split read alignments
Calculating split read alignments
Evaluating split reads
Calculating spanning stats
Calculating spanning p-values
Failure for defuse command:
/home/local/bin/Rscript ./defuse-0.6.1//scripts/evaluate_fraglength_mean.R ./temp/defuse/concordant.read.stats ./temp/defuse/spanlength.cov 50 ./temp/defuse/splitreads.span.stats ./temp/defuse/splitreads.span.pval.tmp
Reason:
Job command with nonzero return code
Job output:
Running on node4
Rscript execution error: No such file or directory

real 0m0.099s
user 0m0.000s
sys 0m0.003s
Return codes: 255
Commands failed after 1 seconds


when I check I found there is no ./temp/defuse/splitreads.span.pval.tmp produced, what is the reason?
thanks in advance for anyone's reply.

code as bellow:
~/programs/defuse-0.6.1/scripts/defuse.pl -c ~/programs/defuse-0.6.1/scripts/config.txt -1 $inputdir/$file1 -2 $inputdir/$file2 -o $outputdir -p 24
zslee is offline   Reply With Quote
Old 01-31-2014, 04:30 PM   #2
NKAkers
Member
 
Location: New York, NY

Join Date: Sep 2011
Posts: 26
Default

/home/local/bin/Rscript ./defuse-0.6.1//scripts/evaluate_fraglength_mean.R

This is your problem, I believe. The double forward slash betweeen defuse-0.6.1 and scripts.

Check your config.txt file to make sure you named your directories without a slash at the end. ie:

/home/usr/defuse-0.6.1
NOT:
/home/usr/defuse-0.6.1/
NKAkers is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 08:38 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO