SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
MUMmer plot full of dots and no diagonal lines dbob Bioinformatics 3 02-18-2016 07:41 AM
error unable to parse known snp litali Bioinformatics 0 10-06-2015 04:00 AM
Alignment of assembly to reference (nuclear genome) [MUMmer] prs321 Bioinformatics 0 09-10-2013 10:48 AM
How to use the Bioperl to parse the parse flat file of UniProtKB database? bewlib Bioinformatics 1 11-29-2012 04:30 PM
Global Alignment With Mummer (Parameter for Gap Extension & Opening Cost) peveralldubois Bioinformatics 0 03-06-2011 11:45 PM

Reply
 
Thread Tools
Old 07-21-2019, 07:25 AM   #1
powoods
Junior Member
 
Location: Colorado

Join Date: Jul 2019
Posts: 1
Default mummer plot unable to parse alignment file

Hello,

I am currently trying to make a dotplot in order to compare the sequence similarity between a reference genome and an early stage reference genome that my own lab is constructing. The software I am using to do this is called "mummer".

To get an initial feel for how the mummer software works, I aligned one chromosome of the reference genome to itself since this should in theory produce a perfect diagonal line.

The code I used for this was:
mummer Chromosome1.fasta Chromosome1.fasta > Chromosome1.mums

Then to create a dotplot of this alignment file I used the following code:
mummerplot -postscript -p OUTPUT_plot Chromosome1.mums

This code created the perfectly diagonal line dot plot as predicted.

My issue is that when I try to use the same code to align two different sequences, mummerplot is not able to parse the alignment file.

Here is the code I am using:
mummer Chromosome1.fasta Scaffold1.fasta >Chrom1_v_Scaff1.mums
mummerplot -postscript -p OUTPUT_plot Chrom1_v_Scaff1.mums

The following error appears every time I align two different sequences and try to plot the alignment:
gnuplot 5.2 patchlevel 7
Reading mummer file Chrom1_v_Scaff1.mums (use mummer -c)
ERROR: Could not parse Chrom1_v_Scaff1.mums
26869245 25 82

I have tried all the other alignment programs in mummer including "-mum", "-maxmatch" and "-nucmer" and they all give the same error.

I would really appreciate a solution to this issue if anyone has one, thank you.
powoods is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 08:51 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO