SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
bwa quality trimming and samtools rmdup greigite Bioinformatics 7 02-22-2013 04:22 AM
newbler quality trimming Himalaya 454 Pyrosequencing 2 08-22-2012 05:44 AM
BWA errors after quality trimming flipwell Bioinformatics 3 05-21-2012 08:39 PM
Looking for an perl script to quality trimming data tarias Bioinformatics 4 09-21-2011 11:24 PM
Quality trimming fastq 454 data? ewilbanks Bioinformatics 2 04-14-2011 11:45 PM

Reply
 
Thread Tools
Old 11-08-2015, 01:53 AM   #21
Gigiux
Junior Member
 
Location: Germany

Join Date: Nov 2015
Posts: 3
Default

Dear all,
I am new to NGS and I have the kind of same problem as trimmoME 19/7/15.
I am applying trimmomatric to trim fastaq files by quality and to remove the adapters. I have two paired files seq1.1.fq and seq1.2.fq with nextera adapters so I ran the following command:
java -jar trimmomatic-0.33.jar PE -threads 16 -phred64 seq1.1.fq seq1.2.fq pairedOutup1 pairedOutup2 unpairedOutup1 unpairedOutup2 ILLUMINACLIP:NexteraPE-PE.fa:2:30:10:1:true LEADING:5 TRAILING:5 SLIDINGWINDOW:4:15 MINLEN:36

The command is executed with the following display:
Using PrefixPair: 'AGATGTGTATAAGAGACAG' and 'AGATGTGTATAAGAGACAG'
Using Long Clipping Sequence: 'GTCTCGTGGGCTCGGAGATGTGTATAAGAGACAG'
Using Long Clipping Sequence: 'TCGTCGGCAGCGTCAGATGTGTATAAGAGACAG'
Using Long Clipping Sequence: 'CTGTCTCTTATACACATCTGACGCTGCCGACGA'
Using Long Clipping Sequence: 'CTGTCTCTTATACACATCTCCGAGCCCACGAGAC'
ILLUMINACLIP: Using 1 prefix pairs, 4 forward/reverse sequences, 0 forward only sequences, 0 reverse only sequences
Input Read Pairs: 947710 Both Surviving: 0 (0.00%) Forward Only Surviving: 0 (0.00%) Reverse Only Surviving: 0 (0.00%) Dropped: 947710 (100.00%)
TrimmomaticPE: Completed successfully

However all the output files are completely empty.

The first lines of the input are:
{seq1.1.fq}
@M03595:11:000000000-AG58B:1:1101:16029:1738 1:N:0:26
ATTGTTAATCGTAAAGCAATGTTCATTCCGATTGTGGCTGTTGCAAGTTTTATGCTTGTAGGTTATGCTGCAACCGATAAAGAAATGCCGGAAATTAGATCTAATCAAATTGAAGTTC
+
1>A1AF33DD1AA113B11B1GGE3FGEF00EEAG20AFCGH1A111FGGH2G21FHBGB21FG1F11F1101BB//E//1@100D1@B/////BG111BBG11FE111BG111BFGE
@M03595:11:000000000-AG58B:1:1101:14217:1754 1:N:0:26
GTTGGCCATAAGGCTGTTGGTGCGATAGTTAATAATGTGATGGTTCCGATCGATACAAAATTAAATACGGGTGATGTCGTAGAAATCAAGACAAATAAACAGTCACAG
+
1AA11@11C1111BF1GG11A0100A00DF22D22D2D22D21BD1B//B///A/A1110BG111F2A///>//FBFFAFA//21BB1111>000B111@10BF1@11
@M03595:11:000000000-AG58B:1:1101:13810:1764 1:N:0:26
GTTGAGACTGTGGATGGTATCAGCGGGTATTGCATGAGTGAGTTTATAAAACTCTGTTAG
+
...

{seq1.2.fq}
@M03595:11:000000000-AG58B:1:1101:16029:1738 2:N:0:26
TTACTTCAATTTGTTTATTTCTAATTTCCGGCATTTCTTTATCGGTTGCAGCATAACCTACAAGCATATAACTTGCAACAGCCACAATCGGAATGAACATTGCTTTACGATTAACAAT
+
111>>D@31BDF33BB333BAB33DFG3A00A0AFGDGGH2FEA0BE/01110B1111D1A111/0D1222BDG1111B000>0B0/B1////B@11@1BF11GHHFE//FG?1@11B
@M03595:11:000000000-AG58B:1:1101:14217:1754 2:N:0:26
CTGTGACTGTTTCTTTGTCTTGATTTCTTCTACTTCACCCGTATTTAATTTTGTTTCTATCGGTTCCTTCACATTATTAACTATCGCTCCAACTGCCTTATGGCCAAC
+
1>1>13BB1FDF3BBG3BAFG13DFGAF333333D331AA0B0BFG22DDGH2B0B222DA/////12DA1A2DF1DG22AFDGE//0A>11100@0BD1B11/01/>
@M03595:11:000000000-AG58B:1:1101:13810:1764 2:N:0:26
CTAACAGAGTTTTATATTCTCACTCATGCAATACCCGCTGATACCATCCACATTCTCAAC
+

What might be the issue? maybe the quality is so low that all the sequences are removed?
Thank you.
Gigiux is offline   Reply With Quote
Old 11-08-2015, 05:42 AM   #22
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 7,079
Default

Have you checked the FastQC profile for these samples? How did they look?

When something like this happens always start with no or minimal filters/restrictions and see if you get a result. Then start adding filters in afterwards.
GenoMax is offline   Reply With Quote
Old 11-08-2015, 06:08 AM   #23
mastal
Senior Member
 
Location: uk

Join Date: Mar 2009
Posts: 667
Default

I suspect the problem is the -phred64 setting.

I think that if you have samples prepared using the Nextera kits, Illumina had switched to -phred33 quality scores by then.
mastal is offline   Reply With Quote
Old 11-08-2015, 09:00 AM   #24
mastal
Senior Member
 
Location: uk

Join Date: Mar 2009
Posts: 667
Default

Also the order of your output files is incorrect.

Trimmomatic will give you the output files in the following order - forward_paired, forward_unpaired, reverse_paired, reverse_unpaired.
mastal is offline   Reply With Quote
Old 11-24-2015, 09:55 AM   #25
kimseonw
Junior Member
 
Location: Maryland, USA

Join Date: Oct 2015
Posts: 2
Default

Hello. Would you help me to set options for trimmomatic equivalent to fastq_quality_filter -q 20 -p 75. I like to remove reads with less than 75% of Q20 as well as adapter while maintaining paired end. Thanks much.

Last edited by kimseonw; 11-24-2015 at 09:57 AM.
kimseonw is offline   Reply With Quote
Old 11-24-2015, 10:32 AM   #26
mastal
Senior Member
 
Location: uk

Join Date: Mar 2009
Posts: 667
Default

Have a look at the manual.

http://www.usadellab.org/cms/uploads...nual_V0.32.pdf
mastal is offline   Reply With Quote
Old 11-24-2015, 11:14 AM   #27
kimseonw
Junior Member
 
Location: Maryland, USA

Join Date: Oct 2015
Posts: 2
Default

mastal. Sure I do. My understanding is reads containing below certain score can be removed but minimum percentage of certain score may not be removed by Trimmomatic, and I'd like to make sure. Thanks again!
kimseonw is offline   Reply With Quote
Old 09-21-2020, 04:00 PM   #28
ebustosc
Junior Member
 
Location: Bogota Colombia

Join Date: Oct 2018
Posts: 1
Unhappy question

Quote:
Originally Posted by westerman View Post
... And I answered my own question about MAXINFO. It is a (newer) parameter that I don't use. However the manual I am looking at says that there are only two numbers associated with MAXINFO: <targetLength>:<strictness> You seem to have three numbers 0 ... 40 ... 0.5. That could be a problem.
You could tell me: how did you solve it?
I have all three parameters and the manual only talks about two.
When I enter the script it leaves me single base sequences
ebustosc is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 12:58 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO