SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tophat :OSError: [Errno 2] No such file or directory: '/tmp/segment.juncs jiangs Bioinformatics 3 04-19-2014 11:12 AM
TopHat does not recognize or use the designated output directory gwilymh Bioinformatics 2 07-24-2013 11:16 AM
Galaxy: Error Uploading Directory of Files nkline Bioinformatics 2 07-03-2013 06:20 AM
Tophat/Bowtie: Error while flushing and closing output esyl Bioinformatics 0 01-17-2013 07:18 AM
Tophat output BAM file ISIZE Error ghbore RNA Sequencing 2 11-28-2010 11:49 PM

Reply
 
Thread Tools
Old 11-08-2014, 07:32 AM   #1
colaneri
Member
 
Location: Durham

Join Date: Jul 2012
Posts: 30
Default tophat error with output directory

I'm running tophat in a remote server and I having this error message (see below the command and the error)
Can some one tell to me what could be going on?

# LSBATCH: User input
tophat -p 4 --min-intron-length 40 --max-intron-length 2000 --library-type fr-firststrand --no-novel-juncs -G /proj/seq/data/TAIR10_Ensembl/Annotation/Archives/archive-2013-03-06-09-54-25/Genes/genes.gtf -o/--output-dir tophat/Cnaa_rep1 /proj/seq/data/TAIR10_Ensembl/Sequence/Bowtie2Index/genome AGB_SPK_02-2-Cnaa-rep1_SpikeMix1_TAGCTT_L005_R1_001.fastq.gz, AGB_SPK_02-2-Cnaa-rep1_SpikeMix1_TAGCTT_L006_R1_001.fastq.gz
------------------------------------------------------------

Exited with exit code 1.

Resource usage summary:

CPU time : 0.07 sec.
Max Processes : 1
Max Threads : 1

The output (if any) follows:

Traceback (most recent call last):
File "/nas02/apps/tophat-2.0.13/bin/tophat", line 4088, in ?
sys.exit(main())
File "/nas02/apps/tophat-2.0.13/bin/tophat", line 3866, in main
prepare_output_dir()
File "/nas02/apps/tophat-2.0.13/bin/tophat", line 1242, in prepare_output_dir
os.mkdir(output_dir)
OSError: [Errno 13] Permission denied: '/--output-dir/'
colaneri is offline   Reply With Quote
Old 11-08-2014, 08:27 AM   #2
Brian Bushnell
Super Moderator
 
Location: Walnut Creek, CA

Join Date: Jan 2014
Posts: 2,707
Default

Rather than "-o/--output-dir", you need to just use "-o".
Brian Bushnell is offline   Reply With Quote
Old 11-08-2014, 09:03 AM   #3
colaneri
Member
 
Location: Durham

Join Date: Jul 2012
Posts: 30
Default Things get weird

Tx Brian, after change to -o
now I getting this error message
here I have less clue of what is going on

# LSBATCH: User input
tophat -p 4 --min-intron-length 40 --max-intron-length 2000 --library-type fr-firststrand --no-novel-juncs -G /proj/seq/data/TAIR10_Ensembl/Annotation/Archives/archive-2013-03-06-09-54-25/Genes/genes.gtf -o Cnaa_rep1 /proj/seq/data/TAIR10_Ensembl/Sequence/Bowtie2Index/genome AGB_SPK_02-2-Cnaa-rep1_SpikeMix1_TAGCTT_L005_R1_001.fastq, AGB_SPK_02-2-Cnaa-rep1_SpikeMix1_TAGCTT_L006_R1_001.fastq
------------------------------------------------------------

Exited with exit code 1.

Resource usage summary:

CPU time : 0.25 sec.
Max Processes : 1
Max Threads : 1

The output (if any) follows:


[2014-11-08 12:47:39] Beginning TopHat run (v2.0.13)
-----------------------------------------------
[2014-11-08 12:47:39] Checking for Bowtie
Bowtie version: 2.2.1.0
[2014-11-08 12:47:41] Checking for Bowtie index files (genome)..
[2014-11-08 12:47:41] Checking for reference FASTA file
[2014-11-08 12:47:41] Generating SAM header for /proj/seq/data/TAIR10_Ensembl/Sequence/Bowtie2Index/genome
Traceback (most recent call last):
File "/nas02/apps/tophat-2.0.13/bin/tophat", line 4088, in ?
sys.exit(main())
File "/nas02/apps/tophat-2.0.13/bin/tophat", line 3942, in main
params.read_params = check_reads_format(params, reads_list)
File "/nas02/apps/tophat-2.0.13/bin/tophat", line 1837, in check_reads_format
zf = ZReader(f_name, params)
File "/nas02/apps/tophat-2.0.13/bin/tophat", line 1790, in __init__
self.file=open(filename)
IOError: [Errno 2] No such file or directory: ''
colaneri is offline   Reply With Quote
Old 11-08-2014, 09:12 AM   #4
Brian Bushnell
Super Moderator
 
Location: Walnut Creek, CA

Join Date: Jan 2014
Posts: 2,707
Default

Quote:
AGB_SPK_02-2-Cnaa-rep1_SpikeMix1_TAGCTT_L005_R1_001.fastq, AGB_SPK_02-2-Cnaa-rep1_SpikeMix1_TAGCTT_L006_R1_001.fastq
That looks wrong. Are your reads paired? If so, you should be using R1 and R2, and there should NOT be a comma in between, just a space. You are trying to use reads from two different lanes. E.G. the correct input files might look like this:

Quote:
AGB_SPK_02-2-Cnaa-rep1_SpikeMix1_TAGCTT_L005_R1_001.fastq AGB_SPK_02-2-Cnaa-rep1_SpikeMix1_TAGCTT_L005_R2_001.fastq
Brian Bushnell is offline   Reply With Quote
Old 11-08-2014, 09:25 AM   #5
colaneri
Member
 
Location: Durham

Join Date: Jul 2012
Posts: 30
Default technical replicates

Yes they are files from the same library that was sequenced in two different lines. I use the command because the tophat manual.

Using TopHat

Usage: tophat [options]* <genome_index_base> <reads1_1[,...,readsN_1]> [reads1_2,...readsN_2]

I probably get it wrong, but it look to me from there that
reads1_1 and reads N_1 are technical replicates or different fastq files originated from the same library.
colaneri is offline   Reply With Quote
Old 11-08-2014, 09:43 AM   #6
Brian Bushnell
Super Moderator
 
Location: Walnut Creek, CA

Join Date: Jan 2014
Posts: 2,707
Default

You have both a comma and a space. Presumably, you need only one or the other.
Brian Bushnell is offline   Reply With Quote
Old 11-08-2014, 10:41 AM   #7
colaneri
Member
 
Location: Durham

Join Date: Jul 2012
Posts: 30
Default thanks!

Quote:
Originally Posted by Brian Bushnell View Post
You have both a comma and a space. Presumably, you need only one or the other.
However your suggestion looks corrects since the job has not returned any error so far.
How can I be sure that both files were used in the alignment?
colaneri is offline   Reply With Quote
Old 11-08-2014, 10:47 AM   #8
Brian Bushnell
Super Moderator
 
Location: Walnut Creek, CA

Join Date: Jan 2014
Posts: 2,707
Default

The output file will have some reads marked as "read 1" and others marked as "read 2" in the sam bitflag; you can get statistics about pairing rates with samtools flagstat. I think Tophat will also display the pairing rate once it finishes.
Brian Bushnell is offline   Reply With Quote
Old 11-08-2014, 10:57 AM   #9
colaneri
Member
 
Location: Durham

Join Date: Jul 2012
Posts: 30
Default not paired ends

But this is not paired end..
The two fastq are the same library sequenced in two different lines of the flow cell. It is possible to align together two files from the same library in this way?
sorry for all my confusion and thanks a lot for your help
colaneri is offline   Reply With Quote
Old 11-08-2014, 11:00 AM   #10
Brian Bushnell
Super Moderator
 
Location: Walnut Creek, CA

Join Date: Jan 2014
Posts: 2,707
Default

If the reads are single-ended, you should separate them with commas. If the reads are paired, you should separate them with spaces. You can always make things simpler by combining them first:

cat reads_A.fq reads_B.fq > combined.fq

...then run things on the combined file.
Brian Bushnell is offline   Reply With Quote
Old 11-08-2014, 11:08 AM   #11
colaneri
Member
 
Location: Durham

Join Date: Jul 2012
Posts: 30
Default back to the beggining

OK, you are right, the run ended and said that there were problems with pair end. But now I can back to do not understand the previously reported error:

# LSBATCH: User input
tophat -p 4 --min-intron-length 40 --max-intron-length 2000 --library-type fr-firststrand --no-novel-juncs -G /proj/seq/data/TAIR10_Ensembl/Annotation/Archives/archive-2013-03-06-09-54-25/Genes/genes.gtf -o Cnaa_rep1 /proj/seq/data/TAIR10_Ensembl/Sequence/Bowtie2Index/genome AGB_SPK_02-2-Cnaa-rep1_SpikeMix1_TAGCTT_L005_R1_001.fastq, AGB_SPK_02-2-Cnaa-rep1_SpikeMix1_TAGCTT_L006_R1_001.fastq
------------------------------------------------------------

Exited with exit code 1.

Resource usage summary:

CPU time : 0.25 sec.
Max Processes : 1
Max Threads : 1

The output (if any) follows:


[2014-11-08 12:47:39] Beginning TopHat run (v2.0.13)
-----------------------------------------------
[2014-11-08 12:47:39] Checking for Bowtie
Bowtie version: 2.2.1.0
[2014-11-08 12:47:41] Checking for Bowtie index files (genome)..
[2014-11-08 12:47:41] Checking for reference FASTA file
[2014-11-08 12:47:41] Generating SAM header for /proj/seq/data/TAIR10_Ensembl/Sequence/Bowtie2Index/genome
Traceback (most recent call last):
File "/nas02/apps/tophat-2.0.13/bin/tophat", line 4088, in ?
sys.exit(main())
File "/nas02/apps/tophat-2.0.13/bin/tophat", line 3942, in main
params.read_params = check_reads_format(params, reads_list)
File "/nas02/apps/tophat-2.0.13/bin/tophat", line 1837, in check_reads_format
zf = ZReader(f_name, params)
File "/nas02/apps/tophat-2.0.13/bin/tophat", line 1790, in __init__
self.file=open(filename)
IOError: [Errno 2] No such file or directory: ''
colaneri is offline   Reply With Quote
Old 11-08-2014, 11:26 AM   #12
Brian Bushnell
Super Moderator
 
Location: Walnut Creek, CA

Join Date: Jan 2014
Posts: 2,707
Default

Like I said, the problem is here:

001.fastq, AGB_SPK

Remove the space.
Brian Bushnell is offline   Reply With Quote
Old 11-09-2014, 05:41 AM   #13
colaneri
Member
 
Location: Durham

Join Date: Jul 2012
Posts: 30
Default

Quote:
Originally Posted by Brian Bushnell View Post
Like I said, the problem is here:

001.fastq, AGB_SPK

Remove the space.
Brian, I really appreciate your help. I have all the aligments done! thanks a lot.
colaneri is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 03:17 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO