SEQanswers

Go Back   SEQanswers > General



Similar Threads
Thread Thread Starter Forum Replies Last Post
fastq-dump on SRA files harlock0083 Bioinformatics 14 10-18-2018 03:19 AM
SRA to fastq conversion with fastq-dump loses sequences pcantalupo Bioinformatics 13 10-08-2015 04:09 PM
Error in coverting SRA to fastq yixf RNA Sequencing 26 08-09-2015 04:55 PM
SRA to FASTQ ramashankar16 Bioinformatics 5 10-26-2011 03:03 AM
How convert multiple .sra files into .fastq in one go? TuA Bioinformatics 5 05-27-2011 08:32 AM

Reply
 
Thread Tools
Old 09-22-2010, 06:51 AM   #1
xhuister
Member
 
Location: China

Join Date: Apr 2010
Posts: 41
Default How to submit Illimina fastq to SRA?

Hi all,

Does the anybody have experience in Illumina data submission to the Short Read Archive (http://www.ncbi.nlm.nih.gov/Traces/sra)? After reading official documentation (http://www.ncbi.nlm.nih.gov/Traces/s...Guidelines.pdf), I still don't know how to.
I've already created study, experiment and run through the web interface, but I don't know how to upload my read data and link it to the study or run?

Thank you!
xhuister is offline   Reply With Quote
Old 09-22-2010, 02:54 PM   #2
malachig
Senior Member
 
Location: WashU

Join Date: Aug 2010
Posts: 117
Default

If the data is RNA-seq data, then I would recommend creating a GEO submission instead. Then GEO's pipeline automatically creates an SRA submission for you. In my opinion, their instructions and website are more user friendly.
malachig is offline   Reply With Quote
Old 09-23-2010, 04:57 AM   #3
xhuister
Member
 
Location: China

Join Date: Apr 2010
Posts: 41
Default

Quote:
Originally Posted by malachig View Post
If the data is RNA-seq data, then I would recommend creating a GEO submission instead. Then GEO's pipeline automatically creates an SRA submission for you. In my opinion, their instructions and website are more user friendly.
Thank you Malachig. My data is not RNA-seq data, but like that. I mailto the SRA yesterday, now I probably know how to do this but haven't tried yet. The rough steps: First create a RUN module through SRA website, then mailto SRA to ask for a FTP password and upload the data to FTP (not compressed), then they will process the data and update the info for your submission.
xhuister is offline   Reply With Quote
Old 09-23-2010, 05:09 AM   #4
colindaven
Senior Member
 
Location: Germany

Join Date: Oct 2008
Posts: 415
Default

Hi, I found the european ERA staff at the EBI to be very helpful. They had pretty good documentation too, but you need to email the staff there first who provide you with the relevant files, as the style sheets you can download are confusing.

Good luck
colindaven is offline   Reply With Quote
Old 09-23-2010, 07:09 AM   #5
xhuister
Member
 
Location: China

Join Date: Apr 2010
Posts: 41
Default

Quote:
Originally Posted by colindaven View Post
Hi, I found the european ERA staff at the EBI to be very helpful. They had pretty good documentation too, but you need to email the staff there first who provide you with the relevant files, as the style sheets you can download are confusing.

Good luck
Thank you colindaven! I emailed just now, hope it works.

And, I also tried upload the data to FTP, and the SRA did process my reads but error ocurred:

data-load: run file problems data inconsistent - length of reads found do not match experiment: ''HWUSI-EAS1571_0012:8:1:1017:20197'' data inconsistent - failed to load data with interface version 1.0
2010-09-23 09:06:02 data-load: run file problems
data-load: run file problems
data inconsistent - length of reads found do not match experiment: ''HWUSI-EAS1571_0012:8:1:1017:20197''
data inconsistent - failed to load data with interface version 1.0

my read is like this:
@HWUSI-EAS1571_0012:8:61:19449:1260#0/1
GAACGTCATGAACGCAGAGTGGCCTTGCTGCCACGATCCACTGAGATTCAGCCCTTTGTCGCTAAGATTCGG
+HWUSI-EAS1571_0012:8:61:19449:1260#0/1
eeffffffeafffffcefffedfff^cdddeeec`ddddddb`d^`Y`a`bcdda__b]b_cL^Y_Y_^^^_

Maybe I wrote the "flowcell" and "lane" wrongly (as attached). What's the flowcell? (I just know the sequence but know little about the sequencing) From the read header (@HWUSI-EAS1571_0012:8:61:19449:1260#0/1), I think lane=8.
Attached Images
File Type: jpg 1.jpg (30.9 KB, 37 views)
xhuister is offline   Reply With Quote
Old 03-03-2013, 02:22 AM   #6
Ariani_Andrea
Junior Member
 
Location: Pisa

Join Date: Mar 2013
Posts: 1
Default

Quote:
Originally Posted by xhuister View Post
Thank you Malachig. My data is not RNA-seq data, but like that. I mailto the SRA yesterday, now I probably know how to do this but haven't tried yet. The rough steps: First create a RUN module through SRA website, then mailto SRA to ask for a FTP password and upload the data to FTP (not compressed), then they will process the data and update the info for your submission.
Hi xhuister,

so I try to send my reads to the SRA but I have some problem. I make project, sample, experiment and RUN. In the last page of run submission they give me a password and an id for ftp private up-load of my data. I've some problem on up-loading data using FTP. I use ncftp for ubuntu, but it seems it does not works.
Have you some suggestion?
Ariani_Andrea is offline   Reply With Quote
Old 03-03-2013, 09:07 AM   #7
MeganS
Member
 
Location: US

Join Date: Sep 2010
Posts: 14
Default

xhuister, check your read lengths. That is what the error message seems to be indicating. You could also try entering the flowcell as "Illumina:@HWUSI-EAS1571_0012". That is the format I used and it worked.

Ariani_Andrea, try regular "ftp". I have not used ncftp, but I know sftp did not work.
MeganS is offline   Reply With Quote
Old 04-21-2016, 12:39 AM   #8
mcastro
Junior Member
 
Location: Barcelona

Join Date: May 2011
Posts: 7
Default SRA errors uploading fastq files

Hi all,

I was trying to upload several human exomes (fastq files) to SRA but I have several problems and I couldn't obtain and answer from sra so I would like to ask if anybody had the same errors.
I used the SRA submission portal and when I completed all the submission steps I got the following error for several files:
XXX_2.fastq:39969:31:syntax error, unexpected '@', expecting fqENDLINE

I detected that some of the fastq files were created with a different sequencing software which add an extra @ after the multiplexing index in the read names. I removed all these characters and now I got for some files the error:

ile ouudru8m/XXX.fq.gz is not recognized by SP

It seems a problem with the server remote folder (it seems that creates temporal folders as ouudru8m) but I cannot obtain an answer from the sra team and I don't know how to deal with this error. Someone had this problem?

I used the ascp command line tool in order to upload all the files to he remote sra folder.

Thank you very much
mcastro is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 08:37 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO