SEQanswers

Go Back   SEQanswers > Applications Forums > De novo discovery



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ray : Segmentation fault (11) Nagesh De novo discovery 0 04-26-2013 02:07 AM
Pindel Segmentation fault with -Q schönblick Bioinformatics 1 02-18-2013 06:13 AM
gffread segmentation fault gokhulkrishnakilaru Bioinformatics 10 01-28-2013 10:28 AM
soap segmentation fault scami Bioinformatics 6 04-17-2012 06:08 AM
SOAP:segmentation fault Mansequencer Bioinformatics 1 11-19-2010 10:47 AM

Reply
 
Thread Tools
Old 04-26-2013, 02:22 AM   #1
Nagesh
Junior Member
 
Location: Bangalore

Join Date: Apr 2013
Posts: 3
Default Ray : Segmentation fault (11)

Hello,

I am trying to run Ray to do hybrid assembly of Illumina (paired end data) and Roche 454 data. I am running the program on server with 64 cores and 512GB RAM

I ran the sample data in Ray; which is working fine.
When I give my data, the program is producing Contigs.fasta output but, giving error before scaffolding.

I ran the following command
$ mpiexec -n 20 ray-build/Ray -k 31 -p mp_R1_trimmed_q20_p100_clipped.fastq mp_R2_trimmed_q20_p100_clipped.fastq -s 454.fastq -o kmer_31_out

After contig buildng program gave the following fault while scaffolding

*** Process received signal ***
Signal: Segmentation fault (11)
Signal code: Address not mapped (1)
Failing at address: 0x15b710
[ 0] /lib64/libpthread.so.0() [0x3dbd00f500]
[ 1] ray-build/Ray(_ZNK4Read6lengthEv+0) [0x50a9b0]
[ 2] ray-build/Ray(_ZN16MessageProcessor33call_RAY_MPI_TAG_GET_READ_MARKERSEP7Message+0x9f) [0x49c09f]
[ 3] ray-build/Ray(_ZN11ComputeCore10runVanillaEv+0x61) [0x532351]
[ 4] ray-build/Ray(_ZN11ComputeCore3runEv+0x6e) [0x53379e]
[ 5] ray-build/Ray(_ZN7Machine5startEv+0x1697) [0x4487a7]
[ 6] ray-build/Ray(main+0x3a) [0x443bba]
[ 7] /lib64/libc.so.6(__libc_start_main+0xfd) [0x3dbc41ecdd]
[ 8] ray-build/Ray() [0x443a89]
*** End of error message ***
--------------------------------------------------------------------------
mpiexec noticed that process rank 19 with PID 21982 on node pragnya exited on signal 11 (Segmentation fault).
--------------------------------------------------------------------------

I tried to run the program with different number of ranks and kmers. But still stoping at scaffolding stage.

Can anyone please help
Nagesh is offline   Reply With Quote
Old 07-04-2013, 07:27 PM   #2
raw937
Member
 
Location: BC

Join Date: Aug 2010
Posts: 18
Default Ray:segmentation fault (11)

So, a question as
I am having the same problem.
I think its an open mpi error.
Run Top - do you see if all 20 cores are running Ray?

In my case, only one is running causing the error.

Double check and get back to me?

cheers
Rick
raw937 is offline   Reply With Quote
Old 07-04-2013, 08:20 PM   #3
Nagesh
Junior Member
 
Location: Bangalore

Join Date: Apr 2013
Posts: 3
Default RE : Ray : Segmentation fault (11)

Hi,

As you suggested, it is an open mpi fault. But when I run the program I see 20 cores being used for initial period of about 1 hour. The program stops after the contig building. The contigs are not scaffolded because of this error
Nagesh is offline   Reply With Quote
Old 02-02-2017, 04:22 AM   #4
dorix
Member
 
Location: Poland

Join Date: Apr 2012
Posts: 12
Default

Hi,
I have the same problem. Has anyone managed to solve it?

Interesting fact is that I have managed to finish many samples with the same machine, mpi, settings, comparable complexity and size... This one refuses to cooperate.

Regards
dorix is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 04:02 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO