SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
View TopHat output xiaohua Bioinformatics 2 04-11-2012 06:11 PM
TopHat output stonerc RNA Sequencing 3 11-07-2011 01:38 PM
strand of the tophat output liuxq Bioinformatics 0 05-17-2011 06:27 AM
Tophat output - Questions makost Bioinformatics 1 02-21-2011 10:41 AM
Cannot understand Tophat output... Help! gen2prot Bioinformatics 4 05-20-2010 08:05 AM

Reply
 
Thread Tools
Old 02-09-2011, 02:08 AM   #1
rururara
Member
 
Location: montreal

Join Date: Jan 2011
Posts: 31
Default TopHat output

I run bowtie - top hat with my 91bp paired end reads.
There's supposed to be accepted_hits.sam as an output file.
but I got accepted_hits.bam.
i'm a little bit confuse here.
i run this command 'tophat -r <parameter> <ref base name> <reads1> <reads2>'
anyone experienced with that?
thanks!
rururara is offline   Reply With Quote
Old 02-09-2011, 04:13 AM   #2
dnusol
Senior Member
 
Location: Spain

Join Date: Jul 2009
Posts: 133
Default

Hi,

that happened to me too. I think the manual is outdated. BAM files are generated which can be directly used in cufflinks for example.
If needed you can transform BAM to SAM with samtools

HTH,

D.
dnusol is offline   Reply With Quote
Old 02-09-2011, 10:32 PM   #3
rururara
Member
 
Location: montreal

Join Date: Jan 2011
Posts: 31
Default

ok. that means 'that' .BAM file is used for cufflinks program.
so if i want to use it for another program i have to convert into SAM. isn't?
thanks anyway!
rururara is offline   Reply With Quote
Old 02-09-2011, 11:13 PM   #4
Jon_Keats
Senior Member
 
Location: Phoenix, AZ

Join Date: Mar 2010
Posts: 279
Default

most programs will that accept .sam files will take the binary .bam version (ie. the bam format is really just a compressed, to save disk space, version of a sam file)
Jon_Keats is offline   Reply With Quote
Old 02-09-2011, 11:16 PM   #5
rururara
Member
 
Location: montreal

Join Date: Jan 2011
Posts: 31
Default

i did the same thing but still can't visualize my alignment.
unless i index the bam file then won't take the big space.
however IGV doesn't accept .bam.bai format.
rururara is offline   Reply With Quote
Old 02-09-2011, 11:28 PM   #6
Jon_Keats
Senior Member
 
Location: Phoenix, AZ

Join Date: Mar 2010
Posts: 279
Default

to view in IGV you need the .bam file and the indexed .bam.bai file in the same folder. Then in IGV load the .bam file after selecting the appropriate genome. The bai file is an index file used to speed up navigation and queries from IGV on the .bam file.
Jon_Keats is offline   Reply With Quote
Old 02-10-2011, 08:52 AM   #7
Emilie
Member
 
Location: Toronto

Join Date: Nov 2010
Posts: 21
Default

Hi,
If you need the sam file, you can also use the --keep-tmp option when running TopHat.
In the manual on TopHat website: "--keep-tmp : Causes TopHat to preserve its intermediate files produced during the run. By default, they are deleted upon exit."
Emilie
Emilie is offline   Reply With Quote
Reply

Tags
tophat

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 09:28 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO