SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with cummeRbund diffData() Enrique Zudaire RNA Sequencing 4 04-08-2016 08:07 AM
Problem with cummeRbund and RSQLite noplacetoh1de Bioinformatics 9 11-03-2014 02:33 PM
Problem with cummeRbund and RSQLite :( dadada4ever Bioinformatics 3 07-31-2013 10:13 AM
CummeRbund problem in R with segfault vd4mindia Bioinformatics 1 05-30-2013 07:03 PM
CummeRbund problem in R and RSQLite vd4mindia Bioinformatics 0 05-05-2013 03:40 AM

Reply
 
Thread Tools
Old 10-26-2014, 08:58 PM   #1
spzhangmit
Junior Member
 
Location: Boston

Join Date: Aug 2014
Posts: 5
Default having searched all forum and still no solution about my cummeRbund problem. Pls help

Hey guys,

My problem is that I can load cummeRbund, but cann't create the database (cuffData.db was 0bytes). No matter what package I installed, such as RSQLite, DBI, splite3... , or using other output data from cuffdiff downloaded from GEO, still didn't work.

> cuff<-readCufflinks("diff_out")
Creating database diff_out/cuffData.db
Error in FUN(c("\n-- Creator: MySQL Workbench 5.2.33/ExportSQLite plugin 2009.12.02\n-- Author: Loyal Goff\n-- Caption: New Model\n-- Project: Name of the project\n-- Changed: 2012-04-30 22:21\n-- Created: 2011-05-02 12:52\nPRAGMA foreign_keys = OFF", :
could not find function "sqliteQuickSQL"


I am running ubuntu 14.04 LTS. And I think the environment for R and cummeRbund is okay.
> sessionInfo()
R version 3.1.1 (2014-07-10)
Platform: x86_64-pc-linux-gnu (64-bit)

locale:
[1] LC_CTYPE=en_US.UTF-8 LC_NUMERIC=C
[3] LC_TIME=en_US.UTF-8 LC_COLLATE=en_US.UTF-8
[5] LC_MONETARY=en_US.UTF-8 LC_MESSAGES=en_US.UTF-8
[7] LC_PAPER=en_US.UTF-8 LC_NAME=C
[9] LC_ADDRESS=C LC_TELEPHONE=C
[11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C

attached base packages:
[1] grid stats4 parallel stats graphics grDevices utils
[8] datasets methods base

other attached packages:
[1] cummeRbund_2.8.0 Gviz_1.10.1 rtracklayer_1.26.1
[4] GenomicRanges_1.18.1 GenomeInfoDb_1.2.2 IRanges_2.0.0
[7] S4Vectors_0.4.0 fastcluster_1.1.13 reshape2_1.4
[10] ggplot2_1.0.0 RSQLite_1.0.0 DBI_0.3.1
[13] BiocGenerics_0.12.0

loaded via a namespace (and not attached):
[1] acepack_1.3-3.3 AnnotationDbi_1.28.0 base64enc_0.1-2
[4] BatchJobs_1.4 BBmisc_1.7 Biobase_2.26.0
[7] BiocParallel_1.0.0 biomaRt_2.22.0 Biostrings_2.34.0
[10] biovizBase_1.14.0 bitops_1.0-6 brew_1.0-6
[13] BSgenome_1.34.0 checkmate_1.5.0 cluster_1.15.3
[16] codetools_0.2-9 colorspace_1.2-4 dichromat_2.0-0
[19] digest_0.6.4 fail_1.2 foreach_1.4.2
[22] foreign_0.8-61 Formula_1.1-2 GenomicAlignments_1.2.0
[25] GenomicFeatures_1.18.1 gtable_0.1.2 Hmisc_3.14-5
[28] iterators_1.0.7 lattice_0.20-29 latticeExtra_0.6-26
[31] MASS_7.3-35 matrixStats_0.10.3 munsell_0.4.2
[34] nnet_7.3-8 plyr_1.8.1 proto_0.3-10
[37] RColorBrewer_1.0-5 Rcpp_0.11.3 RCurl_1.95-4.3
[40] R.methodsS3_1.6.1 rpart_4.1-8 Rsamtools_1.18.1
[43] scales_0.2.4 sendmailR_1.2-1 splines_3.1.1
[46] stringr_0.6.2 survival_2.37-7 tools_3.1.1
[49] VariantAnnotation_1.12.2 XML_3.98-1.1 XVector_0.6.0
[52] zlibbioc_1.12.0

Please help me! I have spent all this weekends but didn't get anything.

Thank you guys in advance!
spzhangmit is offline   Reply With Quote
Old 10-27-2014, 10:33 AM   #2
axa9070
Member
 
Location: Rochester, NY

Join Date: Oct 2014
Posts: 11
Default

I'm having the exact same problem =[

Error in FUN(c("\n-- Creator: MySQL Workbench 5.2.33/ExportSQLite plugin 2009.12.02\n-- Author: Loyal Goff\n-- Caption: New Model\n-- Project: Name of the project\n-- Changed: 2012-04-30 22:21\n-- Created: 2011-05-02 12:52\nPRAGMA foreign_keys = OFF", :
could not find function "sqliteQuickSQL"



sessionInfo()
R version 3.1.1 (2014-07-10)
Platform: x86_64-w64-mingw32/x64 (64-bit)

locale:
[1] LC_COLLATE=English_United States.1252 LC_CTYPE=English_United States.1252
[3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C
[5] LC_TIME=English_United States.1252

attached base packages:
[1] grid stats4 parallel stats graphics grDevices utils datasets methods base

other attached packages:
[1] cummeRbund_2.8.0 Gviz_1.10.1 rtracklayer_1.26.1 GenomicRanges_1.18.1 GenomeInfoDb_1.2.2
[6] IRanges_2.0.0 S4Vectors_0.4.0 fastcluster_1.1.13 reshape2_1.4 ggplot2_1.0.0
[11] RSQLite_1.0.0 DBI_0.3.1 BiocGenerics_0.12.0

loaded via a namespace (and not attached):
[1] acepack_1.3-3.3 AnnotationDbi_1.28.0 base64enc_0.1-2 BatchJobs_1.4
[5] BBmisc_1.7 Biobase_2.26.0 BiocParallel_1.0.0 biomaRt_2.22.0
[9] Biostrings_2.34.0 biovizBase_1.14.0 bitops_1.0-6 brew_1.0-6
[13] BSgenome_1.34.0 checkmate_1.5.0 cluster_1.15.3 codetools_0.2-9
[17] colorspace_1.2-4 dichromat_2.0-0 digest_0.6.4 fail_1.2
[21] foreach_1.4.2 foreign_0.8-61 Formula_1.1-2 GenomicAlignments_1.2.0
[25] GenomicFeatures_1.18.1 gtable_0.1.2 Hmisc_3.14-5 iterators_1.0.7
[29] lattice_0.20-29 latticeExtra_0.6-26 MASS_7.3-35 matrixStats_0.10.3
[33] munsell_0.4.2 nnet_7.3-8 plyr_1.8.1 proto_0.3-10
[37] R.methodsS3_1.6.1 RColorBrewer_1.0-5 Rcpp_0.11.3 RCurl_1.95-4.3
[41] rpart_4.1-8 Rsamtools_1.18.1 scales_0.2.4 sendmailR_1.2-1
[45] splines_3.1.1 stringr_0.6.2 survival_2.37-7 tools_3.1.1
[49] VariantAnnotation_1.12.2 XML_3.98-1.1 XVector_0.6.0 zlibbioc_1.12.0
>
axa9070 is offline   Reply With Quote
Old 10-27-2014, 05:43 PM   #3
spzhangmit
Junior Member
 
Location: Boston

Join Date: Aug 2014
Posts: 5
Default

Yes, is there anyone know how to fix it?
spzhangmit is offline   Reply With Quote
Old 10-28-2014, 04:08 AM   #4
mandar.bobade60
Member
 
Location: India

Join Date: Jun 2013
Posts: 14
Smile

Please set the Path using setwd("wherever/ur/cuffdiff/result/is") in R
And check once again.
I had got same even though I had mentioned path with:

cuff <- readCufflinks("cuffdiff/output/dir/path")

Since cummerRbund only takes currentpath as input, u need to set that path in R before starting working.

This had resolved my problem.

If this doesn't resolve for you. Then please pardon me.
mandar.bobade60 is offline   Reply With Quote
Old 10-28-2014, 08:25 AM   #5
DonDolowy
Member
 
Location: Freiburg

Join Date: Oct 2012
Posts: 56
Default

I have the same problem and the path is correct.

/Update: Thought it was related to Yosemite, as apparently there are some issues with Rstudio and Yosemite getting the path right. Tried to boot up on my old partition with Mavericks. Same problem, and it worked a couple of weeks ago, so it must be related to either the new cummeRbund update or other packages, that have been updated recently.

Last edited by DonDolowy; 10-28-2014 at 02:34 PM.
DonDolowy is offline   Reply With Quote
Old 10-29-2014, 07:57 AM   #6
sbcn
Member
 
Location: spain

Join Date: Oct 2012
Posts: 16
Default

Same problem here, just updated to the latest version cummeRbund (cummeRbund_2.8.0) and I get an error I didn't get some weeks ago when I last used cuffdiff+cummeRbund:

cuff<-readCufflinks()
Creating database /..../cuffData.db
Error in FUN(c("\n-- Creator: MySQL Workbench 5.2.33/ExportSQLite plugin 2009.12.02\n-- Author: Loyal Goff\n-- Caption: New Model\n-- Project: Name of the project\n-- Changed: 2012-04-30 22:21\n-- Created: 2011-05-02 12:52\nPRAGMA foreign_keys = OFF", :
could not find function "sqliteQuickSQL"

I have a previous version (cummeRbund_2.6.1) loaded on another terminal, and it works fine reading the same data: did anyone manage to figure that out?

Cheers
S.

sessionInfo()
R version 3.1.1 (2014-07-10)
Platform: x86_64-redhat-linux-gnu (64-bit)

locale:
[1] LC_CTYPE=en_US.UTF-8 LC_NUMERIC=C
[3] LC_TIME=en_US.UTF-8 LC_COLLATE=en_US.UTF-8
[5] LC_MONETARY=en_US.UTF-8 LC_MESSAGES=en_US.UTF-8
[7] LC_PAPER=en_US.UTF-8 LC_NAME=C
[9] LC_ADDRESS=C LC_TELEPHONE=C
[11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C

attached base packages:
[1] grid stats4 parallel stats graphics grDevices utils
[8] datasets methods base

other attached packages:
[1] BiocInstaller_1.16.0 cummeRbund_2.8.0 Gviz_1.10.1
[4] rtracklayer_1.26.1 GenomicRanges_1.18.1 GenomeInfoDb_1.2.2
[7] IRanges_2.0.0 S4Vectors_0.4.0 fastcluster_1.1.13
[10] reshape2_1.4 ggplot2_1.0.0 RSQLite_1.0.0
[13] DBI_0.3.1 BiocGenerics_0.12.0

loaded via a namespace (and not attached):
[1] acepack_1.3-3.3 AnnotationDbi_1.28.1 base64enc_0.1-2
[4] BatchJobs_1.4 BBmisc_1.7 Biobase_2.26.0
[7] BiocParallel_1.0.0 biomaRt_2.22.0 Biostrings_2.34.0
[10] biovizBase_1.14.0 bitops_1.0-6 brew_1.0-6
[13] BSgenome_1.34.0 checkmate_1.5.0 cluster_1.15.2
[16] codetools_0.2-8 colorspace_1.2-4 dichromat_2.0-0
[19] digest_0.6.4 fail_1.2 foreach_1.4.2
[22] foreign_0.8-61 Formula_1.1-2 GenomicAlignments_1.2.0
[25] GenomicFeatures_1.18.2 gtable_0.1.2 Hmisc_3.14-5
[28] iterators_1.0.7 lattice_0.20-29 latticeExtra_0.6-26
[31] MASS_7.3-33 matrixStats_0.10.3 munsell_0.4.2
[34] nnet_7.3-8 plyr_1.8.1 proto_0.3-10
[37] R.methodsS3_1.6.1 RColorBrewer_1.0-5 Rcpp_0.11.3
[40] RCurl_1.95-4.3 rpart_4.1-8 Rsamtools_1.18.1
[43] scales_0.2.4 sendmailR_1.2-1 splines_3.1.1
[46] stringr_0.6.2 survival_2.37-7 tools_3.1.1
[49] VariantAnnotation_1.12.2 XML_3.98-1.1 XVector_0.6.0
[52] zlibbioc_1.12.0
sbcn is offline   Reply With Quote
Old 10-29-2014, 08:15 AM   #7
blancha
Senior Member
 
Location: Montreal

Join Date: May 2013
Posts: 367
Default

Who don't you just install the R package RSQLite?
If it's already installed, uninstall it and reinstall it.

The function "sqliteQuickSQL" is found in RSQLite.

When I load cummeRbund, RSQLite is also loaded.
I don't see the package in any of your sessions.
blancha is offline   Reply With Quote
Old 10-29-2014, 08:56 AM   #8
blancha
Senior Member
 
Location: Montreal

Join Date: May 2013
Posts: 367
Default

I now see that in the first post the author specified that he had installed RSQLite. However, I don't see it as being loaded in the session info.

When I load cummeRbund, I get the following message: "Loading required package: RSQLite"

You should post all the messages posted during loading to see if there was an error loading RSQLite.

Last edited by blancha; 10-29-2014 at 10:45 AM.
blancha is offline   Reply With Quote
Old 10-29-2014, 01:29 PM   #9
jthomas5062
Member
 
Location: Florida

Join Date: Jul 2014
Posts: 10
Default

Having the same problem here. When loading cummeRbund everything seems to be go smoothly and then I get the following message at the end of the load:

Warning message:
package 'RSQLite' was built under R version 3.1.2

Disregarding this, I change my path to where the Cuffdiff output files are and execute the following command:
cuff_data<-readCufflinks()

Error:
Creating database /Users/jamesdthomas/Desktop/Mbnl2RNASeq/Cuffdiff/diff_out/cuffData.db
Error in FUN(c("\n-- Creator: MySQL Workbench 5.2.33/ExportSQLite plugin 2009.12.02\n-- Author: Loyal Goff\n-- Caption: New Model\n-- Project: Name of the project\n-- Changed: 2012-04-30 22:21\n-- Created: 2011-05-02 12:52\nPRAGMA foreign_keys = OFF", :
could not find function "sqliteQuickSQL"


It seems like the problem is in RSQLite, although after running "sessionInfo()", I can see that RSQLite_1.0.0 is loaded. I've tried to run these same commands on another RNA-Seq experiment and am getting the same error.

Any thoughts?
jthomas5062 is offline   Reply With Quote
Old 10-29-2014, 01:33 PM   #10
blancha
Senior Member
 
Location: Montreal

Join Date: May 2013
Posts: 367
Default

Try uninstalling RSQLite, reinstalling it, restarting your R session with a new workspace, and reloading cummeRbund.

The warning message about RSQLite shouldn't appear when you reload cummeRbund.

Code:
remove.packages("RSQLite")
install.packages("RSQLite")

Last edited by blancha; 10-29-2014 at 01:36 PM. Reason: Missing quotes around RSQLite.
blancha is offline   Reply With Quote
Old 10-29-2014, 01:36 PM   #11
jthomas5062
Member
 
Location: Florida

Join Date: Jul 2014
Posts: 10
Default

Getting the following messages . . . sorry, super new to R!

> remove.packages(RSQLite)
Error in remove.packages : object 'RSQLite' not found
> install.packages(RSQLite)
Error in install.packages : object 'RSQLite' not found
jthomas5062 is offline   Reply With Quote
Old 10-29-2014, 01:42 PM   #12
blancha
Senior Member
 
Location: Montreal

Join Date: May 2013
Posts: 367
Default

My fault. I edited the post above quickly but you executed the code faster.
Just add the quotes.
Also, the session may need to restart if the package is already loaded.
Execute the second line of code once you have the confirmation the package is properly removed.

Code:
remove.packages("RSQLite")
install.packages("RSQLite")
blancha is offline   Reply With Quote
Old 10-29-2014, 01:43 PM   #13
jthomas5062
Member
 
Location: Florida

Join Date: Jul 2014
Posts: 10
Default

This worked:
> remove.packages('RSQLite')
Removing package from ‘/Library/Frameworks/R.framework/Versions/3.1/Resources/library’
(as ‘lib’ is unspecified)

> install.packages("RSQLite")
trying URL 'http://cran.rstudio.com/bin/macosx/mavericks/contrib/3.1/RSQLite_1.0.0.tgz'
Content type 'application/x-gzip' length 1920084 bytes (1.8 Mb)
opened URL
==================================================
downloaded 1.8 Mb


But, still no dice on getting the package to work in cummeRbund :/
jthomas5062 is offline   Reply With Quote
Old 10-29-2014, 02:21 PM   #14
blancha
Senior Member
 
Location: Montreal

Join Date: May 2013
Posts: 367
Default

Well, I tried reinstalling RSQLite on my system just to check my instructions were correct.
I managed to mess up RSQLite.

I got the following error message when trying to load cummeRbund.
Error : object ‘sqliteQuickSQL’ is not exported by 'namespace:RSQLite'

I was however able to get cummeRbund working properly again after updating from from R-3.1.0 to R-3.1.1, and updating all my packages.

So, while I cannot pinpoint the exact source of the problem, the solution appears to simply make sure that you have the latest version of R, and the latest packages. If necessary, reinstall the packages.

You should really post the error messages posted when loading cummeRbund to make the problem easier to diagnose.

Anyway, I'll get back to work and try to waste less time on seqanswers.com.

Last edited by blancha; 10-29-2014 at 02:24 PM.
blancha is offline   Reply With Quote
Old 10-29-2014, 08:13 PM   #15
BrianU
Member
 
Location: Washington, DC

Join Date: Oct 2012
Posts: 20
Default Same issue

I am glad I'm not the only one pulling my hair out over this issue. I've tried updating to the latest version of R and CummeRbund in both Windows 7 and Ubuntu 12.04. Reinstalled RSQLite a couple times along with it's dependencies. Am I missing something?

Quote:
> library(cummeRbund)
Loading required package: BiocGenerics
Loading required package: parallel

Attaching package: ‘BiocGenerics’

The following objects are masked from ‘packagearallel’:

clusterApply, clusterApplyLB, clusterCall, clusterEvalQ, clusterExport, clusterMap, parApply,
parCapply, parLapply, parLapplyLB, parRapply, parSapply, parSapplyLB

The following object is masked from ‘package:stats’:

xtabs

The following objects are masked from ‘package:base’:

anyDuplicated, append, as.data.frame, as.vector, cbind, colnames, do.call, duplicated, eval, evalq,
Filter, Find, get, intersect, is.unsorted, lapply, Map, mapply, match, mget, order, paste, pmax,
pmax.int, pmin, pmin.int, Position, rank, rbind, Reduce, rep.int, rownames, sapply, setdiff, sort,
table, tapply, union, unique, unlist, unsplit

Loading required package: RSQLite
Loading required package: DBI
Loading required package: ggplot2
Loading required package: reshape2
Loading required package: fastcluster

Attaching package: ‘fastcluster’

The following object is masked from ‘package:stats’:

hclust

Loading required package: rtracklayer
Loading required package: GenomicRanges
Loading required package: S4Vectors
Loading required package: stats4
Loading required package: IRanges
Loading required package: GenomeInfoDb
Loading required package: Gviz
Loading required package: grid

Attaching package: ‘cummeRbund’

The following object is masked from ‘package:GenomicRanges’:

promoters

The following object is masked from ‘package:IRanges’:

promoters

The following object is masked from ‘package:BiocGenerics’:

conditions

> wd <- "/home/brian/diff_out/"
> setwd(wd)

> gtfFile <- "mm10_genes.gtf"
> cuff <- readCufflinks(dir=getwd(), gtfFile=gtfFile, genome="mm10", rebuild=TRUE)
Creating database /home/brian/diff_out/cuffData.db
Error in FUN(c("\n-- Creator: MySQL Workbench 5.2.33/ExportSQLite plugin 2009.12.02\n-- Author: Loyal Goff\n-- Caption: New Model\n-- Project: Name of the project\n-- Changed: 2012-04-30 22:21\n-- Created: 2011-05-02 12:52\nPRAGMA foreign_keys = OFF", :
could not find function "sqliteQuickSQL"

I get no errors loading CummeRbund, only when I try to create an SQLite database using readCufflinks().

Quote:
> sessionInfo()
R version 3.1.1 (2014-07-10)
Platform: x86_64-unknown-linux-gnu (64-bit)

locale:
[1] LC_CTYPE=en_US.UTF-8 LC_NUMERIC=C LC_TIME=en_US.UTF-8 LC_COLLATE=en_US.UTF-8
[5] LC_MONETARY=en_US.UTF-8 LC_MESSAGES=en_US.UTF-8 LC_PAPER=en_US.UTF-8 LC_NAME=C
[9] LC_ADDRESS=C LC_TELEPHONE=C LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C

attached base packages:
[1] grid stats4 parallel stats graphics grDevices utils datasets methods base

other attached packages:
[1] cummeRbund_2.8.0 Gviz_1.10.1 rtracklayer_1.26.1 GenomicRanges_1.18.1 GenomeInfoDb_1.2.2
[6] IRanges_2.0.0 S4Vectors_0.4.0 fastcluster_1.1.13 reshape2_1.4 ggplot2_1.0.0
[11] RSQLite_1.0.0 DBI_0.3.1 BiocGenerics_0.12.0

loaded via a namespace (and not attached):
[1] acepack_1.3-3.3 AnnotationDbi_1.28.1 base64enc_0.1-2 BatchJobs_1.4
[5] BBmisc_1.7 Biobase_2.26.0 BiocParallel_1.0.0 biomaRt_2.22.0
[9] Biostrings_2.34.0 biovizBase_1.14.0 bitops_1.0-6 brew_1.0-6
[13] BSgenome_1.34.0 checkmate_1.5.0 cluster_1.15.3 codetools_0.2-9
[17] colorspace_1.2-4 dichromat_2.0-0 digest_0.6.4 fail_1.2
[21] foreach_1.4.2 foreign_0.8-61 Formula_1.1-2 GenomicAlignments_1.2.0
[25] GenomicFeatures_1.18.2 gtable_0.1.2 Hmisc_3.14-5 iterators_1.0.7
[29] lattice_0.20-29 latticeExtra_0.6-26 MASS_7.3-35 matrixStats_0.10.3
[33] munsell_0.4.2 nnet_7.3-8 plyr_1.8.1 proto_0.3-10
[37] RColorBrewer_1.0-5 Rcpp_0.11.3 RCurl_1.95-4.3 R.methodsS3_1.6.1
[41] rpart_4.1-8 Rsamtools_1.18.1 scales_0.2.4 sendmailR_1.2-1
[45] splines_3.1.1 stringr_0.6.2 survival_2.37-7 tools_3.1.1
[49] VariantAnnotation_1.12.2 XML_3.98-1.1 XVector_0.6.0 zlibbioc_1.12.0
BrianU is offline   Reply With Quote
Old 10-29-2014, 08:56 PM   #16
spzhangmit
Junior Member
 
Location: Boston

Join Date: Aug 2014
Posts: 5
Default

Hey guys,

I have test it in Ubuntu (14.04LTS), Mac, Windows, none of them worked. My R is 3.1.1

For ubuntu OS:

Of course I have installed libxml2-dev and libcurl4-openssl-dev. And I can launched cummeRbund but can not let it works in cuff <-readCufflinks("diff_out") which just gave 0 bytes cuffData.db.

I have tried to install all the dependent packages (including changing the order of the installing for these packages), BiocGenerics, DBI, RSQLite, digest, ggplot2, reshape2, fastcluster, rtracklayer, GenomicFeatures, Gviz.

It seems I was stuck by GenomicFeatures when I wanted to reinstall cummeRbund:

Error : object ‘sqliteQuickSQL’ is not exported by 'namespace:RSQLite'
ERROR: lazy loading failed for package ‘GenomicFeatures’
* removing ‘/usr/local/lib/R/site-library/GenomicFeatures’
ERROR: dependency ‘GenomicFeatures’ is not available for package ‘biovizBase’
* removing ‘/usr/local/lib/R/site-library/biovizBase’
ERROR: dependencies ‘GenomicFeatures’, ‘biovizBase’ are not available for package ‘Gviz’
* removing ‘/usr/local/lib/R/site-library/Gviz’
ERROR: dependency ‘Gviz’ is not available for package ‘cummeRbund’
* removing ‘/usr/local/lib/R/site-library/cummeRbund’

And I can't install GenomicFeatures due to the same problem "Error : object ‘sqliteQuickSQL’ is not exported by 'namespace:RSQLite'"

So, I guess, for me, the problem is sqliteQuickSQL.

How do you think?

Thanks!
spzhangmit is offline   Reply With Quote
Old 10-29-2014, 11:55 PM   #17
RomaChicken
Junior Member
 
Location: China

Join Date: Sep 2013
Posts: 4
Default

Hi, have you found the solution? I also meet the same problem.

Quote:
Originally Posted by spzhangmit View Post
Hey guys,

I have test it in Ubuntu (14.04LTS), Mac, Windows, none of them worked. My R is 3.1.1

For ubuntu OS:

Of course I have installed libxml2-dev and libcurl4-openssl-dev. And I can launched cummeRbund but can not let it works in cuff <-readCufflinks("diff_out") which just gave 0 bytes cuffData.db.

I have tried to install all the dependent packages (including changing the order of the installing for these packages), BiocGenerics, DBI, RSQLite, digest, ggplot2, reshape2, fastcluster, rtracklayer, GenomicFeatures, Gviz.

It seems I was stuck by GenomicFeatures when I wanted to reinstall cummeRbund:

Error : object ‘sqliteQuickSQL’ is not exported by 'namespace:RSQLite'
ERROR: lazy loading failed for package ‘GenomicFeatures’
* removing ‘/usr/local/lib/R/site-library/GenomicFeatures’
ERROR: dependency ‘GenomicFeatures’ is not available for package ‘biovizBase’
* removing ‘/usr/local/lib/R/site-library/biovizBase’
ERROR: dependencies ‘GenomicFeatures’, ‘biovizBase’ are not available for package ‘Gviz’
* removing ‘/usr/local/lib/R/site-library/Gviz’
ERROR: dependency ‘Gviz’ is not available for package ‘cummeRbund’
* removing ‘/usr/local/lib/R/site-library/cummeRbund’

And I can't install GenomicFeatures due to the same problem "Error : object ‘sqliteQuickSQL’ is not exported by 'namespace:RSQLite'"

So, I guess, for me, the problem is sqliteQuickSQL.

How do you think?

Thanks!
RomaChicken is offline   Reply With Quote
Old 10-30-2014, 01:12 AM   #18
RomaChicken
Junior Member
 
Location: China

Join Date: Sep 2013
Posts: 4
Default

I think I may have solved problem. And you can try my steps。
First, upgrade biocLite:
>source("http://www.bioconductor.org/biocLite.R")
>biocLite("BiocUpgrade")

Then, install "cummeRbund"
>biocLite("cummeRbund")

Last, install or reinstall "RSQLite"
>biocLite("RSQLite")

I hope it works for you.
RomaChicken is offline   Reply With Quote
Old 10-30-2014, 03:38 AM   #19
sbcn
Member
 
Location: spain

Join Date: Oct 2012
Posts: 16
Default

I have finally completely uninstalled and re-installed RSQLite as suggested, and it solved the problem!
Although it was loaded in the session previously and it is the same version of the package, now reading in data with "readCufflinks" works...

When I first tried to re-install it, I faced that error message:
"
ERROR: failed to lock directory ‘/nfs/users/test/R/x86_64-redhat-linux-gnu-library/3.1’ for modifying
Try removing ‘/nfs/users/test/R/x86_64-redhat-linux-gnu-library/3.1/00LOCK-RSQLite’

The downloaded source packages are in
‘/tmp/Rtmp7rm8UF/downloaded_packages’
Warning message:
In install.packages(pkgs = pkgs, lib = lib, repos = repos, ...) :
installation of package ‘RSQLite’ had non-zero exit status
"

which is simply solved by removing the "locked" folder, in case you face the same issue:
rm -r /nfs/users/test/R/x86_64-redhat-linux-gnu-library/3.1/00LOCK-RSQLite/

I opened a fresh R session and simply re-installed RSQLite using biocLite:
source("http://www.bioconductor.org/biocLite.R")
biocLite("RSQLite")

Still don't really understand the issue, but well, it works :-)
sbcn is offline   Reply With Quote
Old 10-30-2014, 04:37 AM   #20
BrianU
Member
 
Location: Washington, DC

Join Date: Oct 2012
Posts: 20
Default

Quote:
Originally Posted by RomaChicken View Post
I think I may have solved problem. And you can try my steps。
First, upgrade biocLite:
>source("http://www.bioconductor.org/biocLite.R")
>biocLite("BiocUpgrade")

Then, install "cummeRbund"
>biocLite("cummeRbund")

Last, install or reinstall "RSQLite"
>biocLite("RSQLite")

I hope it works for you.
I tried your solution of uninstalling both and reinstalling, but it didn't work for me. The only thing that I noticed was odd was trying to upgrade bioconductor...

Quote:
R version 3.1.1 (2014-07-10) -- "Sock it to Me"
Copyright (C) 2014 The R Foundation for Statistical Computing
Platform: x86_64-unknown-linux-gnu (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

> source("http://www.bioconductor.org/biocLite.R")
Bioconductor version 3.0 (BiocInstaller 1.16.0), ?biocLite for help
> biocLite("BiocUpgrade")
Error: Bioconductor version 3.0 cannot be upgraded with R version 3.1.0
> biocLite("cummeRbund")
BioC_mirror: http://bioconductor.org
Using Bioconductor version 3.0 (BiocInstaller 1.16.0), R version 3.1.1.
Installing package(s) 'cummeRbund'
also installing the dependency ‘RSQLite’
BrianU is offline   Reply With Quote
Reply

Tags
cummerbund, rna-seq

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 11:54 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO