SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
qualimap rnaseq error Him26 Bioinformatics 4 10-03-2016 05:46 PM
Qualimap Large Standard Deviation shmibble Bioinformatics 4 07-18-2015 11:08 PM
Qualimap - Analyze Regions shmibble Bioinformatics 0 07-16-2015 04:00 AM
qualimap multi morning latte Bioinformatics 0 11-03-2014 05:17 PM
qualimap error biotechkk Bioinformatics 0 08-07-2014 01:54 AM

Reply
 
Thread Tools
Old 09-26-2018, 02:38 AM   #1
SK-N-BE
Member
 
Location: Germany

Join Date: Apr 2018
Posts: 11
Default Running qualimap fails:

I tried to run qualimap: http://qualimap.bioinfo.cipf.es/.
When using the command ./qualimap, I am always getting the following error message:

./qualimap Java memory size is set to 1200M Launching application... OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=1024m; support was removed in 8.0 QualiMap v.2.2.1 Built on 2016-10-03 18:14 java: symbol lookup error: /home/xxx/Softwares/miniconda3/jre/lib/amd64/../../../lib/libX11.so.6: undefined symbol: xcb_wait_for_reply64

What is the problem? Why doesn`t it work as it should? Is it a "java" problem or the file lixX11.so.6?

I got the following answer via researchgate:

"The symbol lookup error is a miniconda3 issue. The Java runtime environment (jre) therein has X11 libraries for managing windows to give a GUI when running a program from command line. Those libraries are looking for a specific set of libraries called XCB and not finding it. This tells me your miniconda3 environment is using Xlib instead of XCB, which makes sense (Xlib is a far more common and robust library than XCB, IMO).
To fix this you should just need to get the XCB libraries added/updated to your miniconda's jre build."

How may I do this?
SK-N-BE is offline   Reply With Quote
Old 09-26-2018, 03:07 AM   #2
GenoMax
Senior Member
 
Location: East Coast USA

Join Date: Feb 2008
Posts: 6,795
Default

I am not sure what the size of BAM file you are trying to use is but you could try adding the option "--java-mem-size=16G" to your qualimap command (Adjust RAM amount as needed). and see if that helps.
GenoMax is offline   Reply With Quote
Reply

Tags
java, miniconda, qualimap

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 06:03 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO