SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samtools fasta line length segfault, redux jdrum00 Bioinformatics 6 06-02-2015 10:58 PM
maq map termiantes with segfault ben8seq Bioinformatics 0 05-17-2011 03:57 AM
bwa bug (?) leading to samtools segfault fpepin Bioinformatics 4 05-03-2011 10:49 AM
cuffdiff segfault Ichinichi Bioinformatics 0 03-05-2010 08:58 AM

Reply
 
Thread Tools
Old 01-26-2012, 11:54 PM   #1
Bukowski
Senior Member
 
Location: UK

Join Date: Jan 2010
Posts: 390
Default Diagnosing samtools segfault

I'm trying to run samtools mpileup on BAM files, part of a tumour/normal pair so I can do some further analysis.

BAM's are aligned with BWA, post-processed with GATK and validated with ValidateSam from Picard. As far as I can tell there is no difference really between the BAM files, except that one causes mpileup to segfault every time.

I don't really know how to diagnose why this is happening - any hints? Errors occuring with Version: 0.1.18 (r982:295) and 0.1.14.
Bukowski is offline   Reply With Quote
Old 01-27-2012, 02:18 AM   #2
nickloman
Senior Member
 
Location: Birmingham, UK

Join Date: Jul 2009
Posts: 356
Default

Sounds like you might need the help of Heng Li (lh3 on here).

But in the meantime you could build samtools with debug flags (you will probably need to edit the Makefile to do this) and then run it through gdb, e.g.

gdb samtools
run "mpileup <other samtools arguments>"

When it segfaults you can then get a backtrace with 'bt'. That will at least show what part of the code is giving the problem.

If it's always happening on a particular alignment you could just filter that line out for now until the problem is fixed.
nickloman is offline   Reply With Quote
Old 11-04-2012, 12:01 PM   #3
Bernt.Popp
Junior Member
 
Location: Germany

Join Date: Feb 2012
Posts: 8
Default

I have the exact same problem with exome BAMs aligned with LifeScope, processed according to GATKs best practices v4 and validated with Picards ValidateSam.
UnifiedGenotyper walks true the files without error, when trying to call the exomes with samtools (Version: 0.1.18 (r982:295) i always get a "Segmentation fault (core dumped)" error.

Is there anything new about this error i.e. a bugfix/workaround?
Bernt.Popp is offline   Reply With Quote
Old 11-04-2012, 11:59 PM   #4
Bernt.Popp
Junior Member
 
Location: Germany

Join Date: Feb 2012
Posts: 8
Default

Apperently the Version in most linux repositorys is old altough it has the same version number. Samtools has moved its repository from Sourceforge to github, where you now can pul the latest Version with all Bugfuxes.
https://github.com/samtools/samtools
--> github clone https://github.com/samtools/samtools
--> make samtools
current Version: Version: 0.1.18-r580
Bernt.Popp is offline   Reply With Quote
Reply

Tags
mpileup, samtools, segfault

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 02:36 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO