SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't make Maq nightsun Bioinformatics 1 12-30-2011 08:24 PM
Installing Newbler 2.5.3 on 64 bit Ubuntu...anyone??? WaltL 454 Pyrosequencing 30 10-30-2011 11:06 PM
help - buffer overflow problem of Maq in Ubuntu 8.10 yuanlang Bioinformatics 12 07-01-2010 04:24 AM
Can't make Maq RockChalkJayhawk Bioinformatics 4 08-24-2009 10:32 AM
maq compile error on Ubuntu baozhi Bioinformatics 1 02-19-2009 01:28 PM

Reply
 
Thread Tools
Old 10-13-2009, 03:06 PM   #1
sbberes
Member
 
Location: Houston TX

Join Date: Jan 2009
Posts: 22
Default Maq make error on Ubuntu 9.04 64 bit

Update: Searching the web found an Unbutu Maq patch that may address the issue.
SBB

Hello bioinformatics gurus,
I am trying to run Maq under vmware fusion using an Unbuntu 64 bit virtual machine on my MacPro. I have the Maq linux 64 bit distribution. When I try to ./configure, make, make install, I get an error 2 message in make. Initially it suggested that maybe I needed to get the latest versions of Autoconf and GNU m4 - which I did. This did not solve the problem. Currently the problem seems to be associated with an inability to find zlib.h. I used the package manager to add the latest version of the zlib dev package, and specifically added zlib.h to my path. However ./configure still does not seem to be able to identify zlib.h, and make fails with the same error message. The ./configure and make output are below. Thanks in advance for any assistance.
S. Beres
Molecular biologist by training--Bioinformaticist by necessity

sbberes@ubuntu:~/Desktop/Bioinformatics/MAQ/maq-0.7.1$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking if gcc accepts -m64... yes
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking zlib.h usability... no
checking zlib.h presence... no
checking for zlib.h... no
configure: creating ./config.status
config.status: creating Makefile
config.status: creating config.h
config.status: config.h is unchanged

sbberes@ubuntu:~/Desktop/Bioinformatics/MAQ/maq-0.7.1$ make
make all-am
make[1]: Entering directory `/home/sbberes/Desktop/Bioinformatics/MAQ/maq-0.7.1'
gcc -DHAVE_CONFIG_H -I. -Wall -m64 -D_FASTMAP -DMAQ_LONGREADS -g -O2 -c main.c
gcc -DHAVE_CONFIG_H -I. -Wall -m64 -D_FASTMAP -DMAQ_LONGREADS -g -O2 -c const.c
gcc -DHAVE_CONFIG_H -I. -Wall -m64 -D_FASTMAP -DMAQ_LONGREADS -g -O2 -c seq.c
gcc -DHAVE_CONFIG_H -I. -Wall -m64 -D_FASTMAP -DMAQ_LONGREADS -g -O2 -c bfa.c
bfa.c:1:18: error: zlib.h: No such file or directory
bfa.c: In function ‘nst_load_bfa1’:
bfa.c:31: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
bfa.c:32: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
bfa.c:33: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
bfa.c:35: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
bfa.c:37: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
bfa.c: In function ‘nst_bfa_len’:
bfa.c:46: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
bfa.c:48: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
make[1]: *** [bfa.o] Error 1
make[1]: Leaving directory `/home/sbberes/Desktop/Bioinformatics/MAQ/maq-0.7.1'
make: *** [all] Error 2

Last edited by sbberes; 10-13-2009 at 05:55 PM. Reason: update information
sbberes is offline   Reply With Quote
Old 10-13-2009, 05:54 PM   #2
nilshomer
Nils Homer
 
nilshomer's Avatar
 
Location: Boston, MA, USA

Join Date: Nov 2008
Posts: 1,285
Default

Quote:
Originally Posted by sbberes View Post
Hello bioinformatics gurus,
I am trying to run Maq under vmware fusion using an Unbuntu 64 bit virtual machine on my MacPro. I have the Maq linux 64 bit distribution. When I try to ./configure, make, make install, I get an error 2 message in make. Initially it suggested that maybe I needed to get the latest versions of Autoconf and GNU m4 - which I did. This did not solve the problem. Currently the problem seems to be associated with an inability to find zlib.h. I used the package manager to add the latest version of the zlib dev package, and specifically added zlib.h to my path. However ./configure still does not seem to be able to identify zlib.h, and make fails with the same error message. The ./configure and make output are below. Thanks in advance for any assistance.
S. Beres
Molecular biologist by training--Bioinformaticist by necessity

sbberes@ubuntu:~/Desktop/Bioinformatics/MAQ/maq-0.7.1$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking if gcc accepts -m64... yes
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking zlib.h usability... no
checking zlib.h presence... no
checking for zlib.h... no
configure: creating ./config.status
config.status: creating Makefile
config.status: creating config.h
config.status: config.h is unchanged

sbberes@ubuntu:~/Desktop/Bioinformatics/MAQ/maq-0.7.1$ make
make all-am
make[1]: Entering directory `/home/sbberes/Desktop/Bioinformatics/MAQ/maq-0.7.1'
gcc -DHAVE_CONFIG_H -I. -Wall -m64 -D_FASTMAP -DMAQ_LONGREADS -g -O2 -c main.c
gcc -DHAVE_CONFIG_H -I. -Wall -m64 -D_FASTMAP -DMAQ_LONGREADS -g -O2 -c const.c
gcc -DHAVE_CONFIG_H -I. -Wall -m64 -D_FASTMAP -DMAQ_LONGREADS -g -O2 -c seq.c
gcc -DHAVE_CONFIG_H -I. -Wall -m64 -D_FASTMAP -DMAQ_LONGREADS -g -O2 -c bfa.c
bfa.c:1:18: error: zlib.h: No such file or directory
bfa.c: In function ‘nst_load_bfa1’:
bfa.c:31: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
bfa.c:32: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
bfa.c:33: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
bfa.c:35: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
bfa.c:37: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
bfa.c: In function ‘nst_bfa_len’:
bfa.c:46: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
bfa.c:48: warning: ignoring return value of ‘fread’, declared with attribute warn_unused_result
make[1]: *** [bfa.o] Error 1
make[1]: Leaving directory `/home/sbberes/Desktop/Bioinformatics/MAQ/maq-0.7.1'
make: *** [all] Error 2

Make sure you have zlib installed.
nilshomer is offline   Reply With Quote
Old 10-14-2009, 01:45 AM   #3
simonandrews
Simon Andrews
 
Location: Babraham Inst, Cambridge, UK

Join Date: May 2009
Posts: 871
Default

Quote:
Originally Posted by sbberes View Post

checking zlib.h presence... no
checking for zlib.h... no


bfa.c:1:18: error: zlib.h: No such file or directory
make[1]: *** [bfa.o] Error 1
As Nilshomer said the problem is the missing zlib.h, however there is a bug in maq as the configure should have failed if this was a requirement.

A quick fix in ubuntu would be:

sudo apt-get install zliblg-dev
simonandrews is offline   Reply With Quote
Old 10-14-2009, 07:36 AM   #4
sbberes
Member
 
Location: Houston TX

Join Date: Jan 2009
Posts: 22
Default Thanks for the advice

Thanks for the prompt feedback. The first thing I did when I got the error messages was check for zlibg and then run an install. However that did not seem to solve the problem. Reran the install this morning and now ./configure finds zlib. Maq make still failed now complaining that the version of autoconf was to new. Was able to solve the problem by installing the latest version of g++ and dependancies.

Again thanks for the assistance.
Steve Beres
sbberes is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 05:03 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO