SEQanswers

Go Back   SEQanswers > Bioinformatics > Bioinformatics



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samtools "is recognized as '*'" "truncated file" error axiom7 Bioinformatics 3 11-26-2014 02:53 AM
"allele balance ratio" and "quality by depth" in VCF files efoss Bioinformatics 2 10-25-2011 11:13 AM
The position file formats ".clocs" and "_pos.txt"? Ist there any difference? elgor Illumina/Solexa 0 06-27-2011 07:55 AM
"Systems biology and administration" & "Genome generation: no engineering allowed" seb567 Bioinformatics 0 05-25-2010 12:19 PM
SEQanswers second "publication": "How to map billions of short reads onto genomes" ECO Literature Watch 0 06-29-2009 11:49 PM

Reply
 
Thread Tools
Old 11-15-2010, 09:05 AM   #1
James
Member
 
Location: Cardiff

Join Date: Mar 2010
Posts: 23
Default another tophat "could not execute prep_reads" error

Hi,

Im getting this error:
Code:
tophat -o RNA-seq-14.11.10/tophat_out_0H -G maygtf.gtf --no-novel-juncs --solexa1.3-quals indexes/_May_2009-masked reads/RNA-seq/R43s_1_sequence_0H.fastq


[Mon Nov 15 12:52:59 2010] Beginning TopHat run (v1.1.0)
-----------------------------------------------
[Mon Nov 15 12:52:59 2010] Preparing output location RNA-seq-14.11.10/tophat_out_0H//
[Mon Nov 15 12:52:59 2010] Checking for Bowtie index files
[Mon Nov 15 12:52:59 2010] Checking for reference FASTA file
[Mon Nov 15 12:52:59 2010] Checking for Bowtie
	Bowtie version:			 0.12.7.0
[Mon Nov 15 12:52:59 2010] Checking for Samtools
	Samtools version:		 0.1.9.0
[Mon Nov 15 12:52:59 2010] Checking reads
	min read length: 36bp, max read length: 36bp
	format:		 fastq
	quality scale:	 phred64 (reads generated with GA pipeline version >= 1.3)
[Mon Nov 15 12:55:49 2010] Reading known junctions from GTF file
	[FAILED]
Error: could not execute prep_reads
I check the log file for prep_reads it has:

prep_reads v1.1.3 (1680)
---------------------------
prep_reads: unrecognized option `--gtf-annotations'

Anybody had this error? or can help? Thanks James
James is offline   Reply With Quote
Old 11-16-2010, 10:19 AM   #2
SongLi
Member
 
Location: Durham

Join Date: Oct 2010
Posts: 19
Default

I got the same error for my dataset today, without those options:

tophat -o Mytophat_out -G mygtf.gtf indexes/myindex reads/myreads.fasta

The error message is :

[FAILED]
Error: could not execute prep_reads


and in the prep_reads.log is:

prep_reads v1.1.3 (1680)
---------------------------
somedir/prep_reads: unrecognized option `--gtf-annotations'


Hope someone can help.


Quote:
Originally Posted by James View Post
Hi,

Im getting this error:
Code:
tophat -o RNA-seq-14.11.10/tophat_out_0H -G maygtf.gtf --no-novel-juncs --solexa1.3-quals indexes/_May_2009-masked reads/RNA-seq/R43s_1_sequence_0H.fastq


[Mon Nov 15 12:52:59 2010] Beginning TopHat run (v1.1.0)
-----------------------------------------------
[Mon Nov 15 12:52:59 2010] Preparing output location RNA-seq-14.11.10/tophat_out_0H//
[Mon Nov 15 12:52:59 2010] Checking for Bowtie index files
[Mon Nov 15 12:52:59 2010] Checking for reference FASTA file
[Mon Nov 15 12:52:59 2010] Checking for Bowtie
	Bowtie version:			 0.12.7.0
[Mon Nov 15 12:52:59 2010] Checking for Samtools
	Samtools version:		 0.1.9.0
[Mon Nov 15 12:52:59 2010] Checking reads
	min read length: 36bp, max read length: 36bp
	format:		 fastq
	quality scale:	 phred64 (reads generated with GA pipeline version >= 1.3)
[Mon Nov 15 12:55:49 2010] Reading known junctions from GTF file
	[FAILED]
Error: could not execute prep_reads
I check the log file for prep_reads it has:

prep_reads v1.1.3 (1680)
---------------------------
prep_reads: unrecognized option `--gtf-annotations'

Anybody had this error? or can help? Thanks James

Last edited by SongLi; 11-16-2010 at 10:21 AM.
SongLi is offline   Reply With Quote
Old 11-16-2010, 12:30 PM   #3
James
Member
 
Location: Cardiff

Join Date: Mar 2010
Posts: 23
Default

I fixed this problem. It may have been two things:

It may have been calling an older prep_reads I had lurking in my path.

It said I was calling tophat v1.1.0 even though I downloaded v1.1.3. I just re-downloaded the binaries and replaced them. Now it tells me I'm running v1.1.3.

I'm running Mac OSX 10.5.8. by the way.
James is offline   Reply With Quote
Old 11-16-2010, 12:44 PM   #4
SongLi
Member
 
Location: Durham

Join Date: Oct 2010
Posts: 19
Default

Thank you James,

However, it may not be the reason, because in the log file you posted, it says v1.1.3 there.

I still have the problem on my side.



Quote:
Originally Posted by James View Post
I fixed this problem. It may have been two things:

It may have been calling an older prep_reads I had lurking in my path.

It said I was calling tophat v1.1.0 even though I downloaded v1.1.3. I just re-downloaded the binaries and replaced them. Now it tells me I'm running v1.1.3.

I'm running Mac OSX 10.5.8. by the way.
SongLi is offline   Reply With Quote
Old 11-16-2010, 01:27 PM   #5
SongLi
Member
 
Location: Durham

Join Date: Oct 2010
Posts: 19
Default

Hi James,

Since you have solved the problem, would you mind post what the messages you get when the read RTF file passed?

On my side the error is:
[Tue Nov 16 17:02:17 2010] Reading known junctions from GTF file
[FAILED]
Error: could not execute prep_reads

That may help me to figure out what's wrong in my case.
Thanks,



Quote:
Originally Posted by James View Post
I fixed this problem. It may have been two things:

It may have been calling an older prep_reads I had lurking in my path.

It said I was calling tophat v1.1.0 even though I downloaded v1.1.3. I just re-downloaded the binaries and replaced them. Now it tells me I'm running v1.1.3.

I'm running Mac OSX 10.5.8. by the way.
SongLi is offline   Reply With Quote
Old 11-17-2010, 03:03 AM   #6
oliviera
Member
 
Location: germany

Join Date: Apr 2010
Posts: 31
Default

I have the same problem with tophat 1.1.3, and do not manage to solve the problem.

I used :
./tophat --solexa1.3-quals --no-novel-juncs -G Danio_rerio.Zv9.60.gtf -o /5cq15 Danio_rerio.Zv9.60 5.fastq

the log file is the same as yours:
prep_reads v1.1.3 (1680)
---------------------------
/home/olivier/src/illumina_software_version/tophat_113/bin/prep_reads: unrecognized option '--gtf-annotations'

Funny thing however in the gtf_juncs log file: seems to do something their
gtf_juncs v1.1.3 (1680)
---------------------------
Extracted 218405 junctions from /Danio_rerio.Zv9.60.gtf

I tried gtf and gff format and both failed.
When I run without -G option it works fine...
Any feedback would be much appreciated

Cheers

Oliviera
oliviera is offline   Reply With Quote
Old 11-17-2010, 03:29 AM   #7
oliviera
Member
 
Location: germany

Join Date: Apr 2010
Posts: 31
Default

I just tested the new release 1.1.4 and now the problem seems to be fixed!
Thanx a lot


Oliviera
oliviera is offline   Reply With Quote
Old 11-17-2010, 04:49 AM   #8
SongLi
Member
 
Location: Durham

Join Date: Oct 2010
Posts: 19
Default

Thank you TopHat team for the timingly fix!

Don't know where to post, so I just post here.

Quote:
Originally Posted by oliviera View Post
I just tested the new release 1.1.4 and now the problem seems to be fixed!
Thanx a lot


Oliviera
SongLi is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 08:13 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO