SEQanswers

Go Back   SEQanswers > Applications Forums > De novo discovery



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bowtie out of memory Palgrave Bioinformatics 6 03-04-2014 06:33 PM
Bowtie memory error polsum Bioinformatics 2 12-02-2011 12:17 PM
cufflinks memory allocation error. billthebrute RNA Sequencing 3 10-06-2011 06:00 AM
bug in memory allocation in cuffdiff with bias correction biterbilen Bioinformatics 0 06-03-2011 09:18 AM
Picard MergeSamFile Memory Increase qqcandy Bioinformatics 1 07-14-2010 06:32 AM

Reply
 
Thread Tools
Old 04-01-2013, 09:04 PM   #1
ataraxia
Junior Member
 
Location: Australia

Join Date: Feb 2013
Posts: 7
Default Trinity: option to increase bowtie memory allocation

Hi all,
I have pair-end data that I am currently analysing using Trinity.

I am now running the following script provided by Trinity to estimate abundance:

run_RSEM_align_n_estimate.pl --seqType fq --SS_lib_type RF --left seq1.fq --right seq2.fq --thread_count 16 --prefix /output/RSEM --transcripts Trinity.fasta

and although I get all the output files, I get errors in the log:

Warning: Exhausted best-first chunk memory for read X; skipping read
(or around 11000 reads)

# reads processed: 188565323
# reads with at least one reported alignment: 82758840 (43.89%)
# reads that failed to align: 105806483 (56.11%)
Reported 225985477 paired-end alignments to 1 output stream(s)
[bam_sort_core] merging from 335 files...


From my understanding, you can play with the following setting in Bowtie (--chunkmbs) to increase memory requirements for alignment.

But is there any possibility to do so using the perl script provided in Trinity (run_RSEM_align_n_estimate.pl)? Or should I analyse my data with RSEM directly, as it offers a --bowtie-chunkmbs option?
ataraxia is offline   Reply With Quote
Old 04-17-2013, 06:38 PM   #2
lzsph
Member
 
Location: China

Join Date: Jul 2012
Posts: 13
Default

UPDATED:

Go to the trinityrnaseq_r2013-02-05/trinity-plugins/rsem folder, find a script named "rsem-calculate-expression", open it with a text editor, at line 30, there is
Quote:
my $chunkMbs = 0;# 0 = use bowtie default
, change the "0" to "200" or other integer, then save it. It means it add the --chunkmbs in the command when you run the
Quote:
run_RSEM_align_n_estimate.pl
, I ran the script again after edit the script, it appeared like this:

Quote:
bowtie -q --phred33-quals -n 2 -e 99999999 -l 25 -I 1 -X 1000 --chunkmbs 200 -p 4 -a -m 200 -S TRANS -1 Ms-1-1_R1.fastq -2 Ms-1-1_R2.fastq | /Users/lzsph/scripts/trinityrnaseq_r2013-02-25/util/RSEM_util/../../trinity-plugins/rsem/sam/samtools view -S -b -o RSEM.temp/RSEM.bam -
[samopen] SAM header is present: 192875 sequences.
# reads processed: 20000000
# reads with at least one reported alignment: 16275899 (81.38%)

No warning message appeared.


Before I edit the script mentioned above, I also found this QA here (http://sourceforge.net/mailarchive/f...tyrnaseq-users), they said re-run the program may solve this problem. But when I reran the perl script, still the same problem, maybe my personal computer has a lower RAM (Mid-2011 iMac, 8GB RAM). I also Googled a lot, so I want to add the --chunkmbs in the script.

Hope it helps.

Regards,
-s

Last edited by lzsph; 04-17-2013 at 06:41 PM.
lzsph is offline   Reply With Quote
Old 04-23-2013, 04:48 PM   #3
ataraxia
Junior Member
 
Location: Australia

Join Date: Feb 2013
Posts: 7
Default

Thanks lzsph,
This fixed my problem.
ataraxia is offline   Reply With Quote
Reply

Tags
bowtie, trinity

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 10:14 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Single Sign On provided by vBSSO